Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

This topic was also explained at the FAQ on GitHub:

data ending up on Google servers. Unfortunately, this also affects encrypted backups done via Seedvault as the opt-out is enforced by the system.
It is not yet widely known that backups can now be encrypted with a device key and even Google claims that it can not access backup data [audit]. Instead of opting out completely, app developers can say that their app should only get backed up, if the backup is encrypted.
So if you are annoyed that your favorite app is not included in backups, you can contact the app’s developers and make them aware of this option. For example, this is how the Transportr app enabled only encrypted backups.
However, keep in mind that some security critical apps such as Signal or Briar might still have good reasons to opt-out of backup completely.

But AFAIK, the apk (installation) files are still backuped and can later be restored. Just without user-related data.
But neverthless I hope too for a possibility to backup every app in the future :wink:

The idea is AFAIK a more secure and faster upgrade process: If your FP3 is installing an update, it’ll install it on the inactive slot while you’re still able to use your device. After the installation is finished, you just have to restart your FP3 an it’ll switch the slots to the previously inactive slot (where the new update is installed).
If there’s was issue while updating and your FP3 won’t restart after the update, you still have a working OS on the other slot. If your OS fails to restart several times, it’ll - to my recollection - switch to the other slot and try booting from there. But I’m not very into thhe A/B slot topic. Some others might be able to tell you more accurate informations :wink:

Unlocking the bootloder would wipe your data, of course. So this is not a practical way…
Maybe you could wait until @kinjiru tries to do an update?
Since I have rooted my FP3 I can’t try it, of cource…

Cool! I’d love to hear you feedback if it worked or not :grinning:

Correct. But if I remember correctly, the “App backup” option (to also backup apk) was disabled by default in Seedvault settings, and I enabled it manually.

@os01 and @HolosericaCaligo:
I just tried the update using the Updater app for an OTA from 2021-01-04 to 2021-01-18, and this went smoothly on my FP3+ with locked bootloader :smiley:

Apps and user data all still there, and also the F-Droid privileged extension and UnifiedNLP priv-apps I had installed on system (using adb push, with the OTA survivor scripts and permission files from the zips)

Just for fun I dumped logcat before and after reboot, to get a glimpse of what happens in the background.

1 Like

Thanks for your reply. :slight_smile:

Sadly, the system image is signed, but not the recovery.

29 posts were split to a new topic: :fr: Questions sur LineageOS

Any news on this? It’s still happening with LOS from Jan 11.
I also opened an issue on the LOS issue tracker If I can help somehow, with logs or the like, just ask

I like that wording “express your thanks to the maintainer by means of hard currency”, but sadly I am one of the few who refuse using Paypal, which is the only option offered at the Ko-Fi page. So what can I do? I could write a private message to dk1978, but I rather put this question on the forum believing there would be other fairphoners not using paypal. Maybe Ko-Fi could add the possibility of direct bank transfer.


As I don’t use LineageOS (yet) on my FP3+ this is a bit off-topic, but I have to put a big Thank You because you mentioned this:

The missing double-tap-to-wake-feature was a big annoyance for me; seems like this app is the solution (if the always-active proximity sensor drains the battery not too much, let’s see).

So, back to topic :wink:

This is already a very long topic, could a moderator please move all the non-English posts to a new language orientated topic.


Yeah, good point, I moved those posts.


I ordered a FP3+ with /e/ preinstalled but I had to return it because I encountered noticeable screen lags when scrolling simple websites. See Lag / Inconsistent Framerate (#2077) · Issues · e / Backlog · GitLab for more background. (As a “workaround”, it’s possible to change the performance setting to the highest values but I don’t think that’s great for battery life…)

Now I’m curious to know whether anyone here has similar issues because I’m considering buying a (regular) FP3+ and flashing LOS 17.1+microG. So I wonder whether this problem is specific to to the /e/ fork.

Purely subjective, but in my experience scrolling websites on my FP3+ does show an inconsistent framerate on LOS17.1.
I don’t remember noticing such lags during the few weeks using stock FPOS 10.

Setting performance profile from balanced to performance does seem to help, even for scrolling up and down in the settings app.

In the /e issue you posted I see some patches are mentioned (scheduler/governor), don’t know if this could be a thing for LOS too?

Just try scrolling this thread here. I see a very noticeable lag both in the preinstalled browser and in Firefox. (My post was a little bit simplified. I’m returning it both I still have it here on my desk, so I could try this out now…)

Yeah, I’m the one who mentioned these commits there, but I haven’t received a response. I think these commits are in LOS too. They looked suspicious to me because they’re related to power (and setting the power setting is a workaround) plus they’re related to scrolling. To be honest I have no real idea, but judging from the commit messages I believe some of this code controls the CPU power mode when scrolling, so this could be relevant.


Yes, I see this in the settings app too. Just not as as terrible as in the browser.

FPOS n est pas vraiment stable beaucoup de beugs

Dans ce forum, nous avons tendance à respecter la langue d’un sujet choisi par le premier post. Les sujets multilingues sont marqués comme tels.
Nous n’imposons pas absolument cela, mais cela rend les sujets plus faciles à lire pour tout le monde.

Des traducteurs sont disponibles en ligne.
(J’ai utilisé pour ce texte, puisque je ne parle pas français, désolé pour cela).

mon ordinateur traduit tout automatiquement , google translate automatiquement

C’est bien pour vous, mais n’imposez pas cela aux autres :wink: .

je ne dis pas cela pour vous informer mais en quelle langue dois je poster ? en anglais ? je m en excuse

This topic here is in English, but as I said we usually go by the language used in the first post of a topic. Non-English topics have a language tag, like French ones for example …

You’ll find topics tagged with more than one language, too, these are multilingual then.


Want to thank the developers of the official Lineage ROM! Installation was smooth and I’ve been running the OS for the last two weeks without any problems. I had to change bootslots (fastboot --set-active=b && fastboot flash boot_b boot.img) and after that installation was a breeze. The first update came in last week and installed without issues. Been running without Gapps as well.

For others, I created a Whatsapp backup on my old phone, but restoring it is pain without a Google account. So I’ve documented it before (2 years ago) and used almost the same procedure this time (step 4 is manual this time) after installing WhatsApp:

  1. Problem: restore fails, the file date is 1970 and WhatsApp reports the size as 0kb
  2. Manually create the directory: Internal shared storage/WhatsApp/Databases/
  3. Place only two files in this directory, replace * with 12 or the number depending on your files/version
    msgstore-2021-01-01.1.db.crypt* (the newest backup file)
  4. Give Whatsapp permission to access contacts and media. On my previous Phone Whatsapp asked permission, this time I had to manually give permission through the Android settings because WhatsApp didn’t ask anything after running it.

Once again, thank you @dk1978 for all the effort!

I’ve been using LOS 17.1 for microG since it got available (around the 10th of january).
So far it’s very stable :smiley:

There are a few issues I wanted to share (although the first one is related to Magisk/rooting):

  • When FP3 is rooted, sometimes while using calling function, either with Signal/WhatsApp or if you’re trying to call someone directly after that over the normal cellular network, the whole OS is crashing. The display goes black and I always have to force it to boot into bootloader (Power button + Vol. down button) to start the OS from there.
    Until now, this behaviour never occured without root.

  • One issue that was already mentioned here is the Night Light that doesn’t work for me either.

  • If VoLTE is activated, I still can’t see the name/number of the caller (“Unknown number/caller”). This issue exists since I upgraded my FP3 to Android 10 (original OS) but seems to be solved in the meantime or at least no occuring that much since the 0066 update.

This issue and some ghost touches that are occuring lately (which seem to be fixed with the latest 0077 update) leads me to the question wheter you’re planning to integrate those (i guess) firmware files or not? Or do we have to patch them seperately?

1 Like