English

Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

Is there a way “someone” could raise the build frequency?

1 Like

You may want to ask that here:

I am on Lineage OS for microg on my FP2. I flash it once a month when it is available.
I still do not have a FP3. :slight_smile:

Meanwhile, I installed LOS (with Google, no Magisk, though that might change at some point).
The link in the LOS-Wiki for unlocking the Bootloader is not linking to the correct procedure. The one that worked for me is located here:


Other than that, it was really nice to install the image. It went smooth and I have not yet encountered any issues.

One suggestion for the initial setup: Please allow for mobile data to be disabled instead of being forced to select a mobile data sim card. I do not have mobile data and I don’t really want it to connect at all. In the original FOS, this was an option that I really appreciated.

Thanks for all the work you put in already and your continued efforts for bringing use LOS 17. That is really cool. :slight_smile:

3 Likes

+1 for latest (official) LineageOS for microG (version 17.1 as of this writing) support for the FP3!

In fact, it is a must before I consider buying a (new) phone, because I do not want or trust any other Android solution on our smartphones (that goes for the whole family).

There is just nothing else than LOS for microG + F-Droid + Aurora Store + Magisk + AdAway (systemless via Magisk) + Bromite SystemWebview + Bromite web browser thinkable for us.

I just tried that too. But my phone refused to boot LOS or TWRP. I got that “your device is corrupt” warning.
So I unlocked my bootloader again, installed TWRP and restored my backup.
I wonder how you made it :thinking:

So we would have downgrade the modem (?) firmware in order to get this working again. Or of course updating the firmware as soon as fairphone releases a fix?
Is there a possibility to get such firmware fixes directly with a LOS update?

2 Likes

Hello ! :slight_smile:
In my attempts to get more in control of what my telephone does i reached the point of installing Lineage OS on my Fairphone 3.
Previouslly to this i update from Android 9 to Android 10 (Fairphone OS) and afterwards i tried /e/ os but i was not too happy with it.
I have now installed Lineage OS 16 succesfully. I got a small surprise with the camera which does not seem to work. I suspect this is due to the fact that i have upgraded recently my camera module to the 48MP version which is standardly in FP3+.
With the standard app (com.android.camera2) i just get the messege “Camera stopt steeds”.
I tried Open Camera but that also does not work.
Is there anything i can do to get the camera to work ?

Indeed.

Either reinstall the old modules or wait until Christmas for LOS 17.1:


(or reinstall /e/ or FPOS under which the new modules should work)

Mmmm think i will wait…just get it done before Christmas so i can make nice pictures with my familly, ok?

:)) joking a bit of course:) thanks for the support !

5 Likes

Which ROM have you running? The official LOS one? Did you add any packages (gapps, magisk, …)?

For me the locking works fine with /e/ and the official LOS. In fact, I dont understand how it could not work, since:

  • secure-boot is disabled -> SBL is not verified
  • LOS disables verity mode -> partition hashes are not checked

But obviously I am missing something :slight_smile:
Did you check the checksum of the image before you flashed it? Perhaps it was corrupted?

FYI, in the meantime I have built my own LOS version (based on the official version), that:

  • is signed with my own keys (instead of the google test keys)
  • enables verity mode (disabled in LOS)
  • creates a ‘user’ build (instead of ‘userdebug’)

Works like a charm, all with locked boot loader!

1 Like

@AnotherElk
Thanks! But it was a different error message - I had no possibility to force to boot the system.
There was something written like “your device/system is corrupt. the system can’t be booted […]"
EDIT: Here’s an image:

Sorry, I forgot to mention that. I’m using LOS + microG and Magisk.
But I just found a little note at the FAQ-section on the microG website:

Do you use test keys?
Heck, no! We sign all our builds with our own private keys.

So that might be the reason?
But I don’t think so since you were able to lock the bootloader with your own LOS build which is signed with your own private keys…

After flashing/booting TWRP, I always got that error message. Only the bootloader was working. But after I locked the bootloader again, the exact same image of TWRP was working again.
But I’ll try it again tomorrow.

That was a wrong memory, I just tried it again:

  • After unlocking the bootloader, the command fastboot boot twrp-3.4.0-0-FP3.img fails with FAILED (remote: Partition flashing is not allowed)

  • The command fastboot boot twrp-3.4.0-0-FP3.img fails with FAILED (remote: unlock device to use this command)

  • Booting to system or recovery ends with the mentioned error screen.

Huge thanks for the LineageOS release for FP3. I installed it last week and it works flawlessly.

This week I got a notification that a new update was available. Already? I understand from the Updater (pic related) that this is the new weekly build, dated Nov 30. Is it going to prompt me to update every week? Should I update every week?

I updated the operating system of my previous LineageOS devices a few times a year tops, is that bad practice?

When I was using LOS on my FP2 I only installed the one update per month that contained the security fixes and left out all the others.
For that I checked https://download.lineageos.org/FP2/changes/

For lineage-17.1-20201113-nightly-FP2-signed.zip it says:

Bump Security String to 2020-11-05

5 Likes

You should be able to set that notification time to a month in the three-dots menu of the updater (though that never worked on my FP2, I hope it’ll work for you).

Whether you should… I think updating once a month for the security patches is optimal and already good enough.

All depends on what you call “bad”. I don’t think it’s “bad”, but it’s always better to keep your phone sort of updated.

Btw., welcome to the forum :wink:

Edit: Ingo was a few minutes faster :wink:

2 Likes

When you say “After unlocking the bootloader” you meant in fact “After locking the bootloader”?

You cannot flash TWRP when the boot loader is locked, that is the purpose of locking the boot loader - preventing someone else to flash a modified image to your phone without data loss.

You need to:

Good luck!

1 Like

You’re right. But since I was not able to either boot to system or recovery, I tried that nevertheless. But it was somehow clear that this won’t work :see_no_evil:.
I think that maybe Magisk causes those issues resulting in a not working system.

Since you said that you have Magisk, I suppose that you rooted your phone. So I guess that the problem comes from that.

It is known that if you relock the bootloader after installing a root access the booting process will fail (because in order to gain root privileges the boot partition is altered and won’t match the bootloader’s expectations).

In conclusion : if you root your phone do not relock the bootloader.

3 Likes

@Ingo @Alex.A Thanks a lot!

2 Likes

Anyone else has battery trouble with official LOS version?

Before switching to the official, I was on the beta LOS and my battery was super good, 4-5 days. Since the last update, it is only 2-3 days.