English

Notification "Headset is plugged in": How to turn off?

Tags: #<Tag:0x00007f05de7f4758>

FP2 @ OpenOS 7.1.2 19.05.2

When I plug in my headset, my phone gives me a permanent notification about it. How do I turn this off?


Thanks. I hate it.

1 Like

That notification was my white whale for a while, but I figured out how to disable it in the end. It takes a bit of work. TL;DR: there’s a setting for it in GravityBox.

  1. enable root access in Settings > Developer settings. If no item by this name appears, go to Settings > About phone. Scroll down to ‘Build number’ and tap it repeatedly until you get a notification that tells you that you’re now a developer. The ‘Developer settings’ item will have appeared in the Settings screen.
  2. Install the Xposed Installer app (available on F-Droid) and use it to install the Xposed framework.
  3. In Xposed, look up the Xposed module ‘GravityBox (N),’ install it, enable it and then reboot your phone.
  4. Open up GravityBox, go to ‘Statusbar tweaks’ and then ‘Ongoing notification blocker.’
  5. In the list that pops up, look up ‘Call Management’ (I guess it would be ‘Anrufverwaltung’ for a German language OS) and select it, and tap ‘OK.’
  6. Plug in headphones to see if this has worked. If it hasn’t, reboot your phone.

(Cue someone else giving a far simpler solution that requires neither root nor Xposed)

1 Like

Can it not just be wiped away to the right or the left?

No.
A quick search suggests it’s a general Android issue (for those who perceive it as such) across devices.

1 Like

Since you are running Fairphone Open OS, I thought I’d mention that I don’t get this notification in LineageOS 16.0 (for microG, but that shouldn’t matter in this case).

Thank you @rmf

Your help has reduced my daily annoyance by 1 :grin:

1 Like

Thank you again for helping rmf. But sadly, the -1 annoyance is a +1 again, because of course, the solution comes with its own problems.

Deactivating the notification means deactivating the whole mechanism that detects the headphone.

Now the phone does not automatically stop the audio player, if you plug out the earphones, willing or by accident, the phone keeps blaring your music out of the squeaker.

So now I have to decide. Does it annoy me more that there is a notification on my screen or do I want to annoy everyone in the train with short segments of music out of my squeaker because the headphone jack on top module #3 is loose again (starts after about six months, gets useless after about a year) and doesnt hold on to the headphone jack properly?

That is very strange - for me, it works perfectly. If I plug in headphones, music starts playing (a setting in my music player) and when I unplug them, the music stops. The phone detects the headphones just as it ought to.

Does the desired behaviour return when you disable the GravityBox setting? If your headphone jack is particularly loose, it may be a hardware issue.

Edit: I skimmed through that headphone port thread, and unless I missed it, no one there suggested re-bending the contacts inside the headphone port. For a while, I carried my FP2 in a pocket under a bag strap that pressed on the headphone plug, and it bent those contacts out of shape to the point where sound was only coming through one channel, and finally wasn’t coming through at all. I took a pin and carefully re-bent the brass contacts inside the port, and it improved contact and grip (and I moved the phone to a different pocket). YMMV and try at your own risk of course, but this is the method I’ve been using to fix up 3.5 mm ports for years.

Thanks for your reply.

In Gravitybox:
By default, the phone does detect the phone jack.
Turn setting on - No more plug awareness
Turn setting off - Annoying message

I still firmly believe my Wackelkontakt problem is just FP’s bad build quality or FP’s design flaw. As a comparison, my seven year old Galaxy Nexus still holds on to any 3.5 mm headphone or headset jack like a hungry Dingo to its prey :slight_smile:

So how do I do the bend the brass part? I was not successful finding a guide. My duckduck-fu is weak :smiley:

I looked for a guide too but couldn’t find one, or even any reference to the practice. Am I the only one who’s been doing this?

Anyway, I took out the top module for easy access, and then used a pin with the very end bent over into a little hook (I heated it up with a lighter first, to make the metal flexible rather than brittle), to pull the brass bits inward. There’s some openings in the plastic part that allow you to poke in from the side and push the brass tabs inward, but most of the work is done through the port itself.

Thank you for the tip. I shall practice it on one of the two old modules i already had to buy because of this problem.

19377384

1 Like