Not registering my sim card

Hi there,
I’m just setting up my new fair phone 2 but it is not recognising my SIM card. Any ideas what to do? I am connected to the network but not having any luck when playing around in sim settings.
I’ve tried it in both the SIM card holders.

What exactly doesn’t work? If you are connected to the network then obviously your SIM is recognized. So I’m guessing you can’t connect to the internet and/or place calls?
Have you contacted your provider and asked for the APN settings?

The phone says sim not recognised. The sim image and the tip of the screen has a little line through it.
I can’t make calls. But I am connected to the Internet (via wifi). Is your recommendation to phone my provider (EE).

If I ask for the APN settings, what do then do with them?

Are there two of those symbols? If there is just one then that’s normal if you inserted one SIM.

Oh ok than that can’t be solved with APN settings.

How old is the SIM?
Does it still work in other phones?
Did you try cleaning the sim a little with a dry cloth?

:warning: Be careful when dismounting the SIM as the pins can break.

It’s probably two years old.
I will try cleaning it.
Yes it works in my old phone (Samsumg Galaxy s5).


I have the same problem, and I use a sim card that is totally new. My phone did work for a couple of hours, but then suddenly it said no simcard recognized. I called my provider, but they say the simcard should work properly according to their knowledge.

Any suggestions? Thanks in advance!

Did you try a reboot?

What do it mean by reboot? If tiu mean turning it off and on a gain then yes. But not sure what wise I can do in tens of reboot?

Sounds similar to me. I received a few test messages with my old sim in the new phone but then it went back to ‘not recognused’.