Not receiving messages

My wife has a FP4 that has had problems receiving text messages. We saw that messages that I had sent were not received. She tested the SIM card in a different phone, an old Sony Ericsson phone, and suddenly messages poured in. I then reset the phone to factory settings, and messages were received again. And then after a week or two, messages stopped being received again.

She has had the phone for a while, perhaps a year. And this started happening a month or so after we switched to a different phone company (we live in Norway, and she switched from Ice to Telia).

So I wonder what can be the problem here. Telia has not been very helpful in troubleshooting this. But considering that moving the SIM card from the FP4 to another phone gets text messages working again, is it probable that this is a problem with the FP4? Or can it be some compatibility issue between Telia and the FP4?

There is a message “feature” called RCS which seem to be causing a lot issue.

See if you can disable it in the messagws app, else I suggest to use another SMS app and deaktive Messages from Google

From your description I think that the problem is probably that the new carrier (Telia) has simply failed to validate the FP4. Not strictly a compatibility issue, just a carrier validation issue. The fact that moving the SIM to another phone and back allows the FP4 to receive messages again for a short while is pretty conclusive to my mind.

Unfortunately if the carrier is being unhelpful, and if there was no guarantee from them to begin with, that the FP4 would be supported, you may not get a quick fix.

As well as trying a different app as suggested by ymuell, you should contact official Fairphone Support, they may be able to fix things with Telia.
There have been a few problems with this carrier reported in the past.

I currently have the same problem with my FP4. It is almost two years old. When I bought it, I could neither send nor receive text messages. We then installed the Textra SMS app and from then on it worked perfectly with my provider at the time, “Salt”.
Now I switched providers at the beginning of April 2024, from Salt to Swisscom (I life in Switzerland). Since then, I can no longer send or receive text messages. We have tested various apps (Messages, Textra, Fossify). However, none of them work.
My new provider “Swisscom” should support FP4. What else can I do? I need the SMS function for 2-step authorisations.
The RCS is switched off.

Hi and welcome to the community forum.

In “the old days” (a year or two ago), I would have advised you to begin by checking that your APN settings correspond to those of your carrier, but many of the latter now lock the settings of their SIMs. However, Swisscom settings are in any case not readily found on their website (which should always be the preferred reference source). You would probably be best advised to contact them for details. I’ve had a look at some websites purporting to provide this information, but they differ, which is probably a bad sign.

If I understand you correctly, you have already contacted Swisscom support but you may not have checked the APN aspect with them.

What does APN do for SMS?

Maybe this helps?

Or did you for whatever reason deactivate the Carrier Service App?

Thanks for the suggestions.
I got the new subscription through my employer. In contrast to Swisscom support, the subscription advisor found the solution very quickly. At the same time, I also received a SIM card for using the Internet on my laptop. The SIM cards were sent to me in a letter and were not labelled correctly. Accordingly, I inserted the SIM card for the laptop into the Fairphone and, conversely, the SIM card for the Fairphone into the laptop.
After changing the SIM cards, everything worked perfectly. :smile:
Many thanks again for your help!