No touchscreen at all after LOS20 update

Hi, I’ve updated my Fairphone 4 to the latest LineageOS 20 (lineage-20.0-20231025).

Touchscreen doesn’t work anymore, at all. Only physical buttons do.

The OS launches properly, but I can’t type my PIN when required to.

So I’m kinda stuck.

I can control volume though, as the physical buttons work.

Welcome to the Community Forum.

You might want to look into connecting a USB computer mouse to control your display as a first-aid workaround. This will (probably) require an OTG adapter plug or cable.

In addition, holding POWER and VOLUME UP for a long time can lead you into Recovery Mode (if you end up on a “No command” screen with a “dead” Android, you might need to briefly hold POWER again and briefly press VOLUME UP anew), but I guess you are already familiar with that.


Same here, after the lineage-20.0-20231025-nightly update, touch does not work anymore. Have not tried the USB mouse and keyboard workaround yet.

Here is a reddit thread about this problem on the LineageOS reddit

EDIT: If you don’t have an USB adapter for connecting a keyboard and a mouse, you can also boot to recovery (POWER + VOLUME DOWN) and install the previous image via ADB sideload (only Step 5 in “Installing LineageOS from recovery” from the Lineage OS Wiki)

I think @mikeNG is one if the developers of lineageos for FP4. Perhaps he can help.

I tried the the USB mouse workaround (thanks @urs_lesse), but I don’t know how to downgrade from there. The update manager doesn’t display previous builds.

I also tried ADB sideload with the previous build (lineage-20.0-20231008), this gives me an error like :

Current SPL: 2023-10-25 Target SPL: 2023-10-08 this is considered a downgrade
Denying OTA because it’s a SPL downgrade

So I don’t know how to downgrade properly.

just to note a downgrade might cause data loss, so first back-up everything and then I guess flashing it via fastboot should work?

1 Like

You could download manually from and then use “Local update” from the three dots menu in Updater. TBH I have never tried this function.

Maybe it is an issue with the 2023-10-08 build you used. I successfully downgraded to the 2023-10-15 build. Maybe the latter has the same security patch level as the broken 2023-10-25 build. But I remember the recovery asked me if I really want to downgrade and I had to choose “yes”.

1 Like

It worked ! Thanks a lot for you help @oddfellow !

Here’s what I did, if it can help others :

I tried the local update, but downloading ~ 1Go OTA from a mobile browser isn’t optimal. And it seems that downgrading OTA isn’t allowed in Android.

I ended up sideloading the 2023-10-15 build and got this error :

ERROR: recovery: update package is older than the current build, expected a build newer than timestamp {timestamp} but the package has timestamp {timestamp} and dowgrade not allowed.

The Recovery then asked me to confirm that I wanted to downgrade.

On first try, installation failed and got me another error.

But it worked the second time.