No thumbnails shown when mounting phone via USB


With any Android Android phone that I owned until now, I always could see the thumbnails of pictures when connected by USB to my Windows 10 computer, opening the DCIM folder.

Unfortunately, with my new FP4, it’s not working.

In Windows Explorer, all that I see is standard JPEG icons.

Interesting facts about the issue :

  • deleted pictures are still visible, their name beginning with a “.trashed-xxx” prefix.
  • the behaviour seems inconsistent, since some random pictures does show a thumbnail !

  • Copying a picture from another smartphone does show a thumbnail !

Suspecting an issue with the terrible Fairphone Camera app, I installed a third party camera app ( Manual Camera)

But the issue is still there, with the same inconsistency.

I’ve found some posts on different forums about the same kind of problem, but no fix.



ok, strange
What doe’s support mean?

That’s standard behaviour. When you delete a photo with google photos, it will move it to the trash folder, and you must choose the option “Delete from device” to permanently delete the photo.

But as said, you should contactsupport because this thumbnail problem isn’t normal and you should get some official advice from FP here I believe.

1 Like

Hi Alex.
Do you mean opening a ticket at this address ?

1 Like

Have you tried changing the view options for this particular folder in Windows Explorer? What happens if you choose “Large Symbols” or optimizing for Images in the folder’s properties?

Best wishes,

Thanks Thomas, but I did try that, and it does not change the display, still JPEG standard icons.

1 Like

In addition:

Images can successfully be copied only if not double-clicked before. In this case, the Foto-Prewiewer says “invalid format or file damaged”. Windows Explorer restarts and the phone must be reconnected to copy files again.

1 Like

KleinerAdmin : I did not meet this particular issue, but it seems awful !

That is the online link but you can email support (at) fairphone (dotcom)

Done, ticket opened.
I received an automated answer telling that I had to contact my local reseller (Orange/France), but with the possibility to ignore it by sending the invoice of the Fairphone.
Now I’m waiting for a human answer :grinning:
I will keep you in touch here

1 Like

And I thought I couldn’t find any new FP4 bug today. :smiley: But yeah, I experience the same behavior. And it’s not caused by the Camera app. Photos taken by GCam behave the same.


  • all thumbnails are missing
  • opening an image directly from the phone folder (DCIM) takes an enormous amount of time and sometimes doesn’t even finish
  • sometimes it straight up crashes Explorer and the phone needs to be reconnected

I do wonder if either/any of the complainants have tried starting in safe mode or done a factory reset. Isn’t this likely to be an OS software issue that may not be common to all users?

I’ve just tried safe mode and I managed to crash the Windows Explorer as well. Thumbnails are also still missing. And I don’t like the idea to perform a factory reset just to see if it fixes things. For me, that would be just the last resort before sending the phone back to Fairphone. The experience with the phone is definitely not great so far.

Razem, I’m convinced that the issue can’t be fixed by a factory reset.

My FP is really new, and is in my view in “good health” (very few apps installed, for example), I’m careful with that.

I believe that it’s some kind of an Android bug, because some forums reference the same behaviour, on various phones.

For me, it’s until now the only bad experience I had with the FP4.

1 Like

Are the pictures stored on the internal storage or an SD card (hopefully formatted as external)? Maybe its just all that slow that thumbnails need ages to show up?

Internal storage. I don’t have any SD card inserted. And I only have 3 photos, so it should be pretty fast IMO. :smiley:

Same for me, internal storage. no SD card.

If you contact support they a) will likely ask you to do a factory reset b) will have to do one if you sent it too them.

Hopefully someone will find an alternative.

1 Like

Hi All,
When I plug my FP4 into my laptop to look at photos, the thumbnail in the DCIM folder is the file icon rather than a small photo. Is there a way to change this ? When I copy/move the photo to the laptop the thumbnail is OK.
Thanks in advance

1 Like

Hi AliRay, moved your post to this existing