No thumbnails shown when mounting phone via USB

Hi !
Just a post to tell you that I’m still in touch with Fairphone support to investigate this issue.

6 Likes

I don’t have Windows, so I tested it on my GNOME Linux workstation (Fedora). Thumbnails indeed do not show up when connecting the phone via USB and browse to the SD card. But when inserting the SD card directly into my laptop, the thumbnails indeed do show up. However, I do have to enable the option that I want to see thumbnails everywhere on my computer. If I do not enable that I won’t see thumbnails on network shares and mounted drives. This is for performance reasons.

This is by the way not only a Fairphone issue. It’s probably part of AOSP. There are more topics about this online with a variety of Android phones. I suppose that Fairphone won’t spend time on this. But maybe if you pitch this feature at LineageOS, they might develop it and then Fairphone may cherry pick that change from there. The default should still be to not process thumbnails. But maybe add an option to developer options to enable them, something like that. In any case this is not a Fairphone specific issue but an Android one. I therefore will remove it from the issues list specifically about the Fairphone 4. Android feature requests are out of scope for that. If this was part of the next Android release, then we could keep it there, because then Fairphone does have influence over it, by making a new Android release available :slight_smile: That’s not the case now and I think this issue is likely not resolved this decade, if ever :nerd_face:

I’m really not sure this can’t and shouldn’t be fixed :thinking:

I did a little deep dive and some tests since the MTP spec actually requires thumbnails to be supported…

D.2.10 GetThumb
This operation retrieves a thumbnail for an image object on the responder.
The Representative Sample object property may be used as a more flexible alternative for
devices which support object properties, but this operation must be supported for PTP-
compatibiliy
.

…so this should at least be possible.

In the Dolphin filemanager (KDE Plasma/Arch) it doesn’t work for me either.
But it do get thumbnails in Windows 10…

…and if I open that same folder using Gwenview (KDE’s image viewer) it works as well:

Keep in mind that I’m running Android 12 (CalyxOS) on my FP4 and I can’t try this on a stock FP4 till tomorrow, but it at least shows that it’s possible.
I tried two other Android devices that use MTP as well and did get the same behaviour.

1 Like

Interesting. Then it’s likely a library that’s missing on my computer. Or perhaps support for the thumbnails. Thanks for the double check!

I checked with my Pixel 3 (Android 12), no thumbnails either. So I suppose the leading factor here is a file viewer/manager that uses the MTP library properly (or has the feature enabled to generate thumbnails).

I did some more tests, found some pictures that didn’t have thumbnails , put them on all the devices and tried accessing them, here are the results:

Device connected to
(Application)
FP4 CalyxOS
Android 12
FP4 FPOS
Android 11
Nexus 4
Android 11
SM-T715
Android 9
Windows 10
(Explorer)
:green_circle: :orange_circle: :orange_circle: :orange_circle:
CalyxOS as host / client
(Files)
-/- :orange_circle:/:green_circle: :orange_circle:/- :orange_circle:/:green_circle:
Plasma / Arch & Ubuntu
(Dolphin)
:green_circle: :green_circle: :green_circle: :green_circle:

Dolphin works now, I forgot that I had disabled thumbnails for remote places, gets anyoing with NFS shares.

The interesting part for me is that, as the OP already mentioned, pictures taken with the FPCamera app are all affected. Those won’t show thumbnails if located on a A9 - A11 device, but moved to a A12 device they work just fine.
I did find a few pictures without thumbnails on the older devices as well and those exhibit that same behaviour, but most of them show up without problems.
The older devices were also able to show thumbnails for problematic pictures located on the A12 device.

My takeaway is, this seems rooted somewhere in the MTP-stack. If I read the MTP specs correctly there are (at least) two ways to get thumbnails, either the old PTP way or with a Representative Sample, so maybe we are looking at a situation where host and client can’t negotiate a working solution that would lead to thumbnails being shown :thinking:
No idea why Dolphin just works™, newer MTP-stack maybe :man_shrugging:
Has someone tested this on Windows 11, does Explorer show thumbnails there?

GNOME’s gvfs-mtp just uses libmtp in the background, same as KDE’s kio.
The newest libmtp was released 25.09.2021, that should probably be in the latest Fedora (haven’t checked), so it seems likely Gnome Files doesn’t implement some necessary part.
You could try installing Gwenview or Dolphin, but as a GNOME user you probably don’t want to pull in half of KDE :smirk:
The Gwenview flatpak sadly didn’t show MTP devices when I tried it…

2 Likes

will be released then…? :thinking:

1 Like

Whoops :see_no_evil:
It’s late and the text is long :smirk:

1 Like

I can link my Fairphone 4 by USB to my PC and turn on USB file transfer. Photos is automatically started on the PC and it tries to show thumbnails of the photos on the phone but all I see are blurred photo document icons …
image
How can I get it to display proper thumbnails?
Many thanks.

Hi and welcome, I moved your post to this existing topic, further info above

Wow interesting, i checked that by myself right now…

You could try, as workaround, “link to windows” it syncs very quick via Network/BT and adds some more features than just get the pictures. You can see notifications, make calls, send SMS and some other stuff.
It’s 1 App and an already built-in Windows tool, so not so much bloat.
(maybe just built-in inWin11??)
Personally, I prefer using a cloud, I never plug in my FP4 to the PC.