No NFC option in Quick access Settings


Hello there,

i can not switch nfc on and off with the setting at the top bar. There is no icon what so ever. My Wife has the same phone… And she does not have the problems. Here are some screenshots (Sorry. Everything in German :wink: ):

Can you enable through the settings-connected devices? Maybe after that the icon will appear?

Else check for the App under settings-apps-all apps-three dots-show system apps. Is it there and can you enable any settings/permissions

Works for me. It’s listed and works as advertised. Do you use the native Fairphone OS that came with the phone?

1 Like

yes i do. build is FP4.FP44.A. 149.20220722
the nfc is fully working (did pay with that yesterday). but the icon is not there.
i did enable and disable it but there is no change.

Try to boot into safe mode. I see a lot of 3rd party tiles in your menu, maybe something is causing issues. If it works in safe mode, then a 3rd party app is likely the cause.

1 Like

Yeah, I have the same problem, even in safe mode. But it doesn’t really bother me that much, I leave it on all the time anyway. I guess your best option is to just #contactsupport

In the meantime, you can use Quick Settings app or this script for Automate.


I cannot add a NFC switch/button to my drop down Quick Access menu. Doesn’t show up as an option in the “Customise” settings either.

Works more or less okay generally, just a pain to go flip it on/off in the advanced settings menu…

Any ideas?

I’ve moved your post to this existing topic.

Maybe someone else with this issue has already heard back from support? :thinking:

1 Like

Just for the general collection of “cases” I’m going to drop a related Reddit thread here.
Spoiler: In there, there is also no solution. /:

I’m sure there is, my guess is that a 3rd party app is causing this. Have you tried safe mode or guest mode already? The quick settings button for NFC is there for me.

In the guestmode everything works… Hmmm. Thanks for the help. Now I need to check which app is causing this… :confused:

Hello, same problem here. I’ve tried both the guest mode and the safe mode but the NFC option wasn’t there.
I downloaded yesterday the latest patch so, I guess it’s all fine from OS level


is there a way to enable/disable NFC via Quick Menu?
It’s always a bit of a hassle to wade through the options.


Using Android 11 on the FP3 :slight_smile: there is an option in the pull down menu which you can place at the top.

hey, funny. I don’t have this button…

Page 1:

Page 2:



I’ve moved your posts to this existing thread, maybe one of the others affected can share some news / potential fixes :thinking:

1 Like

I don’t see the NFC icon in quick settings and my FP4 is currently very standard configuration.
I’ve never actually had occasion to use it, and I have no particular service set up to use it.
Contactless payments says Payment default: Google Pay, but I haven’t set up GP so it’s a bit theoretical!
I had a look round settings in Connection preferences and didn’t see any option to add the toggle to quick settings.

I’m just wondering whether there isn’t an app that adds it rather than one that hides it …? An app that implements NFC in some way, like for payments or tickets.

I never had this icon on my FP4 (with stock OS). But I simply keep it on all the time. I don’t really see the point of turning it off and on again when needed, as the battery consumption is minimal and it would defeat the purpose of seamless mobile payments.

Never used it and have the icon, so I dont think its an app adding it

@meckitt You could try to connect your phone via adb and enter:

adb shell settings put secure sysui_qs_tiles default

This should still set the tiles to default.

Make sure to enable usb-debugging first via the developer settings (7 times tap on build number).

Maybe this helps.