No new phone calls are listed

Most of my calls (the ones I made today or the last days; the ones I received today) arent’t shown in my app. The last ones are from 23rd March (both were outgoing). The app lists outgoing, missed incoming and accepted incoming calls.
Is it most probable an issue of the app, my FP2 or of some phone setting(s), e. g. in Settings → Apps & [notifications] → [the app itself]?
I had the same problem with my previous phoning app.

OS: Fairphone Open 22.08.0-rel.0
Application: Emerald Dialer - Make calls, view call log (F-Droid)

Additionally, the ”notification“ that a call is being done doesn’t disappear when I finish the call. I also cannot wipe the notification out of the screen – it just stays where it is.

Try using the default app, just to check the log is OK. I think you’ll have to define it as the default phone app at least temporarily, while you do that.
You could also check with the developer of Emerald Dialer.

1 Like

How do you mean ”Try using the default app“ in detail? Only reactivate and open it?

Yes. That should allow you to determine whether the problem lies with the log or the app.
However, since you say, I had the same problem with my previous phoning app, I would tend to suspect a problem with the data. I’ve never seen a corrupted log but I suppose that can happen (and might be the fault of a present or previous app).

You say the most recent data that you can see date from March. When did you cease to see the more recent data? Have you ever seen data more recent than March 23rd?

The newest entry in the default app is also from 23rd March and it doesn’t know about any contact of mine…

It was around autumn last year.

For other years and their 23rd of March: yes.

So the immediate problem lies with the call log data.

That’s presumably because you haven’t granted the necessary permission to the app to access your contacts.

I think your best option will be to delete call log data entirely so that a new database is created. However you may wish to make a copy of what data you have, before doing that.
I think it would also be wise to try to discover what has caused this problem before doing anything else. Have you any idea what might have changed on the phone in the autumn of last year that might have caused the problem? A change of phone app maybe?

I deactivated and terminated some apps in Settings → Apps & [notifications] → App-Info. That’s all I can remember for now. Do you know which App/process does what in this list?

(Setting anything back to factory reset (?) is not in option for me yet because I changed a bunch of things at several places.)

Well as a rule it’s not a good idea to disable apps unless you really know what they do.
For instance, make sure that “Call Management” (a System app) is not disabled and that it has the requisite permissions: Call logs, SMS and Storage.

1 Like

Unless I didn’t find such an app, I got an additional issue the last days:
When phoning I cannot hang up, the screen remains black until the other phoner hangs up. This is quite bothering, esp. when noone takes the call: I get onto the answerphone without chance not to.

Nepumuk, What happens if you press the <power> button ? It may just wake the screen, or it may hang up as well (that behaviour can be configured in Settings > Accessibility > Power button ends call).

This isn’t a solution, but it might be a work-around.

1 Like

If this happens when you remove the phone from your ear, it would sound like the proximity sensor needs to be calibrated, or if that doesn’t help perhaps additional measures would be needed …


When having a call, the screen remains black. I can use the button normally, otherwise. It doesn’t end a call (as intended).

After boot I the message ” [is terminated]“. Maybe this got something to do with my issue…?

Quite likely, but it’s not necessarily the app’s fault. It may be an error in the call log or something.

I think the quick solution to this problem is going to be a factory reset. This would

  • delete all user data, app data and caches
  • return all settings to default values
  • retain the current version of the OS as stated by you (Fairphone Open 22.08.0-rel.0)

Dealing with it surgically will likely take a lot of time and effort. But you could begin by just deleting the call log data.

Before doing a reset, I just have a routine question however: do you have a SD card (storage expansion) in the phone and if so, is it formatted as extension of internal storage, or as external (“Portable”)? To find out, go to
Settings > Storage.


The app ”Kontakte-Speicher“ has no rights and I cannot give any to it. I deleted the cache and the user dates, but it seems to make no difference.

New contacts aren’t recognised by the other apps using (information of my) contacts. This ought to have started around the same time as the last call was logged.

That presumably confirms that the ”Kontakte-Speicher“ app has no rights to access the phone’s shared contacts database. If you want to be able to manage your contacts with this app, and use those contacts in other apps, then you need to authorize the app to access contacts.

On 20th October above, you mentioned a problem with the screen remaining black during a call when you remove the phone from your ear, and not being able to hang up. Is that problem solved? Did you follow AnotherElk’s advice about calibrating the proximity sensor?

This seems to be solved as far as I can see. It was the sensor.
Thank you (better late than never :sweat_smile:)

I don’t know how to change an app’s rights for which I don’t have the permission(s) to.

Screenshots for better understanding:

Well, at least we’re now aware that the app doesn’t have the required permissions, so we’re getting somewhere.

We now have to find why you are unable to allow the permissions for this app.

Can you return to Berechtigung “Kontakte” screen and tap on “Alle Apps mit dieser Berechtigung anzeigen” (Show all apps with this permission).

Let’s also remember that your original question was not about contacts but about phone logs. Can you check the permissions of your “Phone” and “Emerald Dialer” apps.

I must say it’s looking to me as though you may have to perform a factory reset as there seem to be multiple issues. I know you’re not keen to do that (who is, generally? :wink: ) but it’s likely to be even more complicated finding the settings and / or apps that are causing problems.

Are you comfortable using ADB?

Let’s say I know how to use a CLI in general and did also a few commands with adb (successfully).

The screenshot’s going to come later.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.