No more 4G connectivity after Android 10 update

Or you installed the /e/ OS Q alpha for FP2. :wink:
But I can say there 4G is working…

1 Like

Hi Nick,

I have changed the subject to a more precise wording. Others have already asked if you have selected the right category. Is this about an FP3 with Android 10? If so, we should reassign the category accordingly.

Regarding your issue: Could you please check if Settings > Network and Internet > Mobile Network > Advanced > Preferred network type is set to “2G/3G/4G auto”? This might be the culprit.

Best wishes,

I updated my FP3 to Android 10 yesterday and lost data connectivity after the update.
I had to look up my provider’s APN and set it manually, it was no longer present in the list of APNs on my phone. I got 4G up again after saving the APN.

(Usually this is set automatically when you put the SIM card for the first time, seems like this time the update wiped it and it did not set automatically again)

Hoping this helps someone, this thread came up first on Google with the search “fairphone android 10 no data”


THanks, yes it is an FP3, sorry. I re-set up the APN and now all good, thanks!


I had the same problem with my FP3 and ANdroid 10 update :
I lose Data connectivity after enable Wifi access point.
I had to restart my FP3 to have data again.
And thanks to this topic, I reset up APN and now it seems to be okay :slight_smile:


Thanks! I had this problem too. No Internet. Resetting the APN to default fixed it.


Ich habe jetzt noch Folgendes zu ergänzen: Gestern unterwegs konnte ich bei Tier keinen E-Scooter mieten - die App meldete fehlende Internet-Verbindung. Außerdem konnte FairEmail den Server (Apple) nicht mehr auflösen. Andere Internet-Dienste und Apps funktionierten hingegen größtenteils problemlos.

Bei näherer Untersuchung ist mir dann aufgefallen, dass mein FP3 irgendwann mit oder nach dem Update auf Android 10 von meinem Netzbetreiber Telekom auf deren IPv6-only-APN internet.v6.telekom umgestellt worden ist. Das sieht man erst, wenn man sich die Details des APNs anschaut. Offenbar macht die übermittelte Konfiguration irgendwelche Schwierigkeiten (u. a. war als Passwort statt „tm“ „telekom“ eingetragen, das war aber wohl nicht das Problem) .

Ich habe nun händisch wieder internet.telekom wie hier beschrieben

hinterlegt und alle Apps und Dienste, die vorher gezickt haben, funktionieren wieder wunderbar. Die fehlende Konnektivität habe ich tatsächlich erst gestern bemerkt, weil ich mit meinem FP3 einfach die weitaus meiste Zeit in WLAN-Reichweite bin.


Can you tell me what APN is and where to change it? Searching APN in the phone’s settings turns up nothing.

Welcome to the community forum!

APN=Access Point Name

An Access Point Name ( APN ) is the name of a gateway between a GSM, GPRS, 3G or 4G mobile network and another computer network, frequently the public Internet.

A mobile device making a data connection must be configured with an APN to present to the carrier. The carrier will then examine this identifier to determine what type of network connection should be created, for example: which IP addresses should be assigned to the wireless device, which security methods should be used, and how or if, it should be connected to some private customer network.

Source: Wikipedia

You can find them under: Settings→Network and Internet→Mobile Network→Advanced→APN


Thanks, that’s done it!

1 Like

This solution also seems to have worked for me. I was previously resetting the APN as per another post, but it turned out the settings on my provider’s website were different from the default and it seems to be working fine now.

This also fixed a problem I had that my VPN wasn’t connecting on mobile data.

1 Like

My Fairphone3 recently (in the last week or 2) upgraded it’s software and ever since I have not been able to get any mobile data whatsoever. I had another upgrade this morning but I am still in the same situation.

The build number is now 8901.3.A.0045.20200905

I’ve moved your post here as it also sounds like a lost APN setting during the upgrade to 10.

1 Like

Since I did the update for Android, I get no 4G connection and even the 3G works on and off.
Is it a pb with my phone? Has anybody got the same issue?
Thanks for your help.

I moved your post here to avoid duplicate topics. Please have a look at the suggested solution(s).

Ah yes. That fixed it. many thanks


I’m in the same predicament. I contacted tech support on the phone coop.
They advised me to select & set APN internet to " everywhere" instead of my provider Orange internet. I still had no 4G so have returned it to Orange but still not resolved. Can you please give me a simplified version of what to do in advanced APN… I can’t work it out and the solution given above isn’t working for me. Thanks

The APN changes depending on your provider, so it’s hard to give you a specific answer without knowing in which country your data plan is based from.

From my experience, you can use Google to find your APN very easily by searching “orange APN internet”, Google should give you an answer in your language that applies to the country you’re in, in my case it shows me the Spanish APN for Orange which is the following

Nombre: Orange Internet Móvil.
APN: orangeworld.
Nombre de usuario: orange.
Contraseña: orange.
MCC: 214.
MNC: 03.
Tipo de autenticación: PAP.
Tipo de APN: default

Once you have that information, you go to your phone settings, “Network and Internet” > “Mobile Network” > “Advanced” > “Access Point Names” (at the very bottom of the list)
Once you open the APN list, you should be able to create a new entry and fill the details you got above from Google, don’t forget to save and after that the APN should be properly set and you should see 4G available again.

If the issue persists after setting the APN to your phone’s provider, it might be that you are experiencing a different issue than the one described here.

Hope it helps !

I had the same problem, but for me fixing was easier. It worked again after I resetter all WiFi and Bluetooth settings. Sounds easier then the APN thing…

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.