No mobile data after coming back from abroad

Dear community, before going on vacation to Brazil mobile data worked with my FP3+ with Aldi Talk (MEDIONmobile). Going to Brazil, I bought a SIM card there, and it worked too. Coming back to Germany, I topped up the Aldi Talk plan, and put the SIM card into the FP3+n, and mobile data is not working anymore. Mobile data works, when putting the SIM card into another phone. Similar problems are reported in the forum, but the only solution seems to be a factory reset, which I’d like to avoid. Does the Fairphone project have an issue/bug tracker, where the problem is documented, and can hopefully be fixed soon?

What log files can I provide, which might point to the cause?

Have you already checked APN and reset them to default? If nothing works maybe you are hit by this strange bug?

There is no public bug tracker so please #contactsupport

And for completeness, could you add on which OperatingSystem version you are (settings-about the phone-build number)?

2 Likes

Dear yvmuell,

Thank you for your reply. We already tried resetting the APN and it didn’t work. Also we only use one SIM card.

The build number is 8901.4.A.0013.4.

Shouldn’t be there some log files, showing what is going wrong?

Thanks, Anja

PS: I contacted the support two days ago. Untill now they haven’t replied.

No chance to borrow a second SIM and check those settings?

Support needs normally at least 5 working days for a first response.

What do you mean with log files? You could create a logcat file from your device e.g. using the App Matlog Libre from F-Droid store.

Or you can capture a bug report probably

2 Likes

I have exactly the same problem coming back from the US where I tried to use a second, local SIM card (which didn’t work with my phone), and then kept my phone on in airplane mode. Once back in Europe trying to use my Belgian Proximus SIM in slot 1 again, everything works except for mobile connection.

I’m of Fairphone 3 with the latest version 0013.4 (Android 11) - July 27, 2022 update.

Here’s everything I tried so far:

  • Verified that mobile data is activated
  • Verified that there is no data limit defined.
    (One weird point is that the OS informs me that I have consumed 5.95GB of data in August even though I have not used any mobile data as confirmed via my provider’s app)
  • Switched the SIM card to slot 2
  • Reinitialised all network connections
  • Checked that the APN settings are correct (same as on another phone using the same operator)
  • Tried the SIM card in another phone: mobile data works there
  • Tried another SIM from the same operator on my phone: mobile data doesn’t work

I also only see factory reset as the next step, but would like to be sure to have tried all other options before.

I saw the following in the release notes of the latest update and wondered if it might be a source of the issue, even though I’m pretty sure I used my mobile data after the update just before leaving on July 28:

“The network compatibility for several carriers has been enhanced.”

Hey yvmuell,

Another SIM card doesn’t work as either.

I will try to capture a bug report. Thank you for your help.

Hey mlennert,

Did you find a solution?

@yvmuell, thank you very much for your continuing support.

What do you mean with log files?

A protocol of the communication between the Fairphone and network provider, where the error is visible and at what step it fails to negotiate the mobile data connection.

Thank you for linking to the instructions how to capture the logs for a bug report. The archive contains a text file, containing the provider name MEDIONmobile.

SERVICE com.android.systemui/.SystemUIService 5814b7a pid=1983
  Client:

    com.android.keyguard.KeyguardUpdateMonitor:
    ----------------------------------------------------------------------------
    KeyguardUpdateMonitor state:
      SIM States:
        SimData{state=5,slotId=0,subId=1}
        SimData{state=1,slotId=1,subId=-1}
    com.android.systemui.statusbar.policy.NetworkControllerImpl:
    ----------------------------------------------------------------------------
    NetworkController state:
      - telephony ------
      hasVoiceCallingFeature()=true
      mListening=true
      - connectivity ------
      mConnectedTransports={1}
      mValidatedTransports={1}
      mInetCondition=true
      mAirplaneMode=false
      mLocale=de_DE
      mLastServiceState={mVoiceRegState=0(IN_SERVICE), mDataRegState=0(IN_SERVICE), mChannelNumber=1021, duplexMode()=0, mCellBandwidths=[], mOperatorAlphaLong=MEDIONmobile, mOperatorAlphaShort=MEDIONmobile, isManualNetworkSelection=false(automatic), getRilVoiceRadioTechnology=16(GSM), getRilDataRadioTechnology=2(EDGE), mCssIndicator=unsupported, mNetworkId=-1, mSystemId=-1, mCdmaRoamingIndicator=-1, mCdmaDefaultRoamingIndicator=-1, mIsEmergencyOnly=false, isUsingCarrierAggregation=false, mLteEarfcnRsrpBoost=0, mNetworkRegistrationInfos=[NetworkRegistrationInfo{ domain=CS transportType=WWAN registrationState=HOME roamingType=NOT_ROAMING accessNetworkTechnology=GSM rejectCause=0 emergencyEnabled=false availableServices=[VOICE,SMS,VIDEO] cellIdentity=CellIdentityGsm:{ mLac=[…] mCid=[…] mArfcn=1021 mBsic=0x1b mMcc=262 mMnc=03 mAlphaLong=MEDIONmobile mAlphaShort=MEDIONmobile mAdditionalPlmns={}} voiceSpecificInfo=VoiceSpecificRegistrationInfo { mCssSupported=false mRoamingIndicator=1 mSystemIsInPrl=-1 mDefaultRoamingIndicator=-1} dataSpecificInfo=null nrState=NONE rRplmn=26203}, NetworkRegistrationInfo{ domain=PS transportType=WWAN registrationState=HOME roamingType=NOT_ROAMING accessNetworkTechnology=EDGE rejectCause=0 emergencyEnabled=false availableServices=[DATA] cellIdentity=CellIdentityGsm:{ mLac=[…] mCid=[…] mArfcn=1021 mBsic=0x1b mMcc=262 mMnc=03 mAlphaLong=MEDIONmobile mAlphaShort=MEDIONmobile mAdditionalPlmns={}} voiceSpecificInfo=null dataSpecificInfo=android.telephony.DataSpecificRegistrationInfo :{ maxDataCalls = 20 isDcNrRestricted = false isNrAvailable = false isEnDcAvailable = false LteVopsSupportInfo :  mVopsSupport = 1 mEmcBearerSupport = 1 mIsUsingCarrierAggregation = false } nrState=NONE rRplmn=26203}], mNrFrequencyRange=0, mOperatorAlphaLongRaw=MEDIONmobile, mOperatorAlphaShortRaw=MEDIONmobile, mIsDataRoamingFromRegistration=false, mIsIwlanPreferred=false}
      mIsEmergency=false
      mEmergencySource=ASSUMED_VOICE_CONTROLLER(201)
      - config ------
      - NetworkController.MobileSignalController(1) -----
      Current State: connected=true,enabled=true,level=3,inetCondition=1,iconGroup=IconGroup(E),activityIn=false,activityOut=false,rssi=0,lastModified=08-27 09:41:31.742,dataSim=false,networkName=MEDIONmobile,networkNameData=MEDIONmobile,dataConnected=false,roaming=false,isDefault=false,isEmergency=false,airplaneMode=false,carrierNetworkChangeMode=false,userSetup=true,defaultDataOff=falseimsRegistered=false,voiceCapable=false,videoCapable=false,mobileDataEnabled=true,roamingDataEnabled=falseshowWFC=false

So this, like dataSim=false, confirms what is shown in the UI. Unfortunately, I do not see where/why it fails. What is state 5 in SimData{state=5,slotId=0,subId=1}? Is that information in the bug report dump?

Hi @AnjaBerlin , no I didn’t and since I absolutely needed access to my mobile data, I did finally go for a factory reset. This did bring my mobile data back, but I also lost some data from some applications for which I forgot to take the necessary steps before…

I’m not really capable of interpreting such a log properly the only I stumble over in connection with the bug mentioned/linked above is

isDefault=false

so my question: you said another SIM didnt work either. When you tested where both SIMs in the phone together and did you check if there is probably a setting seen then that has set (by mistake as is should not exist normally to my understanding), mobile data to always ask? This feature is normally only available for calls and SMS not mobile data.

I understand you have a ticket open with support, I would def. send them the bug report, maybe you can run it again with a second SIM inserted (best from another provider) and/or only another SIM (also best from another provider.

Will see if I can run it on my bog report later today as a comparison.

Hello,
I have the same problem and same reason. I tried everything except the factory reset…
Is there any alternative? No answer from support yet…
:pensive:

please check for the new update and check if it solves the problem
https://forum.fairphone.com/t/fp3-update-4-a-0016-6-without-release-note/88210/14?u=yvmuell

4 Likes

Thank you, yvmuell, I did a factory reset two days ago. I hope it will help others who have the same problem.

It worked!! Thanks a lot!! :star_struck:

2 Likes