No internet at all

Hey there!

Two days ago my internet stopped working at all on my FP2. No matter if it is connected to mz WIFI or via 4G, its all the same. It shows a connection to WIFI and 4G and I even can call and I can receive calls, but no internet. I tried changing SIM-cards but it doesn*t change. I also did reboots, took out the battery, cleaned the contacts of the SIMs, reordered the settings from my phone providers…

I know that there were some posts that WIFI or mobile internet didn*t work but it seems like my case is different because nothing works.

I would be very glad about some help!




it is just a stupid guess, but did you check that your phone is not in “flight mode”?

Maybe it could help to activate and deactivate “flight mode”.

Do you use any firewalls, ad-blockers or privacy-enhancing apps or any app that uses root access or is registered as a device administrator?

Well, flight mode is deactivated. As I wrote I HAVE a connection to the
mobile network and to Wifi but I somehow can*t access the internet.

To the second reply: No, right now I dont have any apps of that kind
installed. I used to have Xprivacy but the Xposed-framework is gone
after an update. I already deactivated tor and nothing changed (but
Firefox isn
t using tor anyway). So I still dont know whats up… But
thanks for your ideas!

What did you do 3 days ago with your phone? Which apps did you install? Tor?

Well, if I knew what I changed I’d change it back.
Now I have disabled root for all apps and somehow it works now. But I actually don’t know which app it has been which restricted Internet access. I’ll reactivate root step by step now and see which app has been the reason for my problem.

Thanks to everybody for your help!



I have the same problem since 2 days on OpenOS 16.06. I have disabled root for all root apps and deactivated all Xposed modules but there is no change. Wiping the Dalvik Cache and Fix Permissions through TWRP was useless too.
The only thing I can remember is that I have updated some apps through F-Droid 3 days ago. Here is a list if important: LocalGsmNlpBackend, Frozen Bubble, µg UnfifiedNlp, F-Droid, Open Camera and Conversations.
I will try to deinstall this apps in the next days to see if one of them is the reason. If unsuccessful I will remove Xposed Framework too.

I have updated “µg UnfifiedNlp, F-Droid, Open Camera” too. I guess the most powerful app of them is µg UnfifiedNlp but I don’t see why it should restrict Internet access…

What’s your reason for “root for all apps”?

What do you mean by “what’s your reason”? I simply disabled root so no app could access it. I didn’t allowed root for all apps, of course, just by permission. Just 3-4 have gained root access…

It sound like: all apps had root-rights. Now it’s clear.

1 Like

I think there is a similar thread which describes the same problem on FP2 OS. I have posted my opinion about the probably mistake (changing platform.xml) here: No data connection after update to 1.4,2 and rooting.
In the meanwhile I have sadly reflashed with Open OS 16.06, because deinstalling all apps I have mentioned in my last post hasn’t fixed the problem.

In any case be careful with /system/etc/permissions/platform.xml !

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.