No data connection after update to 1.4,2 and rooting

Privacy impact is activated?

Yes it is.

I tried de- and re-activating it - doesn’t change a thing.

Just to be sure: you lost your “mobile data”-connection? Wifi is working? How did you root?

No, it’s not just the mobile data connection, it’s ANY data connection (the above logical excerpt was taken when connected to a WLAN). I rooted using super-bootimage.
But the problem persisted after re-updating via SD card (and not rooting).

Just found that my git clone is not the current fork of the project. Will try phhusson’s fork.
The boot-image from your first source was for OS 1.1.7

Of course I did update the known-imgs/fairphone/fp2 file for the 1.4.2 download URL, from where super-bootimg extracts and mangles boot.img.

Problem persists when using phhusson’s super-bootimg.

Did you try NicoM’s boot-image?

Have you already tried cleaning the cache?

Yes, as I already was in recovery mode, I wiped the cache before rebooting.

Any firewall / security app / Xposed modules that could have become active? (e.g. afaik AFwall won’t work until you have root access. So maybe this became active when you rooted the phone?)

None that I know of, and no Xposed. Apart from rooting, just plain FP2 OS.

So now I have found the time to bite the bullet and do a fresh install of the OS (using method #4 from the “Manually install FP OS for the FP2” page with FP OS 1.3.6, and then do the update to 1.5.1 from the SD card).

Everything is working again, and thanks to Titanium Backup Pro I have all my apps and their data back - but not the launcher setup, screen layout etc.

I still have no idea what went wrong.

Okay, so I think I get an idea of what went wrong.

FP was working properly for some time. Then, Titanium Backup said it couldn’t complete the scheduled backup (to the old SD card directory). The complete error message wasn’t visible in the notification, but I think it complained about not having enough free space.

Thinking this had to do with the SD card access issue, I applied the proposed change to /system/etc/permissions/platform.xml. After rebooting, my problem was there again: no network access whatsoever.

Right now, I’m going through the restore steps again. So far, my FP2 after updating to 1.5.1 does have internet access. I’ll then try to dig deeper into the Titanium Backup failure without going down the permissions path again.

I have read this thread today and for me it sounds similar to No internet at all. There I described my problem and what I have done before.
Because you have written in this thread that you had changed /etc/permissions/platform.xml (i.e. /system/etc/permissions) before the problem appeared I remember that I have done the same to fix the Ext SD card permission issue.

Maybe some ways changing platform.xml are dangerous. If I remember rightly I have copied the file from PC to FP2-ExtSDCard and further copied the file with ghost commander (file manager) to /system/etc/permissions for which I had to remount /system with RW option. Probably I have forgotten to remount with R option after that and this was the failure.

For me its too late because I have reflashed my FP2 with Open OS 16.06 but I wanted to write down my experience for other users.

UPDATE: Today I have changed platform.xml as described in SD Card no writing permission in FP2 (mind the missing read permissions) and the phone is still running :slight_smile:

UPDATE 2: Sorry but this wasn’t a solution. Again my phone was unusable (no network). Recommending doing changes to platform.xml only in recovery mode. See SD Card no writing permission in FP2

How did you reflash it? I have them same issue after changing /etc/permissions/platform.xml in a similar way as you did. I reflashed using the Manual installation (using fastboot). All my apps and data are still there, but the network issue persists, too.

Seems like the only option is to boot in TWRP and wipe /data. After doing so the issue seems to be solved. But then I have to set up everything from scratch :frowning:

Reflashing using the manual installation should be no problem. But in my opinion the safest way to change /etc/permissions/platform.xml afterwards is inside recovery mode how I described it under point 4b) in ✏ Update Guide for a modified FP Open OS (with Gapps, Xposed and more).

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.