No fastboot available, but TWRP?

I bricked my FP2 by installing lineageos 15.1 nightly over lineageos 14.1 - it was stuck in the LineageOS boot logo loop. First thing was, I installed TWRP 3.2.3-0 using the TWRP app (which maybe was the culprit?)

  • I flashed 15.1 -> boot hang.
  • I now tried to flash 14.1. again, deleted EVERY cache, dalvik, data, system, etc. 14. Won’t install (only if I disable the checks in the image, which as a BadHack)
  • I tried to re-flash 15.1 nightly, no difference.

I have some experience in flashing phones, so I can’t understand what’s happening now:
I am now in the weird situation that:

  • I can start TWRP recovery mode using Pwr+VolUp buttons, but as said, flashing using TWRP directly or using sideload does not work.
  • BUT: I cannot start Download mode: Pwr+VolDown just shows the FP logo, and stays there. Same when I start TWRP (where adb detects the phone) and calling adb reboot bootloader - the download mode simply does not start.

Has anyone an idea, as my phone is completely unusable ATM, besides starting TWRP?

That’s a feature. I mean, on the FP2 this is the fastboot mode.
On the PC commanline, do you get any output for fastboot devices? Only if you have installed fastboot, of course :wink:

4 Likes

AAAAARRRGGGHHH.

Yesss. I was so used to “Download” mode screens of other phones.
Whow. How could I miss that. Thanks man, you saved my day.

Which checks? No custom ROM ever has been able to verify its signature.

You’re welcome.

On Twitter I saw someone recently also not realizing he was in fastboot all the time (and commenting about “how can it be called fastboot when I’m waiting since 20min?”).
He then suggested to give at least some visual hint. Not a bad idea, I guess.
But I’m not sure who’s the one to do that? Fairphone? Some fastboot devs?

Fastboot is just a protocol that’s implemented in a fork of the Little Kernel (lk) that’s being used as a bootloader by most Android devices.

I’ve created a patch a while ago to do exactly that: https://github.com/z3ntu/android_kernel_lk_fairphone_FP2/commit/618462b437427160d69a5fe8d34269036e80ad32
EDIT: That branch displays the text but there’s some weird stuff going on with the display, so I can’t recommend trying it :wink:

2 Likes

@z3ntu, @Ingo : Yes, a hint would be a good Idea. I saw this recently on my Samsung Galaxy SII (running LineageOS 14.1)

@Roboe: The " Can’t install this package on top of incompatible data. Please try another package or run a factory reset. Updater process ended with ERROR: 7" problem. See Can’t Flash LineageOS

You can work around this by removing OS checks in the updater-script. Which is generally a Bad-Idea™.

Certificates mismatch. You are flashing on top of incompatible data, indeed, so you likely come from an unofficial LOS 14.1 build. In that case, if you got that unofficial build here in the forum, you need to flash the migration ZIP listed in that thread —which changes certificates—, before flashing 15.1. This is not an error, but a safety check, so removing the updater-script assertions is futile.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.