"No Fairphone 2 found in fastboot mode" error when flashing Open OS

I am trying to install the Open OS on my FP2. I am following these instructions.
However, when I run the flash script through sh flash-for-unix.sh (on ubuntu) i get Error:No Fairphone 2 found in fastboot mode.
The phone is obviously connected to the computer and in fastboot mode.


hope I don’t ask the obvious, but did you put a “sudo” in front of your command?
Or did you switch to root with “sudo -s”?


I did pur sudo in front of the command. Actually I tried both with and without sudo, nothing worked. However I think that this could be determined by a bigger issue: i just noticed that when I simply connect the phone to my ubuntu laptop, it is not recognized. The strange thing is that my previous FP2 (recently lost) was correcty read by my laptop.

I had a similar problem on mac when doing the manual installation, but not with Open OS(!), just the standard OS version.
But maybe this could help you as well.
It worked by replacing the ‘fastboot’ file (inside the ‘bin-darwin’ folder) from the ’ [FP2 - Binary images of Fairphone OS 19.02.1]’ download with the one I downloaded from the ‘platform-tools’ here:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.