English

No Connection from FP2 to PC

usb
Tags: #<Tag:0x00007f000d988d48>

#1

Hello, I cannot connect my FP2 via USB with my notebook any more (Win7). The day before, immediately after the OS Upgrade to Android 7.1.2, it worked without Problems (import backup via MyPhoneExplorer). Now after plugging in the cable (the same one that worked the day before) nothing happens, neither the phone nor the notebook recognise the connection (I tried two other data cables - same result). Reboot of the phone doesn’t change anything. Any Idea?


#2

There are two different things at play here.

MyPhoneExplorer works via USB debugging (when connecting via USB instead of WiFi or Bluetooth) and needs no further interaction (well, depending on the setup you may have to start the MyPhoneExplorer client on the phone manually).

For normal file transfer via USB since Android 6 you have to swipe down the notification area and change the USB connection mode from charging to file transfer (MTP).

What exactly doesn’t work now … MyPhoneExplorer or MTP?


#3

When I connect my FP2 with my Notebook via USB data cable, neither the Phone nor the Notebook recognizes the connection. I even don’t get the initial notification to choose. Yesterday the connection worked without any problems. Last action yesterday was the connection with MPE - I don’t think that MPE caused this problem.


#4

Hello @Carlaphilippa

Not sure if it is the same in Android 7, but try this:
.
Disconnect the Phone from your PC.
.
Go to the settings, scroll down and tap on phone info.


.
.

Scroll down again and tap 3 or 5 times on Build number.


.
.
Now it says “You are a developer now”
.
.
Tap the back button. You are back in the settings menu. There now should be a new point that says “Developer options”. Tap on that.

.
.

The Dev options are off right now. Because with great power comes great responsability.
.
Turn them on by tapping " On" and OK


.
.
Now that the options are active, tap on USB Debugging and OK.
.
.
Edit by @AnotherElk:
Scroll down some more to “USB connection mode” and tap.

.
.
Choose MTP

.
.

Connect the phone to your PC. Windows now should go “Bading!”


#5

Additionally, while you’re there, you can set the default USB connection mode to MTP.
The notification procedure will stay as it is, but this setting helped some users, too, in the past.


#6

Thanks a lot, that worked. I didn’t know how to get back to the developers menue, now I can deal with it.


#7

Hi. I am having some difficulties in transferring photos taken with the Fairphone to my laptop. Can someone help me with this. I cannot seem to find the USB transfer icon on the phone…

Stefan2


Camera Error: Can’t connect to the camera
#8

I moved your post to this topic …

  • Connect your phone to your computer.
  • Then, if you swipe down from the top of your screen there should be a notification about the phone charging via USB.
  • Tap on the notification to select a different USB connection mode, you want to enable MTP for normal file transfers. The phone’s storage should then become visible in the file explorer on your computer.

If this somehow doesn’t work, have a look at this earlier post …


#9

Thank you Anotherelk…it worked…

Stefan2

AnotherElk

    February 18

alt stefan2:
I cannot seem to find the USB transfer icon on the phone…

I moved your post to this topic …

  • Connect your phone to your computer.
  • Then, if you swipe down from the top of your screen there should be a notification about the phone charging via USB.
  • Tap on the notification to select a different USB connection mode, you want to enable MTP for normal file transfers. The phone’s storage should then become visible in the file explorer on your computer.
    If this somehow doesn’t work, have a look at this earlier post …

#10

Hi,

I have exactly the same problem (can’t find usb connection), but impossible to fix it. I tried with 2 different data cables (OK with other devices). I activated the dev options, usb debugging, and changed “USB connection mode” on “MTP” but nothing seems to change… do you know other tips to try?
(Sorry for my english!)
Thanks in advance for your reply

Manuel


#11

You still have to use the notification …

If that doesn’t work for you … which OS do you use on the computer side? Windows? Some Linux? macOS?


#12

I don’t receive any notification. The OS of the computer is windows 10.

Manuel


#13

any other idea? i tried with several different cables, but no way to have any notification, with developer mode activated or not…
i can no longer access to the phone via my PC…


#14

Hi…my camera on my fairphone just went crazy…i can no longer take photos. Camera icon cannot connect to phone…Images are blurred and distorted. I cannot fix the problem. Can you help me by giving me some suggestions…camera is only 4 months old.

Stefan

AnotherElk

    February 18

alt stefan2:
I cannot seem to find the USB transfer icon on the phone…

I moved your post to this topic …

  • Connect your phone to your computer.
  • Then, if you swipe down from the top of your screen there should be a notification about the phone charging via USB.
  • Tap on the notification to select a different USB connection mode, you want to enable MTP for normal file transfers. The phone’s storage should then become visible in the file explorer on your computer.
    If this somehow doesn’t work, have a look at this earlier post …

#15

Did you try a different USB port on the PC?


#16

Assuming you mean the rear camera …

Other options:

Online Troubleshooting / #contactsupport

#fairphoneangels (who could perhaps help you checking whether a different camera module would work by swapping it)

That part of @stefan2’s post was just an old quote, this issue was resolved.


#17

I was replying to @Manuel_M


#18

Ah, sorry … if only the forum would show me that :slight_smile: .


#19

Yeah, I didn’t quote


#20

Yes of course, and different compters … i’ve also noticed that i can no longer de-activate developer options menu, I don’t know if it can explain the bug or is related to it…