English

Camera Error: Can’t connect to the camera

Tags: #<Tag:0x00007f05f7076918> #<Tag:0x00007f05f7079168>

I have suffered with the crashing FP2 camera for some time, Fairphone sent me a replacement module last summer. I have tried the hardware-based advice, but the problem always re-appears. For me it appears to be a software issue.

I found that 3rd party apps could launch the camera when the stock camera app failed, and this would temporarily fix the problem. I concluded this is an Android problem, and so no point in replacing or trying to fix the camera module. Android 7 update made no difference and the camera has since got worse.

I found this advice online from Google via user Josh Hudsy at androidcentral.com:

"Go to Settings > Apps,Camera, and then touch Force stop.
Go to Settings > Apps, Camera, and then touch Clear cache.
Go to Settings > Apps, Camera, and then touch Clear data. Caution: Any data saved in this app will be erased.

Then restart your device without opening the camera or any other applications that use the camera "

I tried this last week and the camera has been great! Beforehand, the camera would mostly fail. Since I did the above, it has failed only once or twice for many launches over 4 days!

Hope this helps.

2 Likes

uhmmmm, you’re a genius! thanks, Iain! i did what you suggested and after not working (at all!!!) for the past week and longer rather than once every ten times, it actually has worked immediately now! and another time for verification. i’ll report back in a few days how it evolved. thanks again, dude.

1 Like

That sounds like a good plan - but you need to move the photo files off the phone surely, or are they left in place?

I press the camera and screen together when the camera shows the purple lines. The camera then behaves itself - until change apps. The force stop / clear cache / clear data / restart approach sounds like a longer term solution. I might try without doing the clear data step.

unfortunately… it’s already screwed up again :slight_smile: 100% also. literally every time i try now it’s again the purple glitch thing again with “Cannot connect to camera”.

too bad :confused: (and kind of enfuriating :))

2 Likes

That is one of the fields, where Fairphone needs to do their homework. Fix new-camera-module related bugs and look into Wifi issues with Android 7+. Currently no one seems to know, WHAT or if they are working on any important bugs or if now what is happening in the development team :-/.

I have experienced the same issue with the new FP2 generation (bought June 2018).
The disassembling/reassembling “solved” the issue for my phone only for a couple of weeks, before I had the same issues (over) again.
Now I have found a “solution” that is stable for months which I would like to share here (maybe worth trying for some of you):

The main camera module is tightened by three screws: two screws at the electric contacts and one screw close to the camera lense. The latter (screw close to lense, see picture below) I did not tighten during reassembling - instead I kept it almost completely loosened (maybe you can also just remove that screw completely…).

This way I hoped that the electric contacts are more stable (without any forces bending the piece away from the contacts). For me, this works now reliably for months.

Hope this helps!

grafik

5 Likes

Hi there…i tried your suggestion a few times…but still no results…this fairphone 2 is only one month old…i am losing faith in this product already…any other ideas that might be helpful…
camera does not connect…please help…
Stefan

#contactsupport ?

1 Like

I had the same problem as you, I contacted the support and was sent a new camera module (free of charge, since my phone also was new) free of charge. I had to reinstall the new camera module one time but after that it has been working perfectly.

Hi again…I solved my problem. I did a reset and the camera now works but it still reboots immediately when I turn the phone off…

Sounds like one of the known bugs:

Just a li’l update:

Before emptying the cache it rarely worked. The hours after cleaning the cache it worked perfectly, then not at all. But these days it works often, and when it doesn’t I just shake it a little bit to… (paradoxically) “stabilize the image” and it mostly works now.

Which is, of course, nothing even remotely close to how it should be aka just working perfectly all the friggin’ time :stuck_out_tongue:

1 Like

A post was merged into an existing topic: No Connection from FP2 to PC

@mamue Your tip helped my colleague, simply bending the contact tongues worked perfectly for him. For myself it is not resolved yet, so I’ll try cleaning the contacts later on.

Thanks a million though.

2 Likes

OK, I’ve just tried your trick with the camera screws and I loosed off the top one. I’m a bit pessimistic though because it wasn’t tightly screwed in anyway and it is the two other screws at the bottom of the camera which seem important - they are either side of the contact plate underneath. I’ll report back when I’ve got something to say.

OK, I followed your advice @FairFlo and a month later I haven’t had a single recurrence of the issue. Hope it works for everyone else. You do need a tiny screwdriver though :smile:

2 Likes

This just happened to me, with an FP2 I’ve had for just 2 months. It happened a day or two ago then worked again - so does seem like a dodgy connection somewhere. Going to try the re-assembly and see if it goes away…

Exact same issue - new phone, within 1 month getting this exact camera failure. Can do a temporary fix by disassembling phone or doing a power cycle, but come on…

Really frustrating - and hurting the reputation of fairphone - if you look online you get repeated reviews citing the same camera failure.

Totally support the idea, but honestly between this and random overheating, cannot recomm
end this phone to others, even with the ethical credentials.

Watch this, especially my post #70. Even if the thread is in German the pictures talk for themselves and Google Translate could do the rest.

Up to now I never had to face these problems again.

LG, Philipp

1 Like

Today somebody can to me (I am a Fairphone Angel) with a refurbished FP2 which camera worked in the beginning .
After a few week the camera couldn’t connect any more.
Installing the OpenCamera didn’t solve it.
So I removed the main camera and put it back.
And the problem was solved.

1 Like