No Birthday field in contacts

So my Fairphone 2 arrived and I manged to install Open OS (17.12.1 which right away updated itself to 18.0.1.1) . One of the discovered issues so far, my contacts don’t have a field for the birthday.

I read this thread (closed 4 days to early :wink: ):

but the given link to the feature request is not accessible to me so i can’t check what has been discussed there.
So I imported a .vcf file from an Android 6. which I had for test purposes. There it was no problem to have birthdays. When looking at the file with an text editor the information is present. On the phone now this information is not visible. But when exporting my contacts again the information is still present in the file.

Is this still an issue or just me? Is it worked on? Any solutions other then the workarounds presented in the linked thread? Does Lineage OS has the same problem? (Is there an overview of features of FP Open vs Lineage OS? (I would be interested in working one one.))

I was also under the impression that it was possible to add a “group” field to the contact or “anniversaries” on my test phone which is also not possible here at the moment.

Edit: I have the same problem with LineageOS but “groups” are supported here.

I’m on LineageOS and I just checked: when I edit a contact I can scroll down, tap on “additional fields” (I’m using German so that might not be the correct translation) and then I see the birthday field.

I am on FP Open and there is a field Date and below a drop-down box where I can select Birthday or Anniversary (actually Jahrestag, not sure what the eng version makes it)

1 Like

Strange. That sounds how I remember it from my test Android phone. Do you have a sync account active? And I assume you use the standard App.

@Ingo Thx for the answer, can I drop you a pm with some questions about LineageOS?

So I installed LineageOS (the build from today) today and to my surprise, I still don’t have a Birthday field. But I have groups now. I’m a little confused as to what is going on.

I have the APP Birthdayadapter but that should just put the dates into the calendar

Do you have a google account set up for the App? I tried to set up a non google e-mail Account, but this didn’t help it.

@Ingo How about you?

I guess I will try this later on (Creating a google account). I just have no idea what can be possible be done in the App, to cause such problems. And that not more people are effected. It is hard to imagine for me to be the only one without a google account.

No Guhgel account, just DAVdroid-Addressbook, Synthesis (a proprietary sync tool to work locally with Evolution etc.).
Can you make a screen shot of the fields you have when you go on a contact on “further fields”?
There I have: Name, Alias, Picture, phone, mail, address, Date, company, position, notes, chat, sip, web, kind of relationship.
If I select a Date, I can add the type of date, e.g. Birthday.

If I try to add a new contact and click on “more fields” I have:
Name, Phonetic Name, Nickname, Company, Title, Phone + type, SIP, E-mail + type, Address +type, IM + type, Website, Notes, Group Name in this order.

Now I am at my wits end. sorry.

The contacts App Version is 1.4.22 an it states: com.android.contacts
I don’t have any type of GApps installed. Could this be it?

So I did some more reading. This thread (German):

sounds promising (even tho it is 2.5 years old). I will try that tomorrow and report back.
The main idea is, to have some sort of (e-mail) account connected to Contact App and “using this to store the contact” instead of storing the contacts locally on the phone. I think the thread linked in my first post is actually aiming in that direction as well.
We will see…

Mine is Kontakte 6.0.1

I have all my contacts in my private owncloud server. I sync with “CardDAV-Sync free”. And my Contacts app version is 1.4.22 as well.

From the rest of the thread it seems the problem is storing contacts locally on the phone.

So, I have a partial solution by now. I’m still not sure why the solution works and others don’t but anyway I will write it down for the moment as it is.

But first of all, thanks to @Ingo and @DietmarP for their continuous answers.

Since I tried so many things I will try to structure it a little.

  1. So, from within the contacts App you can click on the 3 dots and choose manage accounts. At least that was the default for me. I could then click on “Add Account” which always opened a windows asking for an e-mail. I suspect as default the idea was an exchange account.

  2. I entered a account which works with imap. After setting this up I could not choose this one in these settings. Which doesn’t come to much of a surprise from a technical point of view but oh well I tried another one. What I did not try was a Google account.

  3. Next step was to install an App called DAVdroid which can be used to sync caldav and carddav things. Since my main e-mail account does not support such things I went for a “web.de” account because I suspected they support features in this direction.

Setting up the account was easy and worked out of the box. Understanding the result was not so intuitive. In the end this account gave me a CardDAV and a CalDAV entry. In order for things to work at least the CardDAV entry has to be checked.
To prevent uploading to these servers anything I tried to disable any automatic syncing, within this App. Within the Contacts App and also via the Account Settings of the general settings. Testing showed that this was not successful so I tried to alter the account settings in such a way that at this point things will fail what has proven to be the most save solution.

  1. With this set up correctly it was now possible to select via the Contacts App Account Manager the DAVdroid Address book account. I exported all my contacts and when importing them again I could choose now the DAVdroid address book and behold, the birthdays are shown again.

Finish.

To me it still not clear how and when exactly I added the correct account and why it was possible. Also the “Account Manager” started from within the Contacts App is different from the one under the general settings, even though they look similar (Which makes sense in the end). I think in the end the trick was to select the DAVdroid CardDAV which I set up, via the system settings Account manager. Because there it was possible to choose this directly (DAVdroid has two entries there, one explicitly has Addressbook in its name). But it is also possible that the system recognizes this automatically and I just didn’t have the CardDAV checked correctly within the DAVdroid App.
What also became quite visible during this extended workout. The calendar App has a similar issue. It is not possible to have a dedicated calendar locally on the phone. At least my first superficial tries strongly indicate that.

To point 1. I actually manged to end up in a state where I didn’t have the setting dots within the Contacts App anymore at one point. This was when I unchecked the CardDAV account within DAVdroid and had an empty address book.

Summary: You need an address book account (e.g. e-mail CardDAV, exchange,…) on your system which is able to sync contacts in order for it to add it within the Contacts App to have the Birthday field. I have not found a stable way to disable the sync functionality so far an invalidated the account credentials after set up (resulting in some error messages sometimes).

Any questions or suggestions, feel free to contact me.

1 Like

In my contacts app (I use Fairphone OS and have version 18.01.1) - which I am pretty sure is the native Contacts app provided with my FP2 (updated since receipt just over 2 years ago), I have ‘More Fields’ (at the bottom of the screen. In ‘More Fields’ I scroll down to ‘Date’ and below ‘Date’ (after clicking on ‘Date’ and then cancelling the pop-up window with date selection, I can see ‘BIrthday’.

Not exactly the easiest to find, but ‘Birthday’ is there!

see my input further down on this (using Fairphone OS 18.01.1).

No it is not there unless you meet the correct conditions, as outlined in my last post, just above yours (which you don’t seem to have read).

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.