No Auto-sync for Google account with MicroG


I’m using Fairphone Open OS and I installed some weeks ago microG to be able to get my Google calendar. I logged in using the Google Calendar and I’m able to see all the events of the calendar. So it works.

However, it doesn’t sync automatically (I think it never did since the beginning). Worse: if I go to “Settings > Account > Google > some-email” to try to sync manually, it does nothing.
Only way to make it sync again is to delete the Google Account and recreate it. Which you may understand is not really a solution.

Do you have an idea if some auto-sync option may be disabled somewhere? I found no settings like that.

Here are two screenshots of my phone:

Sync is off and no way to put it on

Thank you for reading me,

I don’t know if microg is supposed to have that function. Why don’t you install openGAPPS instead of microg if you want to use Google anyway?

1 Like

Hi, you could try to use acaldav. See this post: Google calendar without google play service

1 Like

He maybe depends on Google for the calendar but not for any other thing. microG has a lot more benefits than GMS (mG doesn’t have system permissions and is open source, thus controllable).

There’s a Google app (part of Google Mobile Services) specialised in that, the Google Calendar Sync Adapter ( That can be the problem.

The forum thread @chrisse posted’ll be useful for you. Instead of aCalDav, you could use DAVdroid, too. I’ve been using for three or four ages and had no problem at all. They seem to be very competent and up-to-date with compatibility issues.

1 Like

Yes, I only need Google for the calendar because of my work. I would like to have as less Google software as possible. I forgot to mention that I don’t have a simple gmail account, but a Google Apps account it may perhaps differ.

I tried yesterday evening what you gave @chrisse and I could get the calendars owned by my Google Apps account, but not the ones which are shared with me.
And this morning I got aCalDav errors because it can’t resolve host. Weird, I can connect, but some moments later it gives this error.

I had already DAVdroid installed so I first tried with it as you said @Roboe, but it kept trying to connect.

Don’t you think it’s just some option to enable somewhere? As currently I can already have all the calendars I need with microG. It’s only they don’t refresh regularly.

I also had issues with DAVdroid, which is why I tried aCalDav.
Did you try this?

At the beginning I also had only the main calendar, but not the ones shared with me. After the new try with the shorter address (without /events), it worked.

1 Like

I think you need to “disable secure logins” (sic) somewhere in your Google account from a browser. I guess there are instructions somewhere in the linked forum thread (I can’t search right know)

(If your shared calendar are public and read-only, you can have a look at ICSdroid, but I think it is not your case)

@chrisse Yes I first tried with DAVdroid and then with aCalDav. I directly tried with without the /events at the end. I did it twice, and got several calendars created by myself, but not ones that are shared with me.
Just now I tried this time with the /events at the end and I get exactly the same calendars as without /events.
Furthermore, after a while, aCalDav kept telling that it couldn’ t connect and resolve So I completely deleted the account because aCalDav was spamming with its connection errors.

@Roboe Yes I already disabled secured logins in my Google account before when I tried with microG. And yes, the shared-calendars are not public :confused:

Do you think it’s more complicated because it is Google Apps?

I still find it weird because with microG I could get all the calendars I wanted. It’s only they don’t get refreshed.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.