English

No access to fastboot or bootloader, enters OS just fine. Is it hardbricked and is there a flashtool that can help me?

I originally made a post about it over at XDA, but I thought it might be a good idea to post it here too.

So earlier this year a friend of mine asked me to install lineageOS on his fairphone, do I did. It worked just fine back then, but now he has come to me with it, complaining that he can’t update it. Tried to access fastboot and bootloader through physical buttons and through advanced restart, but it just reboots back into the OS. He doesn’t get any OEM unlock warning when he reboots, so I thought that he might have locked it somehow. Saw in a reddit thread that you could re-unlock it though

adb root
adb shell setprop ro.oem_unlock_supported 1

and tick an option in the developer options menu, but I just get an error when trying to set it. Is this classified as a hardbrick? I know that there are flashtools out there that can help you with that without the need of fastboot (at least for Fairphone 1). I just want to know how I’m supposed to move forward from here. Every single advice would be appreciated.

Thank you.

Edit:Seems to be the same problem as LOS 15.1 - Reboot to recovery unstable?. Anyone has a fix for it?

Edit2: Ingo told be that a possible fix would be to enable the torch and restart with it on. Will try it next time I have access to the phone and will close the thread if it works.

Edit3: Ingo’s tip about enabling the torch before restarting worked just fine. Problem solved.

4 Likes