NFC to Abbott Freestyle Libre broken in 8901.4.A.0016.6 [FIXED in 0017.3]

I am using the Freestyle Libre 2 app on my phone, which uses NFC to connect to and read data from a glucose monitoring sensor i am wearing. (type 1 diabetic here)

After installing the latest android update yesterday the NFC service on my FP3 seems to be broken. When trying to read data from the sensor the app tells me that it is not able to.

The app has exhibited two different behaviours, depending on the circumstances, when trying to read data from the sensor:

  • It initializes data reading as normal, but then tells me it is not able to
  • It immediately tells me it is not able to read data

The difference in behaviour seems to stem from whether i have restarted the phone before trying to read data or not. If I have restarted the phone, the first attempt at reading data will exhibit behaviour 1, any subsequent attempt will exhibit behaviour 2.

What i have done so far:

  • Restarted the phone multiple times
  • Cleared cache and storage of the NFC-Service system app as well as the Freestyle Libre app
  • Verified that it is not a hardware issue by checking if NFC works using the Service Test as described in the following post: No NFC setting on FP3 - #2 by anon9989719

When doing the service test, the sensor i am wearing will be picked up by the NFC service and displays the sensors Tag ID. Also, reading data from the sensor worked until I installed the android update, afterwards it did not work anymore.

So my assumption is that the latest update has broken something within the NFC service system app, which blocks any actual data transfer. This is, in my opinion, confirmed by the behaviour described above, where a freshly restarted phone will try to scan the sensor before quitting with an error, while any subsequent attempt is immediately quitted with an error.

What options do I have to further narrow the issue down or maybe even solve it?

As you might understand this is kind of a serious issue for me. The immediate health concern is negligible, since there are other ways for me to monitor my glucose levels. But at the very least the current sensor i am wearing is trash if i dont get the app to work again, since i am not able to transfer the sensor to any other reading device. And the long term prospect of not being able to reliably use my phone for his kind of thing is kind of offsetting.

System info:

  • Android 11
  • Build 8901.4.A.0016.6

For the sake of completeness could you add the exact Version number oft the update? There is already another report here

I would strongly suggest to report to Fairphone support and make this an urgent issue


Thank you for your immediate reply and the link to the other report. I did not realize there was a topic for each update. I have added the build number to my inital post.

I will contact the FP support then.


Hi all,

I have the same issues as the first poster above. I have already notified Fairphone. But the solution to start the phone in safe mode doesn’t work, because I need the Librelink app to run on order to scan the NFC device.

Hope Fairphone finds out fast what they have misdone…




Thanks for posting. The same thing happened to me also today. My phone updated and suddenly my sensor (that had been working perfectly fine for 6 days) stopped working and I keep getting the unable to scan message. I tried a new sensor and still the same thing. I contacted Abbott and they went through all the troubleshooting options with me before deciding the only option was to send me out two new sensors (which I’m almost certain will also not work). It’s really frustrating as I rely on this for my health and have no idea what to do! Have you made any progress at all? Thank you!

System info:

  • Android 11
  • Build 8901.4.A.0016.6

If this worked before the update and if you need a quick fix, the previous Fairphone OS version is currently still available here …

The installing process will force a factory reset i.e. deleting your data as well as the Apps you installed and their data.
If you’re uncomfortable with this installing guide and if you happen to have fairphoneangels in your vicinity (<- see angelsmap) with Fairphone 3/3+ expertise, you could ask whether they would be able to help in person.
Else … we’re here, too.

And stating the pretty much obvious … You can’t really rely on a smartphone for anything, too many factors can make it fail suddenly for a particular purpose or altogether. For really important things you need an alternative solution to go back to.


Hi all,

I have the same problem since the last update, but unfortunately no solution yet. Just reported to Fairphone as well. Hope they will be able to fix this soon…

Best regards, kizorro

Hi and welcome to the forum.

If you are referring to the post above they contacted Fairphone officially so maybe that is the course you can take as this is only a user forum.

The post belew your shows a possible option but that is a bit of a chore and again as in that post people have made themselves very reliant on devices that are complex, such as a phone to monitor as you do.

Such a device has many reasons to fail and can precipitate issue other than failing to make phoen calls, which is the primary function. Dedicated devices are more stable and don’t require continuous software updates.

Hopefully you have a back up decive to help you monitor your concerns conveniently.

Hi amoun,

For what I know is nfc pretty old technology which is in use for many years. I haven’t heard yet of users of other phones which have the same problem.
There are millions of people around the world using the Abbott Flash Glucose monitoring system. And I have been using it with several phones now, never a problem, up until now.
I’d like to have my phone as secure as possible, but if quality control is a problem, maybe release the security updates in a later date.
I think I and all other users of the Blood Glucose mnitoring device will have a back up, but it is making life a bit more complicated (first world that is…). Hoping for a solutions which does not include a factory reset because of returning to the older software version.

Is there any other way to test NFC?

I just used a simple NFC card, wrote some data using NFC Writer app. Then I flashed the card and I was able to access the written data.

An alternative to using actual medical device to reproduce the issue would help point out the exact issue to them.


I have tried to read the data of the Bloodglucose Monitoring device using NFC Tools app. I can read the device well. But in order to really do something with the data being read from the device, I need the app Abbott is providing (LibreLink). It is almost like this app is not allowed to read the data. Since the update to the newest version is all about security updates by Google/Android, I have a feeling it is something like that. But I’m a mechanical engineer, not a software or electronics-engineer…

1 Like

Personally I agree as I don’t use banking apps, social media, location etc. However many people do so security updates are a priority for a larger user base I imagine.

There’s this update ~ not sure if it is relevant or helps

1 Like

Thank you all for the reports and additional information you provided. Software updates undergo a lot of testing but unfortunately sometimes bugs still slip through.

So far it seems that the issue is isolated to the FreeStyle LibreLink app. This has been reported but it will take us some time to properly identify and fix the cause of the issue. We know you still need the information from your sensors in the meantime, so there are two things you can do:

  1. Try to read the sensor with another app, for example Glimp as recommended in the comment above (thanks @anon9989719!)
  2. Manually downgrade to the previous version of Fairphone OS. We know it can be a hassle because it causes a Factory reset and also involves some degree of security risk due to the older security patch level. That said, if you need to use LibreLink, at least for now, there is no other solution that we are aware of.

Thanks again and sorry for the caused inconvenience!


Hi folkes, I am having the same problem. Updated the FP3 yesterday and since that time, the sensor can not be read anymore.

Had a call with Abbott support and they told me lot of things, even that FP3 is not supported smartphone for the app. Which I think is a poor statment!

The combination worked for me nearly 1 year whitout issues.

Today I attaced a new sensor, but it can’t be read like the old one. The FreeStyleLibre 2 Reader was still able to read the old and now the new one. So I have workaround in place to get the basic stuff.

I also tried to uninstall the app and did a new install, including reboot of the FP3, but doesn’t work at all.

Use the app for my personal ID card, to the read it, and that read action worked.

So it is really a problem with libre app and the security update. Rollback is not a option for me, that would cost me a lot of work to get all the other stuff back to the FP3.

Hope you guys will finde a quick solution to get the FP3 back to way before, that the sensors can be used with the FP3


P.S. Some additional information, because I read the alternative App for reading the sensor. Point is, that with the Libre app the information can be stored within the cloud solution and you can inform previous defined people (like family, wife etc.) about your current messurements. Also the data can directly provided to your doctor, who can than get a very detailed overview of the last weeks and months values. That is quite a good achivement and a much more easier way to life with that illness.

I have run in the same problems. I have contacted Libre Freestyle and they have sent a to me a Freestyle libre 2 scanner, after my old scanner peered out to be a Free Style Libre 1 scanner. I have now renewed my sensor 2 times (1 for the old scanner and 1 for free style libre 2 scanner). A sensor can only be read with the device which has started the sensor.



1 Like

Hi Marco,

your last sentence is not correct!

You can activate the sensor with Libre2 device first and use the smartphone as 2nd device.

The only point ist that the 2nd device can not use the alarm function.

User that so all the time with both devices :wink:

1 Like

I have the same problem. After the update 8901.4.A.0016.6, I have “scan error” each time, I try to scan the sensor.

Same problem here. I rely on the phone to get glucose readings and it’s a huge inconvenience having to switch to alternative tools.

It would be good if anyone can capture adb logs when the scanning is done(and the error is shown).

adb logcat -c && adb logcat -b all > nfc_issue.log and adb logcat -c && adb logcat -b all "*:E" > nfc_issue_errors.log the next time.

I am just curious to understand what’s going wrong and see if I can do something.


1 Like

Hi everyone,

Instead of the adb logcat logs as @TeamB58 mentioned, it might be easier to grab a “bug report” on the device after the scan failed, see:

You can upload the zip here:

Also for anyone familiar with this sensor, is it possible to read anything from the sensor fresh out of the packaging without it being applied on the arm for testing purposes? If that would be possible we can buy one to test and debug in the office.