New software update Kola Nut 1.8.5 is ready

Hi I have updated my fairphonne and reinstalled Google Apps from the widget as told, but it keeps telling me that a new update is available, and I can just keep doing it over and over again. Can it be true?

I tried “Empty cache” and “Erase data” but it’s still the same. It keeps checking if there are new updates. Otherwise it works perfectly.

I have the some problem with the Android Keyboard stopped. I though I could use the Fairphne without installing the Google app store. After all we are offered the choice to install or not, or don"t we?

Please help me to install the old version on this Phone for gods sakes!
I am sorry but your forums are not understandable for me and any tutorials are not helpful.
I tried this but I get an error when installing the 1.6. Version.
this Update is impossible!
I had so far no troubles updating the phone and I liked the slight changes of the previous Versions, but this updates takes away what the fair phone was standing for for me!

No free space anymore - you want me to spam my screens with tons of apps just like any other cheap phone out there?? no thanks, I enjoyed the blank spaces and the ability to launch apps from the hidden side swipe- that was innovative and great about fairphone! It made the fairphone worth it!

the swiping! where is that now? I don’t see any option to enable it? are you serious? it is the only way I can type on a phone/ Again its something innovative and great and now it is gone???

You make me force use google search with the ever present google bar now?? that is no longer fair and autonomous, and do as you please, dear user, as how you were selling your phone so far!

concluding - everything the FairPhone was good for is gone now.

Please help me reinstall the old version or I am going to sell this phone off on eBay. And I am sadly not the first one of my Fairphone Friends planning this by now!
Already the fact, that it is not possible to buy a single cable, which got a loos contact with the phone, but only the charger itself, is ridiculous and not matching with your, you can buy any part extra shows how much lies and not working customer support options are going on here!

I need the previous version to be able to keep using it! Thank you!

If you have used Google Apps previously, the FP thinks you would like to keep using it. If you don’t want to install Google Apps again, you have to choose the AOSP keyboard in the settings. Here is how to do that:

Go to Settings > Input and Language and tick "Android keyboard (AOSP).

If you have critics to tell the Fairphone team, please do so through Support. This is a community forum populated by FP-users like you and me.

I’m sorry to read about your problems. It seems you accidentally installed plain AOSP (also called “Vanilla Android”) without Edge Swipe and the Peace of Mind widget/Last Used/Most Used widget. I’m afraid you will have to update to Fairphone OS manually, to get back these commodities.

Can you find the Fairphone Updater on your phone? Then you can update to Fairphone OS there. If not, here are some links, which should help you:

PS: There is also this topic:

Does the solution provided there suit you?

@paulakreuzer: No, my Problem is not solved yet. Can’t enter recovery mode nor anything else I know of. Do you know how I could bring it back to life?

Did you see this post?

1 Like


I might have been a little hard with my words. Sorry for that.
Nonetheless, the initial 1G/13G scheme was not sufficient for daily use and should have been solved way earlier so that users as myself would have never been tempted to do it themselves.

By now I followed the instructions (link somewhere in this thread, I think from @gsoundsgood or @paulakreuzer) using Flashtool, going down to v1.6 (unified partition) first and than using the fairphone updater.
After initial issues with the drivers to be installed it finally worked out fine (manual install both drivers + restart, Win 8).



Hallo Paul,

vielen Dank. Habe im Support eine Anleitung gefunden “How to install an update manually” und bin danach vorgegangen. Um es kurz zu machen: Kolanut 1.8.5 läuft nun bei mir tadellos; ich meine sogar, dass alles schneller geht, aber das bildet man sich auch leicht ein. Die Icons sind wieder kleiner (als bei 1.8), find ich gut, die “Systemeinstellungen” findet man wieder so wie “vor 1.8”. Ich konnte wieder alles herrichten, wie es vorher war. Fairphone ist wieder mein Freund. Und wenn beim nächsten update auch noch der wirklich nicht wichtige bug mit der “KLANGVERSTÖRUNG” behoben wird (ist ja nur ein Wort in der deutschen Oberfläche), ist es wirklich gut.
Vielen Dank für den schnellen Support


Hi, I thought everything had gone seamlessly with the update, but ever since I’ve been unable to open contacts. The info is there - I can access it through the telephone - but if I try and open the Contacts app it crashes immediately. Any ideas?

It seems that something went wrong with the update. Doing the update again should solve your issues. :slight_smile: (Go to Fairphone Updater > Advanced Mode > Android for Fairphone > Fairphone Kola Nut 1.8.5 > Install).

1 Like

I tried the SP Flash Tool solution but I can’t get it to work with my FP1.

I could install the drivers, but only when I activated the ‘apply update from ADB’ option. Before that, no USB device was visible. Is it possible that there are different FW verisions around?

When I started the download with the connected phone, then inserted the battery while holding the volume-down button pressed (I also tried the volume-up button in any combination with the power-button), a ‘Android Preloader’ briefly appeared and then disappeared again,after a second.

Any ideas why I might be doing wrong?

Ok, since, I don’t find any other topic on this update I just as well may ask here …

since the recent Software Update Kola Nut … I get constantly notifications to update Android Jelly Bean 4.2.2. the update itself doesn’t work, now reading that it is an alternative update blablabla I don’t get all the other stuff Im not a geek sorry… why the hell am I being bothered with these notifications to install it?

thanks for any help.

I am sorry but this comment is not at all helpful. Do you know language for non geek users? I hoped the Fairphone can cater these too. I have no Idea what you are talking about.

since that is happening all the time, I just tried out and installed “the old launcher” without knowing what that is because your leet speak does not explain it properly. It is all as it should be again … but I am bothered now by a “update to android Jelly Bean 4.2.2.” notification and have to constantly reinstall google app store.

IF you want to go back from stock Android to Fairphone OS use this Guide to do so:

To know which file to download check settings > storage: If you have an “internal storage” and a “phone storage” you need to install FP1_KolaNut_v1_8_5_OTA and then you can update the storage with Storage_Upgrader_1_8_5. If you allready have one big storage install FP1U_KolaNut_v1_8_5_OTA.

If you’re stuck anywhere else let us know. :smile:

Please help: have update done 4 times via Fairphone launcher, rebooting done, everything as described, however phone stucks to version 1.8 but lost GoogleApps. Googel Apps not re-installale, even not via Fairphone Updater --> goto --> Apps. Please help: How can I get the update? How can I get Google back?
Thanks a lot, Sonja

Go to settings > developer options > tick “keep screen on”, plug-in your phone and try the update again. Once the update is installed try reinstalling Google apps again.
If it still doesn’t work post back.


I installed the (broken) update version 1.8.5 via ZIP file from the recovery menu.
Since then I’m stuck in the gapps Installation loop. I’ve read this thread but I can’t figure out if there will be an update for those who are in my situation (e.g. 1.8.6)? Or am I missing a solution except flashing my phone with the right ZIP file, which is now online?

I am using OSX, so do you have recommendations which tool to take for flashing?

I’m not in a hurry. I’m using fairphone without gapps ever since. But now, I’d like to install some good open source apps, that can only be found in the stores.

Thanks in advance