New screen not working

After 10 months waiting finally got new screen and was delighted with how easy it was to replace. however screen is completely blank. I just get the startup vibrate sound but nothing on screen. any suggestions I have tried taking it in and out several times

It is possible that a newly shipped display module is DOA (dead on arrival), but there is also the possibility that whatever the issue is not with the display but with another module.
Did you have the same symptoms with the old screen and if not: what was the issue then and when/how did it start?

1 Like

Maybe you could locate a Fairphone Angel near you to test if the display is at fault.
You can have a look at the Communitymap if there is someone near you willing to test-swap displays with you.

On which Version of your OS are you?!

I think you’ll have to use the latest version. We have seen this problem in Lineage OS (see here, especially here).

1 Like

What @retsifp said about updating to the latest version, made me remember this article from the support site:

Copied from the link above:

We foresee two possible scenarios in which you might need to manually install a Fairphone OS on your device:

  1. The update through the Fairphone updater app fails
  2. Your new display stays black

Thank you for your replies yes it worked now that I put the newest update on it. The best ever wigit is gone though which has the most used apps down left side and most recent down the right. It came on my phone when I got it but not in my husband( bought same time) checked through all wigits but not there anymore . i think it was gone after update not after installing new screen…any ideas?

My fairphone’s OS 17.08.1 and still the the New display module wasn’t working yesterday. I’ll try agsin but first i would like to know whether I need to remove the plastic foil that is glued on the holes for the camera and the proximity sensor. (On my old display module those holes are open).

Encountered this issue with my new screen and Lineage OS myself today, so there’s something to it.

I’m 99.9% sure you’re just supposed to remove the foil and that it’s just there to protect during storage and transport :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.