Flashing LineageOS is not working

This is exactly what @Roboe meant I think! (It also makes sense, despite that info :wink: )
I hope this can be fixed soon :slight_smile:
I will stay close to the Porting threads of the forum^^

1 Like

Hey Lazalatin,

you’re not alone. I just received my FP2 yesterday, also a delayed delivery. Software version was FP2-gms- Today I tried to flash a recent TWRP (3.1.1-0) from the official TWRP site. When trying to enter the recovery mode with this, I get a blue screen too. Also, as you mentioned, the TWRP included in the fp2-sibon release works on my phone. After reading this thread I tried the newest available LineageOS build (lineage-14.1-20170808-UNOFFICIAL-FP2.zip) with the same result: a blue screen.
So I guess we have to wait for the new LCD driver to be integrated into TWRP and LineageOS.


So we’ll have to summon @z3ntu here too, he’s the maintainer of the FP2 TWRP-Port. :wink:

1 Like

I’ll work on updating the TWPR port soon.


Thank you @z3ntu :slight_smile:

I merged in the new changes for the kernel. It would be good to give it a new try. There’s also a new panel support or something like that. @z3ntu you should also do new twrp then :slight_smile:



And thanks for @z3ntu to ping me on this.


I tried basing TWRP on the omnirom 7.1 branch (with modified lineage device and kernel) but the resulting recovery.img doesn’t boot at all…

Can you please flash the recovery.img from https://private.z3ntu.xyz/fairphone/TWRP_3.1.1-0-new-kernel/ to your recovery partition and report back if it’s working? Thanks.

CC: @Lazalatin


Kudos to you, it works!
My hopes and dreams have been heard and fulfilled! :heart:
Much love to you all :slight_smile

EDIT: Is this new version still backwards compatible for all FP2?


Yes, it works on my phone too :slight_smile:

I installed this new image, and TWRP still works (with encryption, too).

Since the TWRP version number is still the same … In TWRP terminal uname -a is giving “Linux localhost 3.4.0-gea459bc #1 SMP PREEMPT Sat Aug 12 23:00:45 UTC 2017 armv7l GNU/Linux”

I’m not too involved with Linux yet, but the date in there sounds like it really is the new kernel, right?

Yes. I built the kernel yesterday. You can even see the hostname if my computer when running cat /proc/version in TWRP. :wink:

Just tried, works like a charm. Thanks for your effort.

Does this build work for both hardware? If yes: then I’ll update the instructions for OTA.

I think it is:

So it seems to work for both hardware revisions indeed :slight_smile:

1 Like

So next step, flashing LOS succesfully. @z3ntu started a build with the new kernel included. Can somebody with the new, and somebody with the old hardware test this release?

If this release works for both I’ll make this a OTA release.


You all are awesome, guys, :wink:


Just successfully flashed the current test build (12th August) on my (1 year old) and on my wife’s (1 day old) FP2 :smile:
Thanks a lot @z3ntu @snevas


Thank you! Just to be sure, your wife’s phone had the blue-screen issues before?