New camera, no flash, no torch light


bought the new 12MP camera module, installed it. Camera works, but no flash. Also no torch light. Disassembled, cleaned contacts, reassembled, still no luck. Installed the old 8MP camera module again, flash and torch light work as they should.

Is there something to configure to activate the flash/torch light of the new camera module?


Flash does not work while the flashlight works fine. Photos taken in bad light conditions are always too dark. There is a pre-flash and then the led is dark when the camera takes the photo.
Latest Open OS installed.
Has anybody else this issue?

I have this issue with the stock camera App in LineageOS.
Using Open Camera from F-Droid it works as expected, so is probably not a hardware issue.


My husband and I both got the new camera modules and both modules have the same issue; the flash/torch is not working. Anyone else experiencing the same issue? Also, my phone has started rebooting randomly once or twice a day. No idea if this is related, but it didn’t do this before.

Are you running the latest update of the Fairphone software?

Update: make sure your phone is running Fairphone OS 17.08.1, Fairphone Open or later versions. (Other operating systems are currently not supported.)

Yes, sorry, I probably should have added what I’ve done troubleshooting wise. I am running OS 17.08.1, tried the default camera app, Snap Camera and Open Camera and the Torch function. Doesn’t work with any of those.

That sounds like a case for Fairphone support then. Else you could try to disassemble and reassemble again.

1 Like


I do have more or less exactly the same issue; tried Camera and OpenCamera and the flash isn’t working either, nor is the torch function.

On a more or less unrelated note, the front camera also does far too dark images with the standard camera app, though OpenCamera does just fine here (so this seems to be a software issue).

I’m still running 17.08.1, does anybody know whether there were improvements in to the camera functionalities (don’t see any mentioned here:

Edit: Just tried de- and reattaching the camera module, and it didn’t change anything about the flash.

Edit 2: I just updated to, and now the flash works fine! Just the front camera still shows a far too dark image in the default Camera app (but works still in OpenCamera, so it’s fine!). Not sure if this is a white balance issue or something else… have to test that in daylight conditions tomorrow…

I contacted support on September 9, but have not received a reply yet.

The really strange thing is however that my husband received a new display and his camera flash works with the new display, but not with mine. We haven’t tried if my flash works with his display yet.

The same here: I contacted support 3 times in the last 3 weeks - no answer yet.
Flash doesn’t work.

I’m having the same issue with the stock camera app of the LineageOS ROM by @snevas

I’m having a brand new Fairphone 2 with both recent camera modules (12 MP and 5 MP).
Sadly I didn’t test the flash with the stock ROM before installing LineageOS. But I guess it’s a problem with the AOSP standard camera app, which is the default in LineageOS and probably in “Fairphone Open OS” too.

Use Google Camera app. (or maybe some other camera app)

I have this issue with stock camera, Google camera and open camera on Open OS.
I got an answer from support after a month and I’m waiting for an answer after reply two weeks ago - very unsatisfactory.


I have fp2-sibon-17.10.2. Tried with pre-installed camera app and torch light button among the system settings as well as with Open Camera and Open FlashLight.

All works with old camera, but flash and torch don’t work with new camera. Sporadically I get “cannot connect to camera”. But next attempt does usually work.


There’s now a bugreport:

Flash not working correctly on AOSP Camera app

So is there a solution? My OS is updated to latest version and using stock programs (camera, torch). I am happy with picture quality, but miss flash and torch…

I opened a support ticket. They sent me a new camera module. It worked immediately in all described scenarios.


The same here with LineageOS.
I now use the OpenCamera App from Fdroid and i have now better ,sharper pictures and the flashlight is working perfectly.