English

Netflix 5.x on LineageOS (FP2)

I can’t use Netflix 5.x on LineageOS on my Fairphone 2. Directly after start (before login) Netlifx is telling me:
| This app is not compatible with your device.
| You can download a compatible version from the Netflix website.

Could someone else with a Fairphone 2 with LineageOS please test this!?

You don’t need a Netflix account. It’s enough to test if the login screen appears.

If your device is rooted, you can install Netflix 5.9.1 from here:
https://www.apkmirror.com/apk/netflix-inc/netflix/netflix-5-9-1-build-24867-release/netflix-5-9-1-build-24867-android-apk-download/

On my “Samsung Galaxy S4 Mini” / GT-I9195 / serranoltexx* Netflix 5.x works fine on LineageOS 14.1. So this isn’t a general problem about LineageOS.
The “compatible” version is Netflix 4.x, which is missing some features of Netflix 5.x.
I’m using the official lineage-14.1-20171107-nightly-FP2-signed.zip and Netflix 5.9.0 on a recent Fairphone 2 with the new cameras.
I wrote some more details here: https://bugtracker.fairphone.com/project/fairphone-lineageos-on-fairphone/issue/22
Maybe related: Using LineageOS on the FP2

*Just also successfully tested Netflix on my “Samsung Galaxy S2” / GT-I9100 with LineageOS-14.1 and addonsu.

Unfortunately, I can not confirm it. Netflix works for me under the current Lineage.

Netflix should not work on rooted devices, but the FP2 on LineageOS is not (necessarily) rooted.

I just tested it for you; I’ve been able to install Netflix on current official latest LOS firmware (not rooted though).

If your phone is rooted, you could try to hide root. There are various posts on this in the forum about that topic. Unfortunately I have no experience with hiding root, so I cannot give you a concrete suggestion.

1 Like

@Stefan + @JeroenH
This has nothing to do with Netflix root problems!

Netflix runs fine on rooted devices. I’m absolutely sure about that, because I’m running Netflix on a rooted Samsung Galaxy S4 Mini.
There’s actually no root-blocking mechanism inside the Netflix app (I know some apps do that - but Netflix doesn’t). You just can’t install Netflix it from PlayStore on a rooted device. Instead you must use an APK file for installation.

Nevertheless, if LineageOS-Addonsu isn’t installed the device isn’t rooted by the definition of PlayStore and Netflix, and you can also install Netflix from PlayStore.

1 Like

@StevenHachel
Thanks!

Which version of the Netflix app did you install?
Some 5.x version?

And did you encrypt your phone? (internal storage encryption)
I encrypted my phone. Maybe it’s something about that…

Sorry sorry sorry…
my netflix version is the 4.6.1. Thought that would be the newest and therefore the 5.x. :slight_smile: I’ll download and test the 5.x.
But is not an official version from the Google Play Store, right?

1 Like

That might actually be it. My phone is rooted and encrypted.

I just tried to install the APK from APKMirror. Installation was successful, but when starting the App it complained that it was not compatible with my device and directed me to this Netflix site …

https://help.netflix.com/en/node/57688

While saying
"We are currently experiencing issues streaming on Android devices; however, other devices may still work. We are working to resolve the problem. We apologize for any inconvenience."
I was offered to download the 4.16.1 version APK there, and that installs and runs just fine.

Netflix didn’t complain about root.

1 Like

@AnotherElk
Thanks for that information!

Now that you (@AnotherElk) reproduced the issue we know, that the problem must be a combination 3 things:

  • Fairphone 2
  • LineageOS
  • Netflix 5.x.
    Because Netflix 5.x runs fine on the standard/stock Fairphone OS. And Netflix 5.x also runs fine on my “Samsung Galaxy S4 Mini” with LineageOS-14.1 (with addon-su). And any other apps I tested (including Netflix 4.x and other stuff like Spotify and many more) seem to have a problem.

I only thought about that phone-encryption thing, because I tried to find an explanation why it’s working for @StevenHachel, but not for me. Be the real explanation was, that @StevenHachel runs Netflix 4.x and not 5.x. (see @StevenHachel last message). So I guess we can forget about that phone-encryption thing.

We have another reproducer!

I had a chat with @StevenHachel, he installed Netflix 5.x and got the same error on LineageOS.
(Steven’s device isn’t encrypted, so that’s definitely not the reason for this problem)

Did you try to collect some logs with logcat in order to see if there’s some error somewhere during the use of Netflix app?
Bye!

1 Like

Found this on “help.netflix.com”:

Rooted or uncertified Android mobile devices are unable to download the Netflix app from the Play Store. Rooted or uncertified mobile devices are not blocked from accessing Netflix, but, depending on configuration, may not function properly.

More info here:

https://help.netflix.com/en/node/12983

that’s right, but you can download the app from other sources as well, and then the installation will fail, with version 4.x working.

Might just be the cause. (I know, it is quite illogical, but …)

https://download.lineageos.org/extras

@DjDas
Yes. I’ve put them into the bugreport I created.
https://bugtracker.fairphone.com/project/fairphone-lineageos-on-fairphone/issue/22

Exactly!
Nothing more, nothing less.

This means, rooted devices with LineageOS can run Netflix 5.x!
(like my Samsung Galaxy S4 Mini running LineageOS with addonsu)

As long as you don’t install addonsu (https://download.lineageos.org/extras) you can even download Netflix from PlayStore (I’ve tested).
That’s because without addonsu you don’t have root access (/system/bin/su), which is what the PlayStore is checking for.


But because of this is may be hard to get help from Netflix.

Rooted or uncertified mobile devices […] depending on configuration, may not function properly.


Luckily we know, that Netflix 5.x runs on the Fairphone 2, because it works fine on the Fairphone 2 stock OS (even on the FP Open OS). So it’s not a hardware problem.
And we know, that Netflix 5.x runs on LineageOS.

My current guess is, that this problem is something about:

  • a driver being different from the ones in the Fairphone 2 stock OS,
  • or a compilation setting being different from the ones used for other LineageOS build like the one for the Samsung Galaxy S4 Mini (serranoltexx).

Unfortunately I do not much about building LineageOS ROMs. So maybe someone can help who knows more about that.

Another idea, how to find out what’s happening:

ApkMirror shows, that Netflix 4.x requires at least Android 4.4 (API 19/20). While Netflix 5.x requires Android 5.0 (API 21/22).
https://www.apkmirror.com/apk/netflix-inc/netflix/netflix-4-16-1-build-15145-release/netflix-4-16-1-build-15145-android-apk-download/
https://www.apkmirror.com/apk/netflix-inc/netflix/netflix-5-0-1-build-16103-release/netflix-5-0-1-build-16103-android-apk-download/


But Netflix also says, that not every Android 5.0 device is compatible with Netflix 5.x.

The most recent version of the Netflix app for Android is not compatible with all Android devices running Android 5.0 (Lollipop).
https://help.netflix.com/en/node/57688


So this must be something about an Android ability/feature introduced in Android 5.0. But this ability/feature may still be disabled somehow in Android >= 5.0. And exactly that might be the case here.

The trick is to find out what possible relevant feature was added between Android 4.4 and Android 5.0!

I guess it’s maybe some DRM or safe storage stuff, so Netflix can safely store movies without allowing the user to copy them.

My bad, the Netflix app from Play Store installs on recent LOS 14.1 nightly but I didn’t bother starting it (I don’t have an account). It actually doesn’t work as it doesn’t start up. They suggest to download an APK instead of version 4.x. I started that version and it starts up, but I didn’t verify it works beyond that (again, no account).

So yeah, just to clarify: I can start up 4.16.1 build 200147 (didn’t play videos etc obviously).

That’s exactly the problem with Netflix 5.x we’re talking about. No need to login!

And yes, Netflix 4.x works but misses the very useful offline watching feature. That’s why it’s relevant to get Netflix 5.x running

My take is: I assume they don’t blacklist anything; instead they default to blacklist and whitelist platforms (device + OS) based on whether they are guaranteed not rooted. FPOS (@ FP2) is guaranteed not rooted, so Netflix whitelist that. LOS @ FP2 might be rooted so it won’t work. That an earlier, probably unmaintained version still works is by God’s grace.

Perhaps a community member who feels like leading could contact Netflix but without any given authority from the community (it not being an official port) I am not sure how far that will go.