Neither USB tethering nor wireless tethering work for me (Happy Móvil España)


"…
¿Puedo realizar tethering con Happy Móvil?

Si, se puede hacer tethering con Happy Móvil, pero recientemente
hemos descubierto un error debido a una actualización lanzada por parte
de Android, por lo que, si tu terminal tiene la versión de Android
4.1.2 o superior, es posible que no puedas hacer tethering.

En
iOS también se puede hacer tethering pero debido a una configuración en
algunos terminales también estamos teniendo problemas.

Estamos haciendo todo cuanto podemos para poder solucionar estos errores. En
cuanto sepamos más, lo comunicaremos en este apartado.
Lamentamos las molestias.
… "

your on the right track - I have android 4.2.2 - so above the 4.1.2 , which might be the cause -> any option you can see to do something about “downgrading” my android version ? ( even though it migh not be a very “clever” idea in general … )

You were a tick faster than me (see above)! :wink:

You cannot downgrade, as the Fairphone 1 never had a lower Android version. You should definitely give them a call as soon as possible and ask them if they have already fixed this (or can tell you how to fix it on your FP1). Android 4.1 has been around for over 3 years after all!

many txs - what do you think about the IPforwarding script I found already on another thread for Spanish sims ?

iptables -t nat -A POSTROUTING -o ccmni0 -j MASQUERADE

You can simply try it out. If it doesn’t work, no harm should be done. If you do, let us (me) know the result.

Other than that I can only refer you to this advice from a former Fairphone employee:

tried the first step, but su does not appear to exist :

in:
su -

output :
"/system/bin/sh: su: not found

any idea ?

installaing a “switch user” lib or so ?

Are you using Terminal Emulator?

yes - might be that I am not rooted

When you type su, the superuser request screen should come up. (only this time, for 10 minutes, always)

Edit:

also it shoud say root@FP1 before the cursor.

just found my edit - had to “unroot” phone due to security requirmente as I use my phone as well for work - I achived this “unrooting” via renaming the two su files (one in system/bin , the other one in system/xbin)

struggling now a little to revert only for this test the renaming - “root browser” does not give me the option; any ideas?

Accessing those files will be a bit hard, now you aren’t root on your phone anymore… :confused:
The first requirement would be to have your computer detect your phone, which also isn’t the case at the moment. It might be the easiest, if you simply install Fairphone OS Kola Nut again on top of your current installation. The files in the /system partition will be replaced, giving you back the su-binary.

No user partitions will be harmed.

PS.: If you need an unrooted phone for work, you could try RootCloak, which is a module of the Xposed Framework.

actually my laptop can view files connected only via USB - but I take it’s only the storage files - not the Android ones - correct ?

In case you haven’t noticed it, see the PS above.

Ah, ok, so your computer does detect your phone. I looked into adb, but I’m convinced that still you won’t be able to modify anything on your phone from your computer, if you aren’t root.

I’m afraid you won’t get around installing the operating system again. If the above tutorial doesn’t work because your lack of root, see this one: https://fairphone.zendesk.com/hc/en-us/articles/202478028

think the script did the trick - now pending is only to get the script as “permantly actioned” so I can “unroot” my fairphone again to be able to see my work mail on my failphone ;

any tip how I can go about this ?

P.S.
script :
su -
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o ccmni0 -j MASQUERADE

See my link to rootcloak above.

You will need root for the script I’m proposing (as far as I know you will have to execute it every time before attempting tethering).

  1. Create a file called tethering.sh in your / (“root”) folder.
  2. In the Terminal Emulator settings search for the entry “start command”. Enter su -.
  3. In the file tethering.sh enter the rest of the command @Enos wrote in the other thread. Save.

Now every time before using tethering, open Terminal Emulator and type sh tethering.sh. The script will be executed as root because of the start command.

I think that it’s my same problem…

but link it’s wrong, correct at comment #192: https://code.google.com/p/android/issues/detail?id=38563#c192

Many thanks for the note - just tried your links - think the second one is brooken;
would be greatfull if you could post the apk download link you I take will use - now, after the reset … - to get the tethering back working on your phone

Sorry I forgot to add a detail: even I cannot download the .apk since many months… :frowning:
I was looking on web for the same package but I haven’t found it.

For now I use the same procedure described by @Stefan

shame - more to have this thread complete: tried the rootcloak, but unfortunatedly does not make “root” “invisible” to my employers’ ap - which on the other hand is actually good, as it shows that I have a quality app by my employer …

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.