Need a powerful recovery to backup from broken FP1U to SD card

Hi danxuliu, ist there a TWRP for fairphone 1 with unified storage layout ? i have a broken fp1U and would like to create a backup. Backup to sdcard in original recovery does not work, because its 6GB data, and vfat only allows 4GB-Files.

Sorry @amar, I have worked only on the version shown here with the original storage layout. I do not know if someone else developed a TWRP version with the unified storage layout (maybe @jftr for the official KitKat upgrade?).

Yes, TWRP should be able to handle that, as it splits larger backups in several files (well, I suppose that you already knew it, but just in case :wink: ).

You could probably use ClockworkMod, maybe @Stefan can explain how.

PS: I moved this discussion to a new topic because now it doesn’t have much to do with the original topic anymore.

1 Like

Yes, the recovery.img can be found here:

Note that there is no fastboot on FP1, so you’all have to flash the image using adb shell:

1 Like

This is interesting. Are you sure?
I haven’t used it, yet, but I would assume that (almost) every Android phone has fastboot.

Thanks for your quick answers:

i tried to flush recovery.img with fastboot:

sending ‘recovery’ (5688 KB)…
OKAY [ 0.218s]
writing ‘recovery’…
FAILED (remote:
partition ‘recovery’ not support flash)
finished. total time: 0.237s

Didnt work.

Is there a way to put the recovery.img into a .ZIP-file so i can put it with adb sideload ?

The only command i can run with adb is sideload.

The easiest way would be to boot your phone and flash it from there. It should even work when you’re stuck in a boot loop. But you need to have your phone and your PC already set up, before. (If you’ve successfully used adb before this should do.)

Otherwise you could try flashing a specific partition with proprietary Mediatek tools and your bootloader. (Please be careful!)

1 Like

Thanks for your tip.

I could recover the images (which was the only important data) with the sp flash tool. I used the
Readback option to read the memory to a file, then i run photorec on that file to recover the images && movies.

Steps on linux:

  1. Download sp flash tool (wget
  2. Extract sp flash tool (untar x ./SP_Flash_Tool_Linux_v5.1648.rar) password is mtk2000
  3. Download fairphone binaries
  4. Extract fairphone binaries (unzip
  5. start flash tool as root (cd SP_Flash_Tool_Linux_v5.1648 && sudo ./
  6. Choose scatter file in FP1-Fairphone_OS_v1_8_7_Image_2015081400 folder (MT6589_Android_scatter_emmc.txt)
  7. Choose Readback Tab (Filename: 4G-ROM.img Start Addr 0x0000000049d80000 Length: 0x0000000100000000)
    and click Readback.
    Connect your phone to the usb with the volume down pressed. sp tools starts to read your phone within seconds. This gives you a 4GB file
  8. run photorec on the file (sudo apt install testdisk && photorec 4G-ROM.img
    Your images and movies are restored into a directory.
  9. Copy all images that are bigger than 100kB to a special directory
    (find . -iname “*.jpg” -size +100k -exec cp {} /home/user/pictures_over_100k ; )
  10. Drink beer




I’m hooking in @werner_noebauer (Is it ok that I closed your topic?). He has the same issue:

1 Like

It’s great to hear that this actually works. :slight_smile:

At the time I was doing this it didn’t manage to connect to my phone using Linux (I think; or I was worried about running this software as root). I set up a VM with Windows 10 inside and used this.

BTW: In which way is your phone broken?
Perhaps it’ll work again if you reflash it?

1 Like

It’s no my phone, it’s FP2 but afaik it does not even react to the power button…

If it’s a FP2, this will not work. This is related to the Mediatek chipset.

Your topic is in #fairphone-help and not in #fairphone2help

Hi Stefan,
I thought it is a FP1 so I started here… It is the phone we were talking about in our last meeting :wink:
This thread can be closed.

1 Like

I didn’t remember if it was a FP1 or FP2. :blush: I’ve moved your topic to the appropriate category.