Navigation with Google Maps does not work, Phone calls stop

Dear all,

I have 2 issued with my new Fairphone 4:

  1. when I start a Phone call, after a while, the other person stops hearing me. I tried a reboot and a system Update, still the same shit.

  2. I used to use my old Phone for navigation with Google Maps. This is not working with f4. Navigation starts but then the speaker, who tells the directions, stops. When I stop, and look at the phone, the position is mostly correct, sometimes it needs some time for actualisation. This is useless in a car or a bike.

Have you any suggestions?

Thank!
Lotta

Hi and welcome to the forum
It would be usefull to know

  • Is this using the deafult A11 with updates.
  • Was it like this from the beginning?
  • Are you using Network and or WiFi, maybe they are switching and interupting the connection.?

Reg the first issue it helped several people to remove permanent access of google to the microphone. Maybe this could help with the other issue as well?

1 Like

Why not switching to magic earth. one of the best free, but not OpenSource or FOSS, navigation apps.

Hi Lotta

since you mention in both your topics an issue including a time span:

Is it maybe the same time span affecting both issues like phone call stops after x minutes and the navigation-speaker also stops after the same amount of time ?

In case it is like that then this sounds to me a bit like either an issue about the defined screen lock (-> on my FP3 it´s within settings → security - I guess it´s more or less same on your FP4 - depending on which android version you´re using) and/or the defined time span for turning off the screen automatically (settings → display → extended settings).

I experienced kinda similar behaviour on my FP3-device and it needled me for weeks until I found out it was a specific setting I made - stupid me :wink:

Best
DonFnord

2 Likes

Thanks for the reply but the time span is not fix. The phone call ends at an undefined time span, sometimes 4 minutes, sometimes 10 minutes. It is not reproducible.

I will try that…thanks.

And in case GMaps still stops working, I would try another Navigation App, to see if its a general Problem with speaker or more the app. I as well use Magic Earth instead of GApps, as it also has traffic information etc.

For Navigation, do you have Wifi and Bluetooth scanning on? Also is Google Location Accuracy turned on? Those settings might provide more reliable/faster location information while travelling around.

And btw. is your system up to date or maybe an update available?

When also other Apps stop Wirkung after some time you can call * # * # 2886 # * # * to test the speaker etc.

Now, I found that no App hast permanent permission to use the microphone. So neither Google.

I have no clue how to solve the problem with calling. This is really anoying. Maybe I should send the phone Back?

If you want to try to resolve the issue or send back is a decision only you can make.

The only other thing I can think of is VoLTE and/or 5G. This is currently causing several issues when turned on, so I would turn off one or the other or finally both to see if this helps. And in case it helps I would contact Support to inform them about the provider/network and the noted issues.

1 Like