English

My phone can't boot since I flashed Xposed for Android 6

Hi,
I have a huge problem there :
I updated my FPOpen to 17.06.4, and as always Xposed Frameworks was gone. So I flashed xposed v87 for sdk23, and now when I turn my phone on the boot animation plays, then the buttons on bottom of the screen and the hour on top display on a black screen, and it crashes (and reboot). So my only way of stopping it is by taking the battery off.

Fortunately I can still access TWRP so I guess I should do a wipe. I forgot to do a backup with TWRP but I have a Titanium Backup on my External SD Card.
So my question is what kind of wipe should I do ? I’m quite scared of loosing my apps because I’ve never actually restored anything with Titanium…

And also it would be nice if someone knew what caused this so I can try installing XPosed again.

Thanks in advance, and thank you for reading this :slight_smile:

You could just reinstall the OS. That should wipe XPosed without wiping your apps and data.

1 Like

What @paulakreuzer said :point_up_2:
I would uninstall Xposed before, however. It may delete some residual data.

1 Like

Thank you for the replies.
I tried what you said : I flashed xposed-uninstaller-arm.zip then flashed fp2-sibon-17.06.4-ota-userdebug.zip
Now I get to enter my PIN code and it crashes after a few seconds. It seems to be when xposed apps ask for superuser rights.
Is there a way to delete all the xposed-related apps without wiping all my apps ? Or maybe if I wipe all my apps I’ll be able to restore the non-xposed apps via my Titanium Backup ?

You should wipe Cache in TWRP.

Wiping cache didn’t work ( I also tried re-install fpos after wiping cache…)
So I did a factory reset (“the only wipe I need” in TWRP) and I’m currently restoring every app with Titanium.
After that I’ll have a clean fposos but without xposed frameworks nor any xposed app. Does anyone know if flashing xposed should have worked the first time and should I try again ? (with an actual backup this time)

Flashing xposed should work. Just make sure you have the framework for SDK23.

Okay I flashed Xposed again and then reinstalled manually my xposed apps, now everything works fine ! Thank you all for the help :slight_smile:

topic solved.

1 Like