Music player can't find audio files

Since the upgrade to Koala Nut 1.8.7 the audio player application is not able to find my mp3 files anymore. My music is stored on a 16GB SD card.

I’ve checked on the interweb and found out, that I’m not the only person with this problem. There are lots of threads on different forums about this issue. What I’ve tried so far:

  • Copy music from SD card to internal memory
  • Unmount and remount SD card
  • Stopped and cleared cache of media storage application
  • Boot to recovery and wiped cache partition
  • Combination of things above

Nothing worked for me. I installed Vanilla Music player to check, if maybe only the stock audio player is affected. But I have exactly the same issue in Vanilla, too.

All the audio files are in mp3 format, I can play them from the Android filemanager, which indicates that the files are not corrupt. However, I can’t load them into both the players audio libraries. This seem to be a global issue and not limited to a certain audio player. Files are located in “storage/sdcard1/Music”.

There are no “.nomedia” files present in the music folders.

I have a Fairphone first edition running Kola Nut 1.8.7

I don’t know about this issue. But can you try using the vlc player (you can freely choose directories there) just to see if accessing your music on the sd card works? This is what I use and it worked before and after the update …

1 Like

Are your music files definitely in mp3 format?

When I flashed my SGS 3 mini with CyanogenMod 11 (KitKat) most music players wouldn’t find wma files any more but played mp3 just fine. Poweramp still worked well though.

When I reboot my Fairphone, it always takes 2-3 hours and perhaps a third of the battery power to read my 120 GB of music files on my SD into the MUSIC app. As a consequence I never shut down the Fairphone altogether unless I have to (e.g. for an update).

Sounds horrible, not sure if this is “normal”. Normally better media player software creates small databases for this. Is the music app android or MTK? Maybe there is a better audio player for you “out” there?

I’ve tried VLC once or twice, but it would always instantly freeze with a white screen. However, I might have used the wrong VLC .apk and might give the right one another try the next time I am forced to reboot. The thing is once MUSIC has read the whole SD contents, it works flawless as long as I never shut down the MUSIC app and the Fairphone itself altogether.

I don’t want to get too offtopic. But maybe “Rockbox for Android” will work for you. VLC is more a video media player, not sure how well it works with really big libraries.

I use Rockbox on an SansaClip with a big SD card, but I’ve never used it on an Android device. But I heard they also did that a while ago. Maybe I will check that work you … I’ll let you know.

Update: Don’t brother trying, Rockbox is not working well on Android 4.x and I’m not sure if they still develop it :frowning: Too bad, was a nice project.

Thanks, but don’t spend too much effort on it, I don’t use the Google App Store anyway. :slight_smile: For the time being, I’m ok.

All the files are in mp3 format, I can play them with the filemanager, which indicates the files are not corrupt. However, I can’t load them into both the players audio libraries. This seem to be a global issue and not limited to a certain audio player.

Where are they located, according to the file manager?

Update: I “assume” the following … the database for the music player still knows about the “old” location of the files, but the files are gone from that location (“upgrade to Koala Nut 1.8.7”), all you see are the “ghost” entries. Somehow you have to tell the Music app where to look for the files again and forget about the old paths. That what’s what I think could be the reason. Maybe there is something about this in the forum already, I have to look …

1 Like

I don’t want to undermine the search, but would like to add: I have never had any issue playing AAC files in the default MUSIC app. And MUSIC always found music files regardless of location. Right now my music files are in 2-3 different locations, both in the internal storage and the SD card.

Maybe there is a problem with Google Apps interference?

The files are located in “SD_root/Music”.
There are no “ghost entries”. The music player can’t see any files.

So both, VLC and Vanilla cannot play the files although you can “access” them? So you can go to “SD_root/Music” through their interfaces and choose a file, but not play it?

But in the File Manger selecting and playing a .mp3 works? I tried to understand what you mean with “load”.

I can select and play them with the internal filebrowser of Vanilla, but it can’t add the files to the music library. I can also play them with the standard Android filebrowser.

As I said, the mp3 files are present (no “ghost entries”) and not corrupt. The problem is, that all players I use are not able to add the files to the music library. If I scan the SD card for music from within any player, there seem to be nothing on SD card nor on internal memory.

Maybe there is a hardcoded search path for the SDs? Can the SD Card be remounted? I currently have a unofficial ROM on my FP1. The Music app there seems to automatically find my Music if mounted under /storage/. Is your SD_root also mounted under /storage?

Update: With vlc I can choose any directory to be included into the media library as long as I can access it. (Settings -> Directories).

Both, internal memory and SD card are mounted there. Internal memory “storage/sdcard0” and SD card “storage/sdcard1”

As far as I can see it, you tried all the know workarounds to reset the music app and there are no .nomedia files … Strange. Sorry, nothing more comes to mind here for now.

Maybe backuping & formatting the sd card and carefully moving just the mp3 files onto the card again for testing? Or just trying another empty card with just a few mp3 folders?

I have my music in subfolders of a folder Music in the root of the SD card on 1.8.7, which seems like the setup you have. No problems here, so it’s not a general issue - which means it should be fixable, whilst I agree you’ve tried the obvious database-related issues.

I’m nearly 100% certain you’ve tried this, but just in case:

[quote=“An_Mel, post:1, topic:10881”]
There are no “.nomedia” files present in the music folders.[/quote]
When using the built-in file manager, I’m assuming you have turned ‘show hidden files’ on. Are there any .nomedia folders in the root of your sd-card, or in any folder you need to go through to get to the actual music files? It seems the indexer doesn’t recurse into folders from the point where it encounters a .nomedia file. Might even be worth checking upwards from the mount-point.

I don’t have another SD card. I’ll backup my stuff and try the solution with the phone reset.

There’s another thing I noticed. With the previous version of Koala Nut the internal memory was mounted to my laptop when I connect the phone. Since the upgrade, only external (SD card) memory is mounted when I connect to the laptop.

The idea is just to have a clean SD to prevent hidden .nomedia files. No reset of the phone needed.

You can make your computer search for the .nomedia file:

Under Unix/Apple open a shell and cd to the mounted sd-card, run:

$ find . -iname “.nomedia” 2>/dev/null

Someone has an idea for windows? I think you can just use search, but you have to activate the feature that you can see “hidden” files.