Mobile network won’t work until next reboot

Hi There

I have a problem that sounds exactly the same as this topic (which was never resolved):

Mobile network won’t work until next reboot

The mobile internet usually works after turning on the phone, but after a fairly short amount of time it stops working again. Wifi works normally.

Thanks, Cedd

I found that I could fix this by Force Stopping the Carrier Services application.

It gave me some nasty warnings, but worked fine afterwards.

Go to Settings, Apps and notifications, “See all”, click on the Carrier Services app and then Force Stop it or Disable it.

3 Likes

Does this problem recur? I notice you haven’t flagged it as fixed.
This app has no cache usage, but did you try clearing the storage while you were there to force stop it?

Yep, this seems to have fixed the problem. I’m not sure why or how though!

I have seen this behaviour occasionally when I drove by car, so the phone had to book into another mobile base station. If this occurs, the mobile network (E-Plus/O2/Telefonica) is still displayed on the start screen, and calling/being called works. But the internet doesn’t. Which can only be seen by some app “going on strike”. Only a reboot will help if this happens. It does not happen every time. Once or twice a week. This came with the update to Android 9 of FPOOS, and it is still present on A10.

I do not see a “Carrier Services App”, not even in the System Apps view. Are you talking of the “CarrierDefaultApp” (this is the only app with Carrier in the name I see)?

Hi hman,
Which OS version are you running? Go to Settings > About phone > Build number.

I am running FPOS (standard Fairphone OS provided by the constructor) 22.08.0-rel.0

Under Settings > Apps and notifications > See all apps, I see “Carrier Services” in its alphabetical place. It is not classified as a “System” app, there is no need to choose “Show system” in the three-dot options menu top right.

However, I see you refer to FPOOS, things are likely different. I don’t currently have a device running FPOOS.

From your other remarks, sounds like this may be happening during “hand-over” when you’re on the move, between cells. If the problem is a real nuisance you might contact your network operator, as well as notifying FP support.

1 Like

Hi Both, I’m on android 10, 22.08.0-rel.0, as OldRoutard is. I imagine that you are on an earlier version that doesn’t have the carrier services appliction? Or has it, but at a different place in the menu system?

Fairphone Open 22.08.0-rel.0, according to Updater the latest available.

No Carrier Services. Could be that the name got localized, I use German interface. The only thing that could relate to the Carrier could be “SIM-Toolkit”?

Dont see it either with FPOOS installed

1 Like

Thanks to Yvonne for pointing out the bug report.

@hman From what I read, if you move the SIM to slot 2 there’s a chance things will work better. Have you tried that already?

So far I did not. But I do not experience any trouble with signal strength, also calling functions absolutely normal. But be reminded that the FP2 cannot make phone calls over 4G, and since 3G is already gone, phone calls run on 2G, supposedly.

Just so things are as clear as possible, my suggestion to use the second SIM slot was only aimed at solving your mobile data problem. I’m not attempting to address any calling problem since you stated that you don’t have a calling problem.

I have understood that, and in given time I will test it. But I have problems to understand how the socket could technically produce such a fault. The SIM card is there to authorize network access. It does not encrypt the entire data stream, it’s processing power would be insufficient for that. If communication to it breaks off, users who have SIM PIN active should be asked for the PIN again, which they do not report (I do not have SIM PIN active). I am still wondering where to find the “Carrier Services” app.

It might help if you temporarily activate SIM PIN.

Since I don’t use FPOOS I can’t say for sure, but I suspect this app is replaced by another service, in the context of open source software.
FPOS does not claim to be fully open source.