Mobile Internet Roaming connection issues

Hi everyone,
I ran into a strange issues yesterday and I am lost.

I am currently in spain and I am using mobile data with roaming. There are no contractual limitations or anything but the mobile data connection is not working properly and I am confused:
Certain apps like whatsapp or instagram work without any issues, i can send and receive messages without any delay. Loading pictures is going in medium to high speed. BUT some apps do not have a connection. For example chrome and googe maps are not loading anything.

I checked the coverage too and it is fine. I tried all the on and off I know: Flightmode, device, mobile connections, reinstalling apps, deleting caches etc.

Any ideas?

1 Like

Did you check the APN settings?

I do have the german vodafone APN in my settings. Should I add the spanish ones?

I thought it is more on system level and not network since a few apps have internet and a few do not have.

When I change country, often the APN is deactivated automatically and I have to re-enter it manually.

That’s why I asked you to check it :wink:

Yes APN is the one of your home country, AFAIK.

I never changed APN in another coutry, so just check if they are messed up. Else its always worth it to turn of VoLTE and maybe 5G?

It could be an IPv4/IPv6 problem.
Have you checked your APN settings (APN protocol & APN roaming protocol) in this regard?
If you have set IPv6, you could switch to IPv4 or IPv4/IPv6

1 Like

I can not edit my APN for some reason. They were created automatically.

Okay, i somehow solved it by going to the mobile data settings and changing the preferred quality to 2G and then back to all of them… No idea how this was possible but it seems solved for now.

2 Likes

thanks for the tip. I’ve had the exact same problem since the last firmware update. what is Fairphone doing there?

Steven

I had a very similar issue in the US last week - I live in Denmark and have no I’m issues here. Although mobile data was working, I was not able to make phone calls. Once I changed to only using 3g/2g was I able to make calls again. This was on AT&T network.

1 Like

I had the very same issue when staying in Spain and found the same resolution (by switching to 2G/3G and then back to 4G/5G).
I have the same issue now back at home when I move between my home and work location. When putting the SIM in another phone all works well, so all points to an issue with the FP4.

How old is your SIM card? There are examples that a SIM card in another phone works and not in a Fairphone. So swapping your SIM card for a new one is worth a try.

Perhaps you could try to switch to airplane mode on and off instead of switching to 2G/3G and then back to 4G/5G.

1 Like

Hi Lidwien, thanks for having a look into this topic.

How old is your SIM card? There are examples that a SIM card in another phone works and not in a Fairphone. So swapping your SIM card for a new one is worth a try.

The SIM card is from 2020, roughly 2 years old. May be I could try with a SIM card from another network operator - something I can follow up in the next weeks.

Perhaps you could try to switch to airplane mode on and off instead of switching to 2G/3G and then back to 4G/5G.
I have tried this, but this does not solve the issue.

On the other hand, I have created a new APN configuration (as suggested by @HolosericaCaligo ) with IPv4 only - this seems to do the trick. I’ll monitor this in the next couple of weeks to see if it solves the issue for me.