Mobile data problems with FP3+ in Italy - already before, worse with Android 13

Dear community,
my contract is german, but I’m frequently in Italy with y FP3+. As far as I understood, Italy is using 5G, which FP3+ cannot handle. As son as I crossed the border, my mobile data stopped working, I think because my phone tried to connect with 5G. I don’t havve this problem in any other country. So far (before Android 13), I manually selected a 4G network manually in Italy and solved the problem this way (Network and Internet → SM cards → Choose network automatically → disable, chose a 4G one manually). Annoying, but OK.

Since Android 13, this does not work anymore. The network list does not show the used networks (2G, 3G, 4G) anymore (se picture), and I cannot connect to any of them manually. The only thing that works is restricting my phone to use 3G only (no automatic option like 4G/3G/2G or 3G/2G works). This is really annoying, because slow.

Who has the same problem? Is there a solution?

Thank you and sunny greetings from Italy, Kathi

Have you cross-checked your APN settings with your provider’s recommendations? Sometimes wrong settings can interfere with roaming.

According to, there is 4G in Italy.

I wonder if there is not an agreement between your German provider and an Italian one that would not work well. Did you contact your provider ?

I’m encountering the same problem in France, Switzerland and Germany. Other people reported the same problem. See the posts:

I’ve also contacted support about this last week, referencing the above posts, but I haven’t heard back from them yet. For me also restricting to 3G doesn’t help…

1 Like

Hi people! Thank you for your answers so far :blush:

Yes, I checked my APN settings, same problem with all available APNs (the standard one and the one published by my provider).

Yes, there is 4G in Italy, and before Android 13 I had a workaround that worked - selecting a 4G network manualy. But as shown in the screenshot, this option disappeared with Android 13 and the only thing that works is restricting to 3G. Don’t know why.

And yes, I contacted my provider, it’s definitely a device problem. My partner has the same contract but a different phone and no problems.

Haha, the first post you mentioned describes exactly my problem! At least I’m not alone.

1 Like

Personally, I don’t understand why you needed a workaround before the upgrade since I go to Italy for many years and use my FP3 in 4G everywhere without choosing the network manually. The only difference between us is that my provider is Belgian and not German. That’s why I think there is a problem with your provider.
If there is no according to you, you should contact contactsupport to ask for the missing feature back.


How old is the SIM card?

And I side note: I doubt a phone that is not 5G capable would try to connect, as it does “know” the bands.

Independently of the questions of 5G, roaming or whether you personally need this feature, I’d like to invite anyone with Android 13 who is reading this to try out and report whether choosing the mobile network manually works for you. I’d love to understand if this is just universally not working or whether there are any variables that would influence this.

  • Go to Settings → Network & internet → SIMs (choose one of your SIMs if you have multiple).
  • Scroll down to the section “Network” and uncheck “Automatically select network”. You should see a “Choose network” card and after a while of scanning (can take ~30-120 seconds) you should see a list of network providers (see the screenshot in the first post above).
  • What happens if you select any of those networks? If it works, your should return to the previous screen, if not there should be a message “Couldn’t connect”.

It connects when I follow what you wrote. Then I can go to the previous screen.

1 Like

Interesting. Do you have a FP3(+)? And which Android version do you use? Stock Fairphone OS or do you run some alternative like Lineage OS or /e/OS? Also, if you’re willing to share that, what provider do have?

Android 13 from Fairphone
Orange Belgium

May I ask you what is the result you get ? I had to do it twice in order to be able to choose manually my provider but as said above, it is something you should not need to do.

Precision : I belong to the beta testers group for the FP3 and so we don’t have the same version you and me. Maybe we will be get the same result as me in a future update (no certainty).

When I do it, I get a message “Couldn’t connect” for whatever network I select (as shown in the screenshot in the first post of this thread). Note that mobile data works for me if I leave it on “Automatically select network”, but connecting to the same network manually fails. The reasons for why I personally need to do this, I’ve described in another post:

I also just received a reply from Fairphone support in my ticket that I opened last week:

Our Software team is aware of an issue, which makes it impossible to manually connect to a specific network.
After an extensive investigation, our team discovered the root cause of the issue. A fix will be included in a future software update. We expect that this update will be available at the start of October so keep an eye out for that notification.

They also mentioned that they will look into whether they can make the fix available through the beta testing program, but my understanding from their message is that it is not in the current beta version.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.