Mobile data lost after upgrading FP2 to Android 9

Since I upgraded to Android 9, the Mobile data button does not remain in the ‘on’ position, and therefore, I have no mobile data. The wifi connection works fine, but I do need connection when I am out and about.

Hi and welcome to the community!

Did you check whether the SIM card you want to use for mobile data is actually selected, under Settings > Network & Internet > SIM cards ?
As in my experience, the upgrade may cause various settings being changed/lost; seem to remember this was one of them.

1 Like

Hello. Thank you for the suggestion, but I had already done that. I also contacted my server and they confirmed that everything is correct from their point of view. I still don’t understand why the mobile data button won’t remain in the ‘on’ position. The roaming button behaves normally.

when you ony´ly use one SIM, have you tried the other slot? Else have you tried to completely reset all network settings and set up from scratch? This should include Wifi, bluetooth and mobile data, so make a note as needed about settings especially the APN settings.

Hello,
I think it would be wise to check your APN settings, and possibly re-register the APN (I’ve just had a case where this was successful). Which is your network operator?

I think I am going to have to do this, although it makes me nervous.

I have checked the APN settings.

I forgot to say that my nertwork operator is Pepephone (Spain).

Well, the info on the website is minimalist
image
I would expect there to be a value for the “APN type” field at the least. Could you post the values you have at present, for all the fields (the easiest is to take two screenshots but otherwise just type them out here).

Yes, I found that too. It did seem minimalist, but it is presumably what was has been in my settings all this time. I did also phone Pepephone and was told that I had everything correctly registered. I think there is nothing for it but to reset the settings.
Thank you very much for your advice.

Well, as I said, instead of a reset of all the network settings, which will needlessly delete wi-fi passwords and bluetooth pairings, just delete the APN and create it again.

You can also try just deleting the APN, then reboot the phone and see whether it’s created again automatically.

But the issue to my undertsanding is, the mobile data turn themself off (slider sets itself off), so this is not normal when just APN are incorrect so it does not harm to test, but I would doubt it helps.

Thanks for all the advice. In the end I took the plunge and did a factory reset. It seems to have done the trick and my phone has returned to normal working order. I am very happy!

5 Likes