Mobile data does not work FP4

,

Bei FP direkt! Bin jetzt heute (Sonntag!) tatsächlich wieder im Kontakt mit Angele vom Support. Und nein, ein Ersatzhandy hab ich nicht. Werd ich mir wohl zulegen müssen … bin echt frustriert!

vielleicht aber jmd in der Familie, dem Freundeskreis. Wie gesagt ich verstehe den Frust und denke dennoch es wird sich eine Lösung finden, wenn man sich darauf konzentriert. Und generell, wenn Support per Mail zu lange auf sich warten läst, einfach mal den Hörer in die Hand nehmen und dort anrufen. Wenn auch die Support-Strukturen sicherlich sehr verbesserungswürdig sind, die Menschen die dort arbeiten, erweisen sich doch meist als freundlich und hilfsbereit. Manchmal muss man Ihnen auch einfach den höflichen+bestimmten Anstoss geben, was man denn tatsächlich erwartet, statt noch das zigste Mal irgendwas zu probieren.

Ja, die sind wirklich sehr nett. Anrufen finde ich schwierig, weil es bisher immer auf Englisch ist und ich nicht alles verstehe oder nicht so schnell die richtigen Worte finde. Beim Schreiben fällt mir das leichter. Danke für deine Unterstützung.

1 Like

Hallo. Ich hatte gestern dieses genaue Problem mit meinem Französichen Operator (Bouygues Télécom) und mein neues FP4. Hier ist, was ich getan habe (ich hoffe, dass meine übersetzung gut genug ist):

Einstellungen > Netzwerk und Internet > Mobiles Netzwerk “Bouygues Telecom” > Erweiterte Einstellungen (der Bouygues-Verbindung, nicht der allgemeinen) > Namen der Zugangspunkte (ganz unten) > APN = “mmsbouygtel.com)”) > Authentifizierungstyp = “Keine” > Klick auf die drei Punkte rechts oben > “Speichern”.

Danke für den Hinweis, die APN sind Provider spezifisch, also APN mal nachschauen ist eine gute Idee, nur immer vorher die APN vom jeweiligen Provider nachschlagen

Hi,

I have huge issue since the last android update last week, the data connection is keep failing and I don’t know why.

The data sysmbol at the top is keep showing the small ‘x’, what I tried:

  • turn off / on the sim
  • change 5G/4G/Edge randomly multiple times

Sometimes it works, ‘x’ disappears and I have data connection again. But that doesn’t work always, and not for long. Sometimes the 5G/4G+/4G is changing rapidly until it’s loosing connection again.

Any advice how to solve this?

The provider is Vodafone Germany, 5G is included in the contract. Actually everything was working fine until the recent update, but now it’s impossible to use the phone without WiFi.

Hi and welcome to the forum.

This has been noted, I don’t have an FP4 :: Vodafone Germany. :slight_smile:

1 Like

The recent issue with Vodafone seem to be connected to the recent update. The topic your Post was merged into as well as the above are more about “older” O2 issues.

For some user the issue was solved by correcting/resetting the APN

3 Likes

Thanks, I run the reset and now it seems to work stable again.

BTW, is there any way to remove or edit the provider name on top left? Mine is too long, as you can see on the screenshot, it makes the clock to hide under the front camera.

apn

This may be what you’re looking for:

3 Likes

Hello everybody,

I also had trouble with the LTE connection of the FP4 using eSIM with congstar (Germany) since the latest firmware update FP4.FP3W.A.128.20220516. I found a temporary solution but this needs to be fixed in firmware.

Here are my findings:

  1. After a reboot or after switching to flight mode and back again the mobile data connection via LTE is lost.

  2. To get the connection again:
    Short:
    2.A Make the default APN unusable
    2.B Reset the default APN
    In detail:
    2.a Open "Settings->Network&Internet->->More->Access Points (APN) (I use the German version and just translated from German to English - the real names may differ a little bit)
    2.b Tap the first (default) entry, tap “APN”
    2.c Add any character here to make the entry wrong (yes!) → “OK”
    2.d Three Dot Menu → Save
    2.e The network setting is now updated and the icon(s) show first a neutral state and later on an error
    2.f Wait some 10 seconds → Three dot menu of the “APN” menu → Reset to standard
    2.g Et voilá - after some 10 seconds later the connection works at my FP4. Until I reboot or switch the Flight Mode off and on again…

  3. The issue of FP4 no more connecting to the mobile data under certain circumstances seems to me a bug which came in with the feature “Improved retention of mobile network settings after update.” listed in the ChangeLog of the firmware. Something changed in the structure of the APN / Mobile parameter data - but these changes are not taken over correctly in all SW modules… What I also observed that if you are creating a second APN and want to change the APN Type, APN Protocol and APN Roaming Protocol - the “Save” does not really save this if all of them changed.

I will create a ticket and try to explain my findings - not sure if they will understand me :smile:

1 Like

Just to add, as Congstar is using the Telekom network it might be a different Problem, although its the first time I read about D1 issues. So before you found this workaround, did you try anyrhing else, like turning off 5G and/or VoLTE, reset APN as suggested above, or just delete the APN setting and re-enter manually? Did you check with Congstar as it could be a coincidence that it occurred after the update?

I have one question to you: Do you have the same issue or no issue? You can check within 5 seconds by switching flight mode on and off and WiFi off of course. Be aware - you know how to get the connection again :slight_smile:

Sorry for not explaining all the things before I found the solution described above:

  1. Switched Mobile Connection off and on again → no luck
  2. Turned flight mode off an on again → no luck
  3. Reboot → no luck
  4. Switched off and took battery out, wait some seconds and restart again → no luck
    Until here I went when I was on the way without any working WiFi. When I came home I started my PC found this forum and went on:
  5. Switch VoLTE off → no luck
  6. Tried different mobile data setting “5G/LTE/GPRS/…”, “LTE/GPRS/…”, “GPRS/…” → no luck
  7. Tried to reset the APN → no luck
    When I tried to reset the APN I observed absolutely no reaction on the indicators. Then I came to the conclusion that I have to change something and first changed from “internet.v6.telekom” to “internet.telekom” and - it did not work for the first try. Opening the APN showed “internet.v6.telekom” again so something went wrong. Yes: I did not explicitly tap the “Save” in the three dot menu - which is a bit crude user interface. After doing that change and saving the mobile connection worked!
    Then I played around and came to the conclusion I have written above - there is no relation the “internet.telekom” APN which is IPv4 or historic - after a reboot or after flight mode on / off you’ll be in the same situation with no working mobile internet connection and will come out of it by changing the APN to “internet.v6.telekom” again.

My first thought was that congstar changed something. But I cannot see anything changed in the contract or so. There are no reports of congstar customers having problems. On the other side there are different reports on problems with the mobile connection with the Fairphone after the cited FW update. And after my findings about the APN menu it is out of my imagination that this has to do with the congstar specific points. Just try to change the three entries I described above at once and save it - that behavior is typically in software where datasets are not in sync or have content which is not compatible - for example if one part was refactored and the other was not…

Sorry for this being so looong… But you asked for it :wink:

2 Likes

From what I have seen so far it was only for Vodafone Network, so I’m still thinking it might be some strange coincidence and for sure it can still be due to the update, just would expect more reports when its a general issue also with Telekom network after the update. I dont own a FP4 nor do I use FPOS or Telekom network so cannot check.

I see you tried a lot and thanks for explaining this can still help others and also support might ask similar questions. while waiting for FP support to respond I would still contact Congstar support as well just to have all covered.
Fingers crossed you will not have to use this quite complicated workaround too long

I have access to one FP4 with a Congstar eSIM running stock FPOS and a FP4 with 2 Congstar SIMs (one physical, one eSIM) running CalyxOS.
Didn’t have to change any settings and no issues whatsoever :man_shrugging:

Things are getting even more complex - after @hirnsushi s report I tried another 30 minutes:

Additionally to the Congstar eSIM I have a Vodafone SIM in the phone. Sometimes I use the Vodafone SIM for data and other times I use Congstar eSIM for data. I switched from Vodafone to Congstar a week ago. I was under the impression everything works as intended but I am not sure if this was really the case…

What I tried just before is to switch off the Vodafone SIM and… tada… again no more problem. The problem occurs as the Vodafone SIM is switched on.
Tried to switch off VoLTE (at Congstar) - no luck
Tried to switch off WiFi Call at Vodafone and at congstar - no luck
Tried to switch Vodafone to 2G - no luck
Switch off Vodafone card + Flight mode on / off → Everything works!
Switching on Vodafone again → the data connection still works - until reboot and so on…

Tried to add another APN at the Vodafone SIM with the same IP parameters like Congstar - no luck
Tried to reset APN at Vodafone SIM → no luck

There is another point I found out: The LTE connection is available but the IP connection is not working. It is not only the small indicator arrows blinking while there is the x in the triangle. Even the network status is “connected”.

So at the end it seems to me that the Vodafone issue is even bothering people like me using a Vodafone card just for calls and another card for the mobile connection…

So can you enable mobile data for both SIM at the same time on the FP4? If yes, did you just disable mobile data for Vodafone as long as you dont need it instead of disabling the SIM card overall?

Not sure what you did and I assume you know that APN are provider specific however should you have added Congstar data I’m not surprised it did not help.

I had the same issue ( No Internet Connection after Update/Vodafone) and it made me crazy…
But I am so gratefull that I found the solution in this Forum!
For me it worked to reset the APN and now it seems to work again! :smiley:

3 Likes

No, sorry, I think my description is misleading. I try it again.

Two cards - Vodafone SIM + Congstar eSIM. At the moment I use only the Congstar eSIM for the mobile data connection. At the Vodafone SIM the mobile data is switched off.

After switching the Vodafone SIM completely off, rebooting the phone or switching flight mode on and off again, the data connection works perfectly with the Congstar eSIM without any hack.

I have the feeling that if (!) I would have a datapass for Vodafone I could update the mobile access data as the others did and everything would be OK. Until then there is some internal settings of the Vodafone SIM preventing successful LTE connections via the Congstar eSIM without my hack.

In my eyes this is still a bug in the Fairphone FW - there should be no influence from data connection settings of one SIM to the other - shouldn’t it?

PS: Tried the Handy Konfigurator - does not work reliable. I think this would get better if I would have a datapass for Vodafone…

Its surely caused by the latest update and it resolvable by resetting the APN of Vodafone using the three dots or using this configurator thing. Dont know if it only helps when mobile data are enabled. Overall even if caused by the update it might still be a Vodafone fault as they have to test and approve an update before it is rolled out. Did you already do a reset of all network settings? If not i would try this