🇫🇷 Mise à jour de lineageos

Bonjour à vous tous;
Comme le sujet l’indique, j’ai un FP2 avec lineageos. Jusqu’à présent, lineageos se mettait à jour tout seul comme un grand, et depuis quelques jours, il me demande de le faire pour lui… Il me dit ainsi que la mise à jour est bloquée.
Il y a un “wiki”: http://wiki.lineageos.org/devices/FP2/upgrade

Je suis allé voir, les étapes 1, 2, 3 fonctionnent:

  1. Download the LineageOS install package that you’d like to install or build the package yourself.

    Optionally, download additional application packages such as Google Apps (use the arm architecture). OK

  2. Make sure your computer has working adb. Setup instructions can be found here. OK

  3. Run adb reboot sideload. OK

par contre, l’étape 4, non:

  1. Run adb sideload /path/to/zip (inserting the path to your LineageOS package).

En regardant un peu dans les forums d’installation de lineageos, j’ai vu qu’il fallait télécharger “la ROM” et la placer “à la racine de de la carte SD”.

Je suppose que la “ROM” est la dernière version de lineageos. Par contre, la placer “à la racine de de la carte SD” relève pour moi de l’impossible: je n’ai pas trouvé la commande sous linux qui permet “d’aller à la racine de la carte SD” de mon téléphone. J’ai essayé avec “adb” mais ça ne marche pas. Et est-ce seulement la bonne marche à suivre?

Par ailleurs, le fichier de mise à jour de lineageos est un .zip. Ce n’est pas pour moi un exécutable. Mon FP2 sait ce qu’il doit faire avec ce fichier?

Je suis un ignare, j’aimerais comprendre et faire par moi même, mais là je suis bloqué…

Merci pour votre aide en tout cas…

Salut,
Jusqu’à maintenant, tu faisais des updates et maintenant tu dois faire un upgrade (passer de Lineage 16 à 17). C’est pour cela que la mise à jour ne se fait plus automatiquement.
Pour le point 4, il faut simplement dire où se trouve ton zip sur ton ordi, ensuite tout se fait automatiquement.
Par exemple:
Run adb sideload /Downloads/lineage17.zip

N’oublie pas de flasher gapps en même temps (si tu le souhaites, ce n’est pas obligatoire de les avoir, mais si c’est déjà installé sur on téléphone sous Lineage 16, il faut le faire):

Salut;
En fait, j’ai réussi…
C’est pas si trivial que ça, hein… Je n’avais pas de gapps, donc je n’ai pas eu à flasher quoi que ce soit.

enfin bon, c’est le prix à payer quand on dit m… à android, gogole et consort (et puis par ces temps de confinement, quoi de mieux pour passer sa journée…)
Bonne soirée à vous tous!

Florent

1 Like

Salut,
Oui, je suis d’accord. Je n’ai pas beaucoup de connaissances préalables, mais j’aime passer du temps à chercher des solutions! C’est une sacré satisfaction quand on a réussi à reprendre un peu de contrôle!

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.