MicroUSB does not fit fully into FP2 port

My standard microUSB type B charger/cable works fine on my FP2 when it’s plugged in.

However, the size of the port on my FP2 seems to be too shallow and the little hooks on the cable - which should hold it into the port - actually don’t go in. Instead they push the cable back out of the phone. It is so bad that the slightest touch or vibration of my phone causes the cable to fall out.

I’ve tried several other cables and they are often worse, i.e. the cable has no chance of going in far enough to stay plugged in.

Have other people had this problem? I wonder if a replacement port might actually be deep enough to accept a cable.

That’s not normal. Dirt in the port perhaps? …


You’re absolutely right.

I’ve tried cleaning before but wasn’t sure if that was the problem so didn’t want to go too crazy. But hearing that it’s not normal gave me the confidence to really go at it and I managed to clear out the port so the charger holds itself in once again!



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.