English

🇬🇧 🇫🇷 Microphone does not work when calling (telegram bug ?)

Sorry , if I post here a problem which is already solved. But frankly cannot find the solution…
3 days ago I was still able to call a friend by phone (network: Vodaphone)… 2 days later I called my partner but she did not here me at all. The icon of the microphone during the call was grey and could not be activated. The same for mobile or fixed house phones.
Anyway when she called me the mic worked as usual. So it is not a hardware problem - additionally checked the lower bottom module. The *#*#66#*#* does not work… or just too dumb…
So only when I do a call by myself it does not work.
Then the contacts in the phone menu are gone, too…
When I look for contacts I can only call them via Telegram. But if they do not have telegram ?
Or I am stuck in an accident and have to call the police ? Do they have telegram ;-)))
The only thing I noticed was that there were some updates (F-droid, telegram (?) these recent days…
No idea how to give my vodaphone fairphone the priority over telegram and get my mic working when I do calls…

Hi, I’m interested in following this topic as a member of my family has the same problem with all her apps (including normal vocal calls). I searched for an answer for weeks but haven’t find one yet. We contacted the client service but they seem to be busy. Hope we’ll find something !

Did you try using another SIM (maybe one from a friend or a relative)? This way you can understand whether its a network problem.

I don’t think a bug on Telegram can cause this. But you may try to uninstall it to sort this out.

1 Like

@Aurélien t’as essayé de changer le SIM ? moi j’ose pas ce soir … si le machin me demande le TAN après je devrais le chercher ds mes fouilles toute la nuit :wink:
tu as aussi un messenger qui pourrait bloquer ? je vais essayer tout ca demain

@andreas1 j’essaie ça rapidement. Je mettrais un petit message avec le résultat

C’est bizarre …

as I explained some days ago there was an update …then obviously Telegram took over my contacts.

When I clicked on a contact it said: make a call via Telegram. I rejected and dialed by hand - and no microphone working. (Only when I received a call.)

Then I entered manually for the phone calls - stored manually - my partner as a contact.

Then it showed as phone connection „Deutschland mobil“. I hope that is no dialer program where I get a tremendous invoice in some weeks - like these fake dialer programs which kidnapped the internet connection some 15 years ago…

Anyway I call my partner via the contact icon for the phone calls today and it works.

(But anyway the icon of the microphone still shows „deactivated“ and I cannot activate it.)

Another call to someone else - and it works, too.

(no separate dialer app to be found in the list of my apps…can I see somewhere with which network I am calling ? Which should be Vodaphone - and not the ominous „Deutschland mobil“ ?

Perhaps I’ll buy the new 3+ Fairphone in the near future…

@andreas1 update ! We changed the sim position and so far, it seems to work. We’ll be testing for a week to make sure everything is ok and I’ll post a message to keep you informed

1 Like