English

🇩🇪 Mein Fairphone ist ein ganzer Problemfall (Kamera, SD-Karte, Reboots)

camera
sdcard
🇩🇪
opencamera
newcameramodule
randomreboots
openos
Tags: #<Tag:0x00007f000de3e478> #<Tag:0x00007f000de3e1d0> #<Tag:0x00007f000de3df00> #<Tag:0x00007f000de3dc30> #<Tag:0x00007f000de3d9d8> #<Tag:0x00007f000de3d820> #<Tag:0x00007f000de3d640>

#1

Hallo liebes Forum,

ich habe seit heute ein Problem mit meinen Kameras, das ich nicht in den Griff bekomme;
ich habe alle Guides die ich durch die SuFu gefunden habe durchforstet und abgearbeitet - ohne Erfolg.

Ich habe gestern FP Open OS installiert, mit micro GAPPS und allem drum und dran. Hat alles tadellos funktioniert, bis vor einer Stunde, als ich Whatsapp Web verwenden wollte und plötzlich die Meldung

aufgetaucht ist.
Die Meldung taucht bei der Front- und bei der Rückkamera auf! Die Taschenlampe funktioniert aber, genau so wie die Kalibrierung des Näherungssensors und der Lautsprecher vorne zum telefonieren am Ohr.

Ich habe nun folgendes schon versucht:

  • Alle Kamera-relevanten Apps deinstalliert
  • andere Kamera-apps ausprobiert
  • Cache gewiped
  • auseinandergebaut, Kontakte des Fairphones und der einzelnen Module gereinigt- und wieder zusammengebaut ausprobiert
  • alte Kameramodule (V1) eingesetzt (selbe Probleme)
  • abgesicherten Modus, tock camera App ausprobiert

Da es auch im abgesicherten Modus nicht funktioniert, verstehe ich nicht wo von Seiten der Software das Problem kommen könnte. Es hat ja zu Anfang auch mit GAPPS funktioniert.

Es ist, so nebenbei, schon das 2. Hauptkameramodul und das 3. Top-Modul das mir ohne nachvollziehbare Gründe kaputt geht.

Andere Probleme die ich zusätzlich schildern möchte, um vielleicht einen Zusammenhabg zu schaffen:

ich habe FP Open installiert, weil mein Fairphone oft extrem heiß wird und abstürzt oder generell häufig rebooted - durch das alternative Betriebssystem kriege ich zumindest diese Problem besser in den Griff. Ich war zwischenzeitlich wieder auf das Stock Rom umgestiegen, weil ich micro GAPPs nicht vollständig funktionell einrichten konnte - das funktioniert jetzt dafür.

Außerdem ließt mein FP2 mittlerweile KEINE SD Karten mehr (Fat32 formatiert, Kontakte ebenfalls gereinigt, an jedem PC funktionieren die Karten, es sind SDHC und SDXC Karten von Lexar und San Disk die eigentlich funktionieren sollten).

Ich vermute das mein Core Modul von Anfang an einen oder mehrere Defekte hatte. Leider möchte es der Support nicht für mich tauschen, und aus Angst das es die Fehler nicht behebt möchte ich ehrlich gesagt keine 280€ mehr investieren. Dafür habe ich schon zuviel Schweiß und Wut an diesem Gerät ausgeschüttet…

Danke für eure Hilfe und entschuldigt die riesen Menge an Problemen die es hier zu bewerkstelligen gibt.


#2

Dann wird es natürlich schwierig, überhaupt noch irgendwas zu empfehlen.
Vielleicht hast Du dies noch nicht gesehen:

Vorher würde ich aber noch etwas abwarten, bis sich hier Kundigere als ich vielleicht noch zu Wort melden.


#3

Erscheint die Meldung nur bei Whatsapp bzw. bei bestimmten Apps? Funktioniert die Kamera-App? Möglicherweise ist es einfach ein Problem mit den Zugriffsrechten auf die Kamera.

Ich nutze selber LineageOS, aber vielleicht gibt es auch beim FP Open OS einen Bereich mit Einstellungen, die den Datenschutz betreffen (damit meine ich nicht die normalen App-Einstellungen, wo ebenfalls Rechte für den Kamerazugriff gesetzt werden können)?

Wenn in den Datenschutz-Einstellungen der Datenschutz für z.B. Whatsapp aktiviert ist und der Zugriff auf die Kamera dort verboten ist, wird der App vorgegaukelt, die Kamera stände gerade nicht zur Verfügung (auf die Art kann man Apps zufriedenstellen, die ohne Kamerazugriff nicht funktionieren, denen man den Zugriff
aber nicht erlauben möchte). Deine Fehlermeldung klingt nach so etwas.

Hast du die SD-Karten am Computer oder mit Android formatiert? Der Zugriff auf SD-Karten funktioniert am besten, wenn die SD-Karte von Android formatiert wurde (vorher die Daten auf der Karte sichern!).


#4

Auf diese Art und Weise habe ich am Sonntag FP Open OS installiert. Die Reboots sind ja beispielsweise seit dem nicht mehr aufgetreten - immerhin!

Ich warte jetzt noch etwas ab, ob vielleicht jemand eine andere Idee hat. Ansonsten probiere ich das eben noch einmal.


#5

Das habe ich ja bereits oben beschrieben, das Problem tritt nicht nur in WhatsApp auf, sondern mit jedem Programm das die Kamera aufrufen möchte. WhatsApp gibt zum Beispiel die Fehlermeldung “Kamera kann nicht gestartet werden., bitte starte dein Telefon neu” aus - was ich selbstverständlich bereits probiert habe. Ich habe auch versucht die Rechte zur Kameranutzung umzuverteilen, überall auszuschalten außer in der Kameraanwendung und wie gesagt ja auch alle Caches gelöscht und die Prozesse zum Beenden gezwungen - kein Erfolg.

//

Die SD Karten kann ich gar nicht im Fairphone formatieren, weil es keine Anstalten macht überhaupt zu erkennen das eine eingelegt ist. Sie (die Karten) sind zumindest am Computer in FAT32 formatiert worden.


#6

Noch zwei Nachfragen, auch wenn es für dich vielleicht wenig hilft.

Von wann ist die Hausnummer 280€ für das Core-Modul? Ich frage, weil ja (irgendwann heute wieder) komplette refurbished FP2 nun für gerade 299€ verkauft werden. Oder war in den 280€ noch ein Wust an Zusatzkosten (Versand/Versicherung/Arbeitslohn) drin?

Und auch wenn das Core-Modul offensichtlich der “Hauptverdächtige” ist: Hast Du die kleinen Module mit den beiden Kameras schon in einem anderen FP2 testen können? Das sollte in deiner Gegend (Fairphone-Angel in Köln, Fairphone-Treffen letztes Jahr in Bonn) gut möglich sein.


#7

Das mit dem Core-Modul vergessen wir lieber gleich wieder - habe es gestern noch auf Vireo für 275€ gesehen, heute ist es nicht mehr verfügbar. Entweder habe ich das geträumt, oder jemand hat es hier gelesen :joy: - jetzt findet man es gar nicht mehr … Ob da Versand etc. inbegriffen war, kann ich nicht sagen, aber ich vermute mal eher nicht.

Ja, die Module funktionieren im Fairphone meiner Freundin - auch gestern getestet… Jetzt hoffe ich auf mal auf kulante Hilfe durch den Support :pray: !


#8

Mir gehen langsam die Ideen aus, auch da ich selber das FP Open OS nicht installiert habe. Und die folgenden Ideen hast du vielleicht auch schon probiert:

  • Hast du mal das FP2 auf Werkseinstellungen zurückgesetzt, nachdem das Problem aufgetreten ist, oder alternativ einen neuen Nutzer eingerichtet? Und dann, ohne etwas an den Einstellungen zu ändern oder neue Apps zu installieren, direkt mal die Kamera-App gestartet? Funktioniert das noch?
  • Werden die SD-Karten im FP2 deiner Freundin erkannt (oder einem anderen Android-Smartphone)? Falls in ihrem FP2 schon eine SD-Karte steckt, die nicht entfernt werden soll, könnte man dafür auch ein OTG-Kabel zusammen mit einem SD-Kartenleser verwenden.