Loudspeakers are enabled by default when using WhatsApp

Hi there !

I’ve a Fairphone 5 and WhatsApp (version 2.23.20.76) installed on it.
When calling or receiving calls with WhatsApp, loudspeakers are enabled by default. Is there a configuration to change this behavior, or is it a bug from Fairphone / WhatsApp ?

Thanks,
Jean-Baptiste

4 Likes

Same here, It honestly is becoming annoying when I get my ear blasted on a loudspeaker

2 Likes

Same here, has there been a fix yet?

2 Likes

I noticed the same issue today!

2 Likes

Also have this issue. Becoming quite annoying. If I make a call, the loudspeaker will be enabled automatically irrespective of whether it was turned off previously. If I turn off the loudspeaker while it is ringing, it is again enabled when the call is answered.

It looks like there are some other apps which seem to have a “preference” for loudspeaker instead of the normal in-call speaker also - in a way that I don’t see on other android devices. Microsoft Teams is one example.

I would suspect there is some problem with which audio output is seen as “default” at the OS level?

1 Like

I just made a first WA call (outgoing) with the FP5 and I had to enable Loudspeaker manually.

You are one of the lucky ones then :slightly_smiling_face:

If it helps, here’s more info:

  • Whatsapp is Version 2.24.2.76. I keep it up to date.
  • I have two “accounts” in whatsapp corresponding to two numbers, one from a nanosim, the other an esim. I switch between these manually. It happens for both.
  • The OS build number is FP5.TT45.A.141.20240115
  • Disable USB Audio routing is not enabled in Developer Options.
  • The developer options are present in the menu. This issue was present before I enabled developer mode.
  • The issue has persisted through multiple software updates.
  • This does not happen for “normal” phone network calls.
  • I often use a USB-C 3.5mm headphone adapter for listening to audio. This has an inline charger. Naturally, this is usually plugged out when making/taking calls. Nonetheless, I mention it since it is audio related and there is a small possibility that it could perhaps affect audio configuration by having been present at any stage.

Interested in any of these details from anyone else to see if we can narrow things down.

There is also the possibility of a flaw in whatsapp to consider, though the fact that Teams also defaults to speaker makes me suspect not.

1 Like

Do you have the Google App activated? I have most Google stuff deactivated.

Google Apps are running as per default. Haven’t messed around with Google Play Services or anything like that. Using Gmail, Drive and a few others. Nothing out of the ordinary I can think of regarding anything Google.

The Google App interfered with the mic on some FP4 therefore…

Have disabled the google app and it still happens. Also have noticed the speaker volume is not controllable on whatsapp - changing it makes no difference.

I am having this problem too and know idea what to do - did anyone have any luck?

My wife with a Samsung galaxy s24 sometimes gets that problems too. I guess it’s a WhatsApp Bug. I did got same Problem on my moto g100. Same as on my FP5.

so, is there no solution? I got the same issue

So I’m in an email exchange with Fairphone on this, these are the steps they asked me to do to test:

Step 1: Update

Make sure to update to the latest software: Fairphone OS v.144 (Build number FP5.TT46.A.144 )

The release of some updates may be delayed by up to a few weeks. This depends on your country and phone carrier.


Step 2: Disable 4G Calling and Wi-Fi Calling

Fairphone 5 is technically capable of using 4G Calling and Wi-Fi Calling, also known as VoLTE and VoWi-Fi. However, we might still need to complete the partnerships with your phone carrier. To exclude this as a possible root cause, please try the following:

  1. Go to SettingsNetwork & internet → Mobile network → (Optional) Advanced.
  2. If 4G Calling (VoLTE) or Wi-Fi Calling (VoWi-Fi) are listed in your options, disable them and retry.
  • These settings may be named differently or hidden, depending on your phone carrier. If they are hidden for you, switch the “Preferred network type” setting to 2G or 3G.

Step 3: Service test

  1. Open the Phone app.

  2. Dial ##2886##** in the same way you enter a phone number to make a phone call. Once the last character is introduced, the Service Menu appears (be patient, this can take a few seconds).

  3. Select Manu.

  4. Tap on Audio. This test covers all audio components. The first three tests are for the receiver and the speakers. You need to select PASS for them to be able to continue to the microphone tests.

  5. Then you’ll reach the three tests for the three microphones. To do the tests, tap or move your finger over the hole of the tested microphone. You should be able to hear the result through the receiver/speakers.
    It’s best to run these tests without a case on the phone. The microphones look like small holes in the frame of the phone and are located in the following places:

  6. mic 1 is on the bottom of your Fairphone 5, to the left of the USB port when the screen is facing you.

  7. mic 2 is on the top of your Fairphone 5, on the top right of the phone when the screen in facing you.

  8. mic 3 is on the left side of the phone, opposite the power button/fingerprint sensor. It is most often used for loudspeaker and video calls.

  9. Let me know the results from all the microphone tests. If one of them fails, you’ll still need to select PASS to go to the next test.


Step 4: Test with a Bluetooth or wired headset

Test if using an external microphone resolves the issue. You can test with a wired headset and/or a Bluetooth one.

Once done with this step, you won’t need the headphones for troubleshooting again.


Step 5: Safe mode

Reboot your phone in Safe mode and repeat the service tests from Step 3.

In Safe Mode, downloaded apps are temporarily disabled to help you identify the cause of an issue. In our article on Safe Mode, go through the steps and make sure to read the Important notes. You can easily exit Safe Mode by restarting the phone.


Step 6: Additional information

  • Share the results from the service tests.
  • Did anything change while performing the troubleshooting steps above?
  • Are you experiencing the issue in every condition or during a specific one only (regular calling, speaker calls, recording videos or audios, data calls with some apps…)?
  • Is there anything else you’d like to share about the troubleshooting steps?
  • Also, if not specified already, please share which network provider(s) you use, and the country where you are experiencing the issue.

So my phone has the latest update and WiFi calls is off.

In the service test it was all fine - I also checked the proximity sensor and its fine. It was also fine in safe mode.

In normal call on whatsapp with no bluetooth connected it goes automatically to loudspeaker both for outgoing and incoming calls. I can manually put it to non-loudspeaker.

With bluetooth headphones connected, the problem goes away and it auto-answers on bluetooth. But with only a bluetooth speaker, the phone keeps switching between loudspeaker and the speaker and doesn’t settle.

Its quite annoying as if I’m outside, the phone is auto-answering in loudspeaker and takes a few seconds for me to manually switch to non-loudspeaker and takes a few more seconds to adjust.

Interestingly, Microsoft Teams has the exact same issue - answering in loudspeaker; struggling with a bluetooth speaker to work at all, and working fine with bluetooth headphones.

I have the exact same problem on my Fairphone 5.

Loudspeaker is automatically enabled by default when making or receiving (WhatsApp) calls. It takes me a couple of seconds to disable the loudspeaker after it automatically enables itself again.

I am on the latest Fairphone 5 and WhatsApp updates. I hope this can be fixed as it looks very unprofessional (and it’s simply really annoying) that I constantly have to tell my customers to wait as I am trying to take them off speaker.

I have also factory reset the phone and this didn’t fix the problem.

Same situation here, it has been annoying me ever since I took use of the FP5.
Had an (updated) FP3 running on Android 13 before and did not have the issue.

As far as I can tell this behavior is the same when calling via the Conversations messenger app. So with the issue being observed in WA, Teams and Conversations it pretty much looks like it is in Fairphone’s responsibility…

Finally tried to replicate this and can’t confirm it. WhatsApp on my FP5 doesn’t start incoming (audio-only) calls on speaker but on the ear piece, as it’s supposed to.

Did you try reinstalling WhatsApp?