🇩🇪 🇬🇧 LOS Installation

Hallo zusammen!

Ich bin dabei Lineage OS auf dem Fairphone 3+ zu installieren. Ich habe mich an die Installationsanweisung von Lineage gehalten (Install LineageOS on FP3 | LineageOS Wiki).

Nur leider funktioniert die Kommunikation zwischen PC und Handy nicht. Obwohl ich eigentlich alle Schritte befolgt habe: den universal adb driver am pc installieren, usb debbuging aktivieren, oem unlock am Handy.

Was nicht funktioniert hat:
“Setting up adb:
6. On the computer, open up a terminal/command prompt and type adb devices.
7. A dialog should show on your device, asking you to allow usb debugging. Check “always allow”, and choose “OK”.”
→ Wenn ich in der Eingabeaufforderung am PC “adb devices” eingebe, öffnet sich kein Dialogfeld am Handy.

Und wenn ich mein Handy in den fastboot mode bringe, steht im fastboot mode u.a. “device status - locked”.

Kann mir bitte wer weiterhelfen?
LG Clara

Hello everyone!

I am in the process of installing Lineage OS on the Fairphone 3+. I followed the installation instructions from Lineage (Install LineageOS on FP3 | LineageOS Wiki).

Unfortunately, the communication between the PC and the phone does not work. Although I actually followed all steps: install the universal adb driver on the pc, enable usb debbugging, oem unlock on the phone.

What didn’t work:
“Setting up adb:
6. on the computer, open up a terminal/command prompt and type adb devices.
7. a dialogue should show on your device, asking you to allow usb debugging. Check “always allow”, and choose “OK”.”
→ When I type “adb devices” in the prompt on the PC, no dialogue box opens on the phone.

And when I put my phone into fastboot mode, one of the messages in fastboot mode is “device status - locked”.

Can someone please help me?
LG Clara

1 Like

Are you sure you’re using a data cable and not just a charging cable? Quick way to check is to see if the phone shows up in your PC’s file system when connected.

1 Like

Thank you for your answer.
“FP3” appears under “this PC” in Explorer.

I have now followed these instructions ✏ FP3/FP3+: Complete guide for installing LineageOS
I made it to the recovery. In Recovery I clicked on Factory Reset and then format data/factory reset. Then Apply update and then apply from adb.
I then entered adb sideload lineage-18.1-20211004-nightly-PF3-signed.zip in the Minimal ADB and Fastboot window/terminal.
Now everything works. The terminal says: adb: failed to stat file lineage-18.1-20211004-nightly-PF3-signed.zip: No such file or directory.
And nothing happens.
The mobile says:
Version 18.1 (20211004)
Active slot: b

ADB Sideload

This means, the adb command can not find the file in the directory you’re currently running it from. Assuming you’re trying this on Windows: You can change the directory (e.g. “cd c:\path\to\download\folder”) and run adb from there, or enter the complete path (“adb sideload c:\path\to\folder\lineage-18.1-20211004-nightly-PF3-signed.zip”). If the file indeed is in the folder you’re running adb from, there’s probably a typo in the filename.

Ok, thanks for the suggestion.
And how can I change the directory (e.g. “cd c:\path\to\download\folder”)?

First, find out where your .zip file is located. Then, change to that directory using the cd command.
For example, if the file is in C:\Users\xyz\Downloads\ , just type

cd C:\Users\xyz\Downloads\

Afterwards, run the adb command directly from there.

ok. I saw that I made a mistake: I wrote PF3 instead of FP3.

Now it has worked. However, the terminal does not say “adb: failed to read command: Success” according to the instructions.

But rather: Total xfer: 1.00x

Should I still do the last step: reboot your FP3:

main menu → Reboot system now?

Well, if it doesn’t work after reboot, you can always get back to recovery and/or fastboot to try again, so why not :wink:

Ok, i did it and now it says

this is not the original from my device but it says the same than on this photo…

As you’ve done a factory reset already before installation, doing another one won’t hurt, but probably also won’t help.
I’d just try again with sideloading the zip file, with a bit of luck it’ll work this time :slight_smile:

It has now worked! I am so happy!
I chose “try again” and then it went into the lineage operating system by itself.
Thanks a lot for your help and the great tips!
All the best, Clara


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.