Login not possible (Fairphone Site)

I simply cannot log into my account in the shop.

I have already tried with Firefox and Edge. Normal and in private mode without extensions.

Are you aware that the login of the shop isn’t the same as the login of the forum?

1 Like

yes I am aware that it is not the same.

1 Like

I’m wondering what exactly happens.
Is this using a Windows PC?
Did you have the password saved in, say, Firefox?

Have you cleared the cache in the browsers?

Yes Cache cleared.

I do not save passwords in browser.

After entering the login data, I return to the page with the input fields. Nothing more happens.

So there is no indication you have the wrong password?

It sounds like cookies are not enabled.

That this happens on two browsers is another query.

Is it too much trouble to try and set up a dummy account/

Even if the password was wrong (it’s not), at least the password reset should work, but I tried that too and had the same problem:

Back to the input field without error message.

A family member also has the same problem and cannot log in to the shop.

Cookies are stored.

Same problem yesterday for me.

And I made an order with the same pc / browser last Thursday…

Same problem here, loggin in with correct email/password but then either a blank form appears or this error message:

“Something went wrong with reCAPTCHA. Please contact the store owner.”

But there is no reCAPTHA to solve.

Tried it with latest Firefox and edge.

Same here.

Same here for Chromium and Firefox on Linux as well as Firefox on Windows…

Well I can confirm

a) My account just recycles the login request
b) I did mange to create a dummy account
c) But after logging out I cannot login with the dummy account


Just emailed support and referenced this topic.


I hope this will be fixed soon, because I actually wanted to order some things from the shop.

You can order by phone or email maybe. Plus as I mentioned, if urgent you can create a .new’ account and buy before you log out, that may work :slight_smile:

Anyone tried to order without an account?

1 Like

The same thing happened to me with a certain log-in at Chip.de. I was able to click on the images in the reCAPTCHA, but was then referred back to the login page when confirming. The “solution” was an email to Chip.de, who emailed me the code I wanted. (Windows 10 / Firefox). Can this perhaps be due to a Windows update???

Hi everyone,

Thanks so much for flagging this! It was also flagged through our customer support team and it has been fixed this morning. Apologies for the inconvenience and confusion caused. Should now be up and running! :slight_smile:


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.