English

Living without Google 2.0 - A Google free FP2

livingwogoogle
Tags: #<Tag:0x00007f9ffbfe1d00>

#406

Thanks a lot !
Another very simple solution would be to synchronise with IMAP as you said, and once in a while to delete my emails directly at the server level, when I can see there is a lack of space… Right?


#407

Exactly this was meant with my sentence “move your e-mails away from the server, into a local-only archive folder”.


#408

OK, thank you Tofra ! :relaxed:


#409

By the way, anyone here who would be happy to send me an invite for opening an account on riseup.net?
I’ve been looking for this but it is quite difficult to find…
Thank you in advance !


#410

Yes me too! @Leti974 if you manage to get invited would you be so kind and pass it forward to me?

On a different note I also have a question regarding e-mails. I switched to FP Open OS and found that in general most apps I use/need work flawlessly without google services. Some don’t send push notifications anymore, but that’s also ok cause it means I end up checking them when I want to and not when they want me to :wink: The only Gapp I’m really missing is google maps, I just can’t take the same use out of OsmAnd~, but maybe I still just need to get used to it. I also can use gmaps on the browser if I really need to.

But back to mails, I tried using K-9 for a while but I really don’t like it. The layout is confusing, I missed a couple important e-mails, and from a personal level I’d like to change it. I am using the outlook app at the moment as I have an outlook account, but I wanted to ask two things:

1 - Isn’t it the same, in the end, to have a microsoft proprietary app on my phone than a google one? Is Microsoft known for collecting user data as much as google?

2 - Is there any other free and good e-mail client except for K9?

Thank you in advance for your replies :slight_smile:


#411

Hi,
Have you tried the AOSP email client (= the stock android app that comes with open OS)? I use both K-9 and the AOSP app for 2 different email addesses and I must say that I find the AOSP simpler and easier to use (for a standard use, I am sure that it has limitations that explain why many users prefer K-9).


#412

What are you missing or trying to do? Perhaps we can help …


#413

If you could elaborate what confuses you, I’d be willing to help. Personally I love K-9 because it has nearly all features of a true desktop email client.

And if you want to know what Microsoft does with your emails, check their terms of service.


#414

Google Maps works pretty well in the browser, if that helps.

Yes, I would say so.

Not one I know of, sadly.


#415

@AnotherElk, @StephanK and @ben thank you so much for your replies. So here the points:

OsmAnd: It takes a really long time to load the map if I move city or even neighbourhood, I cannot enter a street AND a number for an address, it only lets me choose a crossroads on that street (which I don’t necessarily know most of the times), and when looking for something that isn’t a precise address (such as a restaurant, or a touristic site) it often doesn’t find it and gives me completely unrelated results (e.g. a bar with the same name but 300 km away). I just find it slow and difficult to use in general, and find myself needing to use google maps on the browser more often than not.

K-9 Mail: I actually took some time to explore and try the many different settings and I think I managed to change most of the settings I was unsatisfied with. I’ll use it with the new settings for a while, maybe I solved the issue.

Thank you guys a lot again for your availability to help :slight_smile:


#416

Indeed, OSMAnd is relatively slow. Maybe because it runs completely locally and has to churn through huge maps - the full data sets of OSM. I can understand your problem with house numbers, although this was better in earlier versions, I think. It won’t become any better performance wise, I guess.


#417

I only experience this since I moved my downloaded offline maps to the SD card, since the SD card is considerably slower than internal memory apparently. But perhaps my perception of slow is different, I’m pretty patient :slight_smile:

You could try whether online maps work better for you. Using them OsmAnd only has to display some picture tiles instead of rendering all this vector stuff from the map files. Catch is, of course, this needs internet access, the faster the better:
Configure map - Map source - Enable Online maps - Settings (just appeared) - Enable "Use Internet"
Configure map - Map source - OsmAnd (online tiles)

A thing to tweak for offline map performance are the details:
Configure map - Details - Disable everything
Configure map - Hide - Enable some stuff to really simplify the map (But who wants that :slight_smile: ?)

Yeah, OsmAnd search seems not to work as conveniently as Google, I was puzzled by that, too. From my point of view there are two factors at play here:

  1. The map data OsmAnd uses doesn’t include all the house numbers it seems.
    Google’s data also doesn’t include all of them, of course, especially in the countryside, but it is better than OsmAnd currently, no way around that.
    Anyway, OsmAnd can’t find what isn’t in its data. Doesn’t help especially if you are used to Google Maps and enter the street complete with the house number already everytime (I tend to do that, too :slight_smile: ).
    In OsmAnd, just enter the street and wait for OsmAnd to find it and give it to you in the results list, then tap on it, and you get the list of numbers OsmAnd knows for this street.

  2. The developers messed up the default search feature. In older versions of OsmAnd you got the incremental search you still get with e.g. Directions - From - Address, but the developers obviously decided to be much more clever than every user who loved that simply working and useful approach. Now you can enter anything in the same search field and just hope for the best …
    The good news: You can still access the incremental search feature, even if this needs a few more taps … Dashboard - Scroll down to History - Show all (right beside “History”) - Address


Fairphone Open 18.01.1 is now available
:de: Wieso ist Navigation rechenintensiv?
Using LineageOS on the FP2
#418

Wow, that’s a lot of info, thank you so much :slight_smile:

So I changed the settings like you said, I hope it will improve my user experience. I also kind of want to be able to live without google maps so I’ll definitely try every possible alternative.

Throughout this thread I’ve seen many mentions of the microG project, which, and I’m not sure I understood it well, is a “fake” version of google apps that can be switched on and off as needed? Is it a whole google apps package that comes at once or is it possible to get, say, a microG maps? And does it have any privacy issues as the official google apps have?

I’m asking this because I started running lately (impressive, I know :wink:) and I found an amazing app to track my runs, distance, time, elevation, etc. The problem is it won’t work in a reliable way without google maps. Would it be possible to have this microG thing and use it only when I go running? Would it possibly “trick” my running app into thinking I do have google maps?

Thank you again so much for helping me out, I’m getting more and more on board with this google-free idea and with knowing my phone better, and that’s mostly thanks to people like you here in the forum who are willing to take some time and help out a noob :grinning:


#419

OSMAnd can track your movement with the GPX extension - either locally or to an online resource. I use it with my hiking trips on holidays.

In OSMAnd you can optionally only load pure street maps which may reduce loading times drastically.


#420

Interestingly, following user demand they added “Address” back to the normal search from version 2.6 up, so you can start your search with the city or a zip code, then easily select the street, then the number … now that’s better.

I just now realized my F-Droid was somehow broken and didn’t tell me about new versions although it was configured to do this, I was still using OsmAnd 2.5, currently they are at 2.7 :slight_smile:

Some more info about 2.6 search changes


Fairphone Open 18.01.1 is now available
Using LineageOS on the FP2
#421

I noticed on a net monitor that Firefox Klar connects with ***.deploy.akamaitechnologies.com and ***.deploy.static.akamaitechnologies.com. Firefox says this browser is build for privacy, but it doesn’t to seem like it…

Am I right about that?

p.s. FK also connected with another server: ams15***something***100.net.

And it looks like Afwall+ cant’t prevent com.android.system ( UID 0 ) calling ‘home’. Just a few minutes ago it made a connection to 84.241.226.140. Although I dont’ know if that’s Google…


#422

Not in the source code, but it could be a dependency, although it would be rare. Most probably is some third-party component on a regular web page you visited, and not Firefox Klar itself. Most matches of *.deploy.akamaitechnologies.com I find online let me guess that it’s a CDN —a Content Delivery Network, a network of quick and distributed around the globe servers that web developers use to get web dependencies (pictures, CSS stylesheets or JS scripts) for their webpages. It’s not a privacy-respectful way to do to your users (if you are a webdev like me), but Firefox cannot block CDNs because it would break the whole Web.

Edit: Damn, remind me that the next time I should search on Wikipedia before randomly browse the Web for something: https://en.wikipedia.org/wiki/Akamai_Technologies


#423

Sounds like a nice open company though …

[quote]The National Security Agency and Federal Bureau of Investigation have reportedly used Facebook’s Akamai content delivery network (CDN) to collect information on Facebook users.[83]

According to researchers from the Universities of Cambridge and California-Berkeley, University College London, and International Computer Science Institute-Berkeley, Akamai has been blocking access to web sites for visitors using Tor.[/quote]


#424

@Roboe Tnx :slight_smile: . You’re right. I found out that it’s just 'cause of the website one visites. Some other websites give the same results.

Does anybody know how to prevent com.android.system (UID 0 ) to call home? I saw that it also makes connection to 8.8.8.8 (Google DNS).

  1. Is this only possible with XPrivacy or is there another way? Privay Guard doesn’t seem to give a solution.
  2. If Xprivacy (yes, I flashed it again…). Does anyone know which UID I have to block and in what way? There is no possibility to block com.android.system (UID 0) in xprivacy.

ps. I’m on Lineage OS. Maybe this is just a problem on LOS, but possibly it is also relevant for FPOS-users.


#425

I know this post is quite old but I installed RadioDroid the other day and it seems to be playing, but I get no sound. Anything specific that I should look for, e.g. in Settings? My phone is running FP Open Source, version 6.0.1 - planning to download the pending update today or tomorrow if I find the time.

Thank you!