English

Fairphone Open 18.01.1 is now available

Tags: #<Tag:0x00007f05dad60d58>

Another update that went smoothly and flawlessly. Thank you. :slight_smile:

3 Likes

Hey, regarding the reboot – this might be your battery unfortunately sitting a bit too loose in its compartment.

Try to squeeze some paper (that you folded some 1-3 times, depends) between the battery and the lower end of the battery compartment (i.e. at the “smallest side” of the battery, opposite of the el. contacts).
otherwise, look for the “random reboots” topic here on the forum!
good luck! :wink:

edit: that was quite off topic. please search the forum next time and if you do not find anything, open a new thread :slight_smile:

First, Thanks and great job with OpenOS !

update run smoothly but I get an error with GoogleServices App…and as you all known with this beloved F&&%%g :face_with_symbols_over_mouth: Google, when this one doesn’t work, some other apps are also crashing !

I tried reinstalling apk from Google but ain’t working neither…(in fact which version should I take ? so many versions :flushed: )
or what s the best way to reinstall Google ?

http://opengapps.org/

For Fairphone Open OS currently: ARM - 6.0 - (package of your choice).
Simply install the downloaded ZIP via the TWRP recovery of Fairphone Open OS.

2 Likes

Thanks ! Works fine ! :grinning:

just need to reinstall some stupid apps linked wih google (Youtube, L’Equipe, Strava)

I used the picoGapps…so let s try on step further on a Google free world, I’ll try to NOT to reinstall googleMaps and use OSM :nerd_face:

2 Likes

I came from mostly Google Maps, too … here and here are some hints regarding OsmAnd in the following topic …

Edit @Lidwien: first steps on FP Open

Hey. I also changed last weekend from FP OS to FP Open OS 18.01.1 by using the manual switcher. Everthing went fine… :slightly_smiling_face: :+1:

Know I have the issue that without amaze I can’t install any app. I read a lot of posts in the community but I couldn’t solve my problem. And I have to less knowledge about using adp, TWRP or something. :frowning_face: Here I am totally beginner.

Can someone give me a short introduction how to install i.e f-droid without using the internal browser to get amaze or an alternative file-manager (is there maybe a better one?)?

I also used threema before and will install it again too. I have the apk on my sd-card and also on my external pc (win 7). Also for that I didn’t find a way to install it on the FP2, the internal “light” file-manager did not install it. Up to now nothing worked.

Hope someone can help!

For the record: To take a screenshot in TWRP, just like in the OS press and hold Power + Volume Down for a moment.

TWRP will show a short white flash of the whole screen as confirmation it took the screenshot.

Screenshots are saved in the folder Pictures/Screenshots by default either on SD card or in Internal Storage (given availability of the folder Pictures/Screenshots, the folder might differ on encrypted phones before entering the encryption password).

Why? This is exactly what works.
Open https://f-droid.org in your browser, and you will be able to install F-Droid that way.
And then using F-Droid, you can install Amaze or whatever.

1 Like

First I would like to avoid the pre-installed apps. In some post I read the browser is also an security risk. I like the idea to change from the very beginning to open source applications. But if it’s the only/easiest way I will try it.

I guess, it should work as well, if you download the f-droid “.apk” to your computer and then copy it to the phone. Open the file with amaze and it will be installed.

Thank you! I tried again the other day and it did work, actually.

What I have noticed in the meantime: I tried to reformat my SDcard, once using TWRP, then through my computer (a Mac). Both times, it looked like it had worked, but when I reinserted the card, none of the contents had changed. My conclusion is that the card must be corrupt, and I should buy a new one. Does that make sense?

OTA update on encrypted phone went well. (Not sure though if the phone needed to boot twice, however in the end it doesn’t matter.)

1 Like

Thank you. It works like you recomended. Afterwards I changed some build in apps to open source, i.e. the browser to Firefox Klar.

Yes, it does. Sometimes, e.g. after a power fault, SD cards get corrupted and become “read-only”, which means it looks like you are writing to it fine, but when you plug it off and on again, it is back to the previous state before the writing.
You should buy a new one.

1 Like

Thanks! I did buy a new one, actually, and it worked!
Linda

1 Like

By the way, what do you mean with « a power fault »? That the phone shuts down by itself because the battery has reached 0%? Or would the random reboots Fairphones are so well-known for also qualify as power faults?

No, those behaviors do not qualify as power faults, it was just an example. I meant electronically, in a defective or poorly-designed device; for instance, this issue with SD cards is not that uncommon in the first versions of Raspberry Pi where USB is not correctly isolated and you often get shortcuts when you plug/unplug USB peripherals.
But it was just an example, it might not be your problem, unless it happens again; then, you’ll have reason to suspect a defect in your phone.

Hi there,
I upgraded to open 18.01.1 yesterday. Since then, impossible to get any wifi connections. The FP2 simply doesn’t see them it seems…

I’ll appreciate any advices :slight_smile:

The next update to 18-02-0 released.

2 Likes