English

Living without Google 2.0 - A Google free FP2

livingwogoogle
Tags: #<Tag:0x00007fa0000dd480>

#343

Or install microg (see first post) to get rid of this warning.
You don’t need any store at all, you can get the apps through apk mirror.
Microg will make the apps that “need google” believe that the play store and services are installed.


#344

Thanks. That was the information I am looking after. I do not think I will have many troubles installing those - but I would like to minimize the risk of finding out that those Apps do not work with OpenOS before trying to do it.
So I am still looking for any hint on somebody using or who tried using the MS-Outlook App and/or the Napster App on OpenOS.

Kind regards, mentos


#345

Some questions for Raccoon users:
I installed Raccoon and downloaded a few apk’s successfully. :slight_smile:
What I still haven’t understood: Raccoon doesn’t seem to have installed as an app on my Mac. Should I delete the .jar file and download it again whenever I need it?
And will I get updates to the apps I downloaded or do I have to download the latest version once in a while via Raccoon?


#346

And one for Safari users:
I created a google account on my mac using safari. How the h*** do I log out of the account? When I quit Safari and relaunch it, I seem to be logged out but is that the only way?


#347

And now, to MicroG: I tried to follow Living without Google 2.0 - A Google free FP2 to install what I need to run some apps downloaded via raccoon but it doesn’t seem to work. Among other things (I’ve lost track…), when I try to install GmsCore.apk from downloads, the process always ends with “X App not installed.”. Is there an idiot-friendly, step-by-step instruction to be found anywhere?


#348

You can do with the .jar what you like. The file is a Java ARchive, not an app. In principle you do not need to download it again and again. You can start it from the terminal command line: java -jar raccoon-3.7.jar
Or with the full path: java -jar /Users/yourname/Downloads/raccoon-3.7.jar
You will need to re-download already downloaded apps once in a while in order to upgrade them.


#349

The step by tep guide to install microg is linked in the first post.


#350

I’ve tried my best to understand (and eaten lots of chocolate to avoid discouragement) but I need to check a few things, please…

1-I’ve been reading about “flashing” things a lot and I’m not sure I understand the word. Finding an online definition is difficult because I always end up with explanations about Adobe Flash. Wiktionary tells me “(computing) To write to the memory of an updatable component such as a BIOS chip or games cartridge.” Could I also say “to transfer (by whatever means” a file to a device"?

2-Lots of posts on this forum say that to install xposed, you need to root your phone first. Is that still true or has it changed with xposed for Lollipop/Marshmallow?

3-I understand I need exposed to make microG believe I have a google account. I actually have one (that I created to use Raccoon). Does that mean I can skip the “xposed” bit (and the root bit - I still don’t think I should go that way!..) and go straight to microG?


#351

OK - that’s what I thought. But if I delete the .jar file and get a new one whenever I need it, it’ll work too, will it?


#352

Since I’m no developer or anything like that either, I can’t tell you exactly what it means, but for me - as a FP user - it usually means “installing through recovery mode”.

You need root rights for Xposed, but if you installed Open OS then “rooting” is super easy. Just go to settings > About and tap on the built number 10 times. Then go to settings > developer options and enable them and then scroll down and enable root.

The main purpose of microG is to trick apps to believe that Google Apps & Services are installed on your android device. Simply having a Google Account won’t do the trick.
To do what it does microg needs to make changes deep inside the system and therefore it needs root and xposed.
Enabling root is not a bad thing, but never allow root rights to any apps you don’t trust. In doubt it’s better to decline and then do some research on the app or ask on the forum. You can always allow root rights later.
I vouch for microg.


#353

OK! Would adding that to the forum dictionary make sense?


#354

I know - I have developer options enabled because I need USB debugging for some apps. But I’m afraid that if I root the phone, I’ll do stupid things…


#355

Are you saying that if the phone is rooted, I can still say that it’s rooted only for 1 or 2 apps (xposed and microG) and it will behave as if it wasn’t for anything else?

I was also wondering whether I should enable root only while I am installing that stuff - but that probably won’t work, will it?..


#356

Probably, but someone with better knowledge than me would have to do it.[quote=“Linda_CH, post:355, topic:11587”]
Are you saying that if the phone is rooted, I can still say that it’s rooted only for 1 or 2 apps (xposed and microG) and it will behave as if it wasn’t for anything else?
[/quote]

Yes, pretty much. If you enable root you still have to allow root to the apps that need it, if you decline they won’t be able to use root. There are two buts:

  • some apps (e.g. banking apps) can detect root on your device and can refuse to work “out of security reasons”. On the other hand it’s not secure to bank on your phone anyway.
  • If you open attachments of mails from strangers or visit shady internet sites you may involuntarily download malware which can use root to do very bad things on your phone. On the other hand these apps can often get root rights even if the phone wasn’t rooted.

I’m not 100% sure, but I guess xposed and microg will need root rights constantly. But you could try.


#357

Yes. It will work the moment you have a new file.


#358

A post was merged into an existing topic: :pencil2: Fairphone Forum Dictionary


#360

Bricked” existst in the dictionary, but it may need some elaboration.


#363

No Voice Guidance in the navigation tool of OSMAnd.

Until now, I haven’t found a way to make the voice work in navigation of OSMAnd. I have disables all google-services. Until today I haven’t looked into it much, but it seems, no TTS (Text to Speach) module was enabled (toegankelijkheid - uitvoor voor tekst-naar-spraak / accessability - output for text to speech). Could it be that this was disabled due to the disabling of google-services?

The F-droid app ‘espeak tts’ does not seem to work…

Any thoughts on how to fix this?


#364

Yes, TTS is a service included in some Google app


#365

On FP Open OS voice navigation with OSMand works flawlessly. I hope that’s not a hidden Goolge Service?! :confused: