English

Lineage OS and Yalp not working

Since updating LOS to LOS + microG I have a problem, that the Yalp store does not get an internet connection anymore. I have disabled all the microG services and checked my firewall. If I open Yalp it wants me to choose a fake or google account to login. I choose fake - it tries to authenticate, then the info “No network connection”.
I have also deleted all Yalp data and cache. No difference.

Do you have any ideas?

It’s been mentioned elsewhere (can’t find link), that this is going on:

5 Likes

Thank you for the hin. I installed Yalp version 0.35 and it’s working now.
Well ok. Yalp found the updates, but downloading is failing. Will try again tomorrow.

1 Like

A 0.41 version that fix this issue should arrive soon.

3 Likes

Had the same problem. Somehow my Fdroid didnt find the new 0.41 version. But you can get the apk here: https://github.com/yeriomin/YalpStore/releases/tag/0.41

Thank you. I downloaded version 0.41. I can now logon and get the updates, but the download does not work…

The download of updates? This worked for me.
Or the download of new apps? This I didn’t try out.

Both. 20 chars or it won’t post.

Did you uninstall yalp before installing the new version? Thats the only idea i have… as for me it is working

I had the same issue.
Removing Yalp and installing from github worked for me.
I wonder if fdroid will now update Yalp, or if I need to remove and install from fdroid again…?

2 Likes

You’ll need to remove and update from F-Droid because APKs will have mismatching signatures (Android security model behaviour to avoid one developer impersonating another).

2 Likes

Yalp 0.41 is now available for Installation in F-Droid.

1 Like

Same here. It worked for me after enabling ⋮ → SettingsDownload to internal storage (which IMO should be the default, optionally exporting whatever APK you want to preserve in the storage).

Hello,
thank you all for your advice. Here is the solution.

  • I installed the latestes Yalp version (thanks @LeonL)
  • Checked my data security (I had internal storage allowed, but thanks @Roboe)

The download still not worked… it hat some sort of https error. So I turned off my Firewall and it worked.

  • I then enabled the service “[10009] Medienspeicher, Download-Manager, Downloads, MTP-Host” it the firewall. Then it worked.

Thanks again @all for your help!

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.