Lineage OS 14.1 proximity sensor bug (wakelock) - do old modem files work?

I installed Lineage OS 14.1 on my completely wiped FP2 yesterday. I followed the instructions that included flashing fairly new modem files. However, the “proximity sensor drains battery” bug seems to be back: I notice a CPU wakelock that drains the battery quickly when apps like “WaveUp” that use the proximity sensor are active. Has anyone tried to flash the “old” modem files that solved the problem under FPOpenOS, or are they not compatible with Lineage OS ?

1 Like

Try the new modem files:

They don’t work. My phones battery was completely flat this morning :frowning:

You can try the oldest modem files that are available here:

Maybe these will fix the drain. No idea if anything else will stop working. Just put the newest one on your SD-card as well so you can revert back easily.

1 Like

Hurray, the annoying battery drain / wake lock is gone after I upgraded my FP2 to the official Lineage OS build and modem-17.09.03.
I am using WaveUp again and everything works like a charm without draining the battery.

1 Like

This topic was automatically closed after 183 days. New replies are no longer allowed.