Lineage + GApps: A real updated install guide for DUMMIES (Mac / Terminal)

I’ve seen a conversation about installing lineage called for dummies, but that really isn’t directed at dummies. Consider me a dummie. Due to two consecutive malfunctioning FP2 phones (random reboot issue), I’d like to try my luck with an alternative OS before going through the hassle of the return procedure again.

So please, provide me with a step by step list of installing Lineage. Some pointers:

  • I have Homebrew installed and I’d like to use Terminal.
  • I want to install GApps (but which one - this is where I got stuck)
  • I don’t know what version Lineage OS to install (13.0 or 14.1?)

Thanks in advance, I hope to do this this weekend.

I think the official LineageOS documentation is pretty good.

First follow

Install version 14.1 and for that take the Gapps from here: (keep platfrom “ARM”).

Which variant to take I think is beyond the scope of an install guide for dummies. It’s your decision and depends on what you want/need. Here is a comparison:


ok, first part worked (installing Fastboot and ADB) - but with some caveats:

  • when ‘fastboot devices’ doesn’t return anything, type ‘adb reboot bootloader’ -
  • the ~/.bash_profile needs to be created - quite easy check the link below
  • the FP2 didn’t go into recovery with the provided combo (Power button + Volume up), so I used adb for that: and that didn’t work either. But I found a solution online, see the third link.
  • Then in the recovery mode menu it appeared that the menu items did not correspond with the ones described in the lineage installation guide, I think I did the right thing by first wiping cache and then wipe/factory reset but then when I wanted to update via sd card (one of the menu options) it said ‘Couldn’t mount sd card’ → I later found out there was no SD card in the Fairphone
  • so I tried the other option ‘Apply update from ADB’ and this seemed to work via ‘adb sideload…’ and then aborted with a ‘failed to verify whole-file signature’ error.
  • Because I already did a Factory reset, I needed to enter Google details to get into the phone (and give adb access again) to try again with an SD card inserted. But by now it’s past midnight and I don’t feel like that. I may continue this quest tomorrow.

To be updated…

Links: (fastboot devices issue) (creating bash_profile) (fixing recovery screen)

  • fastboot works when phone sits on bootloader prompt (screen is empty), while adb works only when phone is booted up.
  • any .profile is just for your comfort and usually contains settings different to the system default. Otherwise system default is loaded. You can even enter it there, when you’re the only user of the system (I still would not recommend to do it). But you have created your .profile now, so you can proceed here.

Good luck for you tomorrow :slight_smile:

thanks! Will update this post when I’ve done it (and if it solves the
problem of random reboots)

Update here. Thanks to the great work by Fairphone developers, the problem of random reboots is completely gone with the latest update. So no need for an alternative OS anymore.

This topic was automatically closed after 183 days. New replies are no longer allowed.